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Legal information
Warning notice system

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent 
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert 
symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are 
graded according to the degree of danger.

DANGER
indicates that death or severe personal injury will result if proper precautions are not taken.

WARNING
indicates that death or severe personal injury may result if proper precautions are not taken.

CAUTION
indicates that minor personal injury can result if proper precautions are not taken.

NOTICE
indicates that property damage can result if proper precautions are not taken.
If more than one degree of danger is present, the warning notice representing the highest degree of danger will be 
used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to property 
damage.

Qualified Personnel
The product/system described in this documentation may be operated only by personnel qualified for the specific 
task in accordance with the relevant documentation, in particular its warning notices and safety instructions. Qualified 
personnel are those who, based on their training and experience, are capable of identifying risks and avoiding 
potential hazards when working with these products/systems.

Proper use of Siemens products
Note the following:

WARNING
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended or 
approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and 
maintenance are required to ensure that the products operate safely and without any problems. The permissible 
ambient conditions must be complied with. The information in the relevant documentation must be observed.

Trademarks
All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication 
may be trademarks whose use by third parties for their own purposes could violate the rights of the owner.

Disclaimer of Liability
We have reviewed the contents of this publication to ensure consistency with the hardware and software described. 
Since variance cannot be precluded entirely, we cannot guarantee full consistency.  However, the information in 
this publication is reviewed regularly and any necessary corrections are included in subsequent editions.

Siemens AG
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Postfach 48 48
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GERMANY
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Copyright © Siemens AG 2017.
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Security information 1
Siemens provides products and solutions with industrial security functions that support the 
secure operation of plants, systems, machines, and networks.

In order to protect plants, systems, machines and networks against cyber threats, it is 
necessary to implement – and continuously maintain – a holistic, state-of-the-art industrial 
security concept. Siemens’ products and solutions only form one element of such a concept.

Customer is responsible to prevent unauthorized access to its plants, systems, machines and 
networks. Systems, machines and components should only be connected to the enterprise 
network or the internet if and to the extent necessary and with appropriate security measures 
(e.g. use of firewalls and network segmentation) in place.

Additionally, Siemens’ guidance on appropriate security measures should be taken into 
account. For more information about industrial security, please visit:

http://www.siemens.com/industrialsecurity.

Siemens’ products and solutions undergo continuous development to make them more secure. 
Siemens strongly recommends to apply product updates as soon as available and to always 
use the latest product versions. Use of product versions that are no longer supported, and 
failure to apply latest updates may increase customer’s exposure to cyber threats.

To stay informed about product updates, subscribe to the Siemens Industrial Security RSS 
Feed under

http://www.siemens.com/industrialsecurity.
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Preface 2
Purpose of the program     

SIMATIC PDM (Process Device Manager) is a general-purpose, manufacturer-independent 
tool for the configuration, parameter assignment, commissioning, diagnostics, and 
maintenance of intelligent field devices (sensors and actuators) and field components (remote 
I/O, multiplexers, control room devices, compact controllers).

Purpose of the documentation
This documentation supports you in your work with SIMATIC PDM software. You are provided 
with an overview of the following topics:

● Installing SIMATIC PDM (Page 31)

● Commissioning the software

● Procedures for configuring networks and field devices

● Procedures for commissioning and using the Runtime functions

Required basic knowledge
The documentation is intended for persons working in field engineering who are responsible 
for configuration, commissioning and plant operation.

General knowledge in the area of field engineering is required to understand this 
documentation.

Knowledge about the use of Windows operating systems is also required.

Activities using STEP 7 and PCS 7 require corresponding knowledge in the field of automation 
technology and of SIMATIC S7.

Validity
This documentation is valid for the SIMATIC PDM V9.1 software package. 

Device-specific help
This documentation only covers the basic functionality of PDM. For device-specific information, 
refer to the documentation of the field device manufacturers.
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Readme for SIMATIC PDM     
For details of the requirements for using SIMATIC PDM, of special functions, and of the various 
applications, see file pdmbase-readme. You can locate the file as follows:

● On the SIMATIC PDM product DVD in the main folder of the DVD

● On the SIMATIC PCS 7 product DVD in the folder ...PDM...\PDMBASE\setup

● After installation of SIMATIC PDM:

– By selecting SIEMENS SIMATIC documentation in the Windows Start menu

– The default folder for the file is ...\SIEMENS\SIMATIC_PDM\.

Online help
The SIMATIC PDM online help is a project-specific help feature, which contains the following 
information:

● Help for SIMATIC PDM 
The PDF file is an extract of the HTML-based online help for SIMATIC PDM. The PDF file 
does not contain any device-specific information.

● Device-specific help 
Device-specific information contained in the online help is derived from the device 
descriptions (EDD) of the devices being used:

– Information on device-specific functions (e.g. available online functions)

– Help for device-specific menu commands (e.g. trend display options, device-specific 
display functions and operating functions)

Note
Scope of the device-specific information

The scope of the device-specific information depends on the information that can be 
derived from the device descriptions. 

The help system is integrated into the software by way of several interfaces:

● The Help menu provides several menu commands: Help Topics opens the help for SIMATIC 
PDM.

● The context-sensitive help provides information with regard to the current context such as 
open dialog boxes or active windows. The help is called by clicking the "Help" button or by 
pressing the F1 key.

● A tooltip is displayed for the toolbar icons when the user hovers the mouse pointer over the 
icons.

If you would prefer to read a hardcopy of the help, you can print specific help topics or chapters, 
or the entire help.

Preface
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Using SIMATIC PDM 3
3.1 Conditions for secure operation of SIMATIC PDM

SIMATIC PDM must be operated within the framework of the holistic PCS 7 security concept, 
see PCS7 & WinCC Security concept  (https://www.industry.siemens.com/topics/global/de/
industrial-security/support/seiten/whitepaper.aspx) and Siemens Industrial Security  (https://
www.siemens.com/industrialsecurity).

 

In particular, SIMATIC PDM may only be used in trustworthy networks. Web clients must be 
operated in the same security cell or trust zone as the Web server. This also means that direct 
access from external networks (e.g. the Internet) is not supported and must be prevented. 

 

Access from external networks (for example, an office network outside the process control 
network) to the PDM Web server (in the process control network) can be implemented using 
a terminal server in the perimeter network (DMZ). Users should only have minimal user rights 
on the terminal server. This only relates to the use of a Web browser. Secure configuration 
and licensing of the terminal server must be performed in compliance with the manufacturer 
recommendations.

Help for SIMATIC PDM (V9.1)
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3.2 Introduction
SIMATIC PDM (Process Device Manager) is a general-purpose, manufacturer-independent 
tool for configuration, parameter assignment, commissioning, diagnostics and maintenance of 
intelligent field devices (sensors and actuators) and field components (remote I/Os, 
multiplexers, control room units, compact controllers). These are simply referred to as devices 
in the rest of this documentation. 

With one software package, SIMATIC PDM enables processing of more than 2500 devices 
from Siemens and 200 other manufacturers from around the world with an homogeneous user 
interface.

The PDM Web application can be used on mobile devices with the Android operating system.

Using SIMATIC PDM
3.2 Introduction
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3.3 Using the documentation

Scope
SIMATIC PDM operates within a SIMATIC STEP 7 / PCS 7 environment or in combination 
with suitable function modules.   

Conventions 
The names of the user interfaces in this software are listed in accordance with the regional 
language of this documentation. If you have installed an MUI operating system, certain 
designations are still displayed in the base language of the operating system after a language 
change and will, therefore, differ from those used in the documentation.

Using SIMATIC PDM
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3.4 Contact partner

Your contact partner (not for demo version)

Questions on SIMATIC STEP 7  / SIMATIC PCS 7 / hardware / SIMATIC PDM / problems with 
S7 communication

Mailing address: SIEMENS AG
Customer Support
D-90475 Nuremberg, Germany

E-mail: online-support.industry@siemens.com
Internet: http://www.siemens.com/automation/service&support  (http://

www.siemens.com/automation/service&support) 

Questions on devices and GSD files
Please get in touch with your contact partner at the device manufacturer. 
For more information, refer to the "List of integrated devices". You can find this in the \_manuals 
folder on the SIMATIC PDM Device Library 2#2015 DVD.

Follow-up installations and additional information on SIMATIC PDM are available on the 
Internet at "www.siemens.com/simatic-pdm (www.siemens.com/simatic-pdm)".
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3.5 Basis for using intelligent field devices

Integration of field devices from different manufacturers into control systems
Device descriptions had to be standardized In order to enable intelligent field devices from 
different manufacturers to be integrated into different control systems. This standard (IEC 
61804-2) was developed in collaboration with the following organizations:

● PROFIBUS User Organization (PNO)

● Hart Communication Foundation (HCF)

● Fieldbus FOUNDATION (FF)

● OPC Foundation

Device descriptions are based on EDDL (Electronic Device Description Language - standard 
IEC 61804-3).

Finding the device description
You can obtain device descriptions in the following ways:     

● DVD "Device Library ...": 
You obtain this DVD with SIMATIC PDM. The Device Library includes device descriptions 
of the HCF library, FF library, PI library and FDI packages. 
You can find additional information on this in the pdmbase readme file.

● From the device manufacturer together with the device

● On the Internet

● In the device catalogs of applications that can evaluate data contained in device descriptions

Note
Device descriptions and EDD

Below, only the term "device description" will be used to refer to "EDD" (Electronic Device 
Description) and "DD" (Device Description). Exception: The user interface uses the terms 
EDD and DD.

Liability
Siemens explicitly declines any liability for damages resulting from the use of the following 
device description files and from interaction with the associated devices:

● For device-specific device description files for non-Siemens devices, the Siemens warranty 
only applies up to the interface.

● For non-device-specific device description files, such as those that correspond to the 
PROFIBUS PA profiles or the HART Universal or Common Practice Commands. 
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● For device description files of the HCF library from the "Device Library" DVD.

● For device description files that were integrated through catalogs.

NOTICE

Important note on the device description files included with the SIMATIC PDM

The device description files of non-Siemens field devices have not been developed by 
Siemens and are included with the shipped products free of charge. The licensee is entitled 
to use the device description files of these devices in the same manner as a trial license 
in accordance with the general terms and conditions for the supply of software for 
automation and drive technology. This right of use may be exercised by the licensee as 
long as the right of use for the PDM software is in effect.
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3.6 Establishing connections to field devices
Plants use field devices with different communication paths and protocols. The overview shows 
a typical connection scenario for the field device groups that are supported by SIMATIC PDM.

Network topologies for PROFIBUS DP
The following figure shows the access paths to field devices for SIMATIC PDM.
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Network topologies for PROFINET 
The following figure shows the access paths to field devices for SIMATIC PDM.

Communication paths 

Note
Interface with SIMATIC PDM

The PC shown is always the interface to SIMATIC PDM. 

In networks with routing capability, the PC can be connected to a linked network. You can find 
information about this in the section "Plant-wide communication by means of routing 
(Page 87)".
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HART modem network 
The following figure shows the access paths to field devices for SIMATIC PDM.

MODBUS network 
The following figure shows the access paths to field devices for SIMATIC PDM.

HART server network 
The following figure shows the access paths to field devices for SIMATIC PDM.

IE/WSN-

PA LINK

Wireless 

HART

HART-Multiplexer

Remote I/O

ES PDMPDM

HART

PROFIBUS DP

Ethernet

Supported networks   
With this version of SIMATIC PDM, field devices are supported on the following networks: 

● PROFIBUS DP network (including subordinate Foundation Fieldbus)

● PROFIBUS PA network

● PROFINET

Using SIMATIC PDM
3.6 Establishing connections to field devices

Help for SIMATIC PDM (V9.1)
Operating Manual, 02/2017, A5E39027365-AA 23



● MODBUS network

● HART modem network

● HART server

Activating PDM functions
License keys are required to use SIMATIC PDM. You can expand the SIMATIC PDM functions 
by adding optional packages. You can find information about this in the section "Product 
packages for SIMATIC PDM (Page 25)".

Additional information
Section "Inserting devices (Page 92)"
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3.7 Product structure

3.7.1 Product packages for SIMATIC PDM
Legend for the table:

● Product component is part of the product package.
○ Optional product component for the product package; obtainable as add-on
- Product component is not relevant for the product package or not available
1) TAG definition (see "SIMATIC PDM TAG" in the section "Options (Page 27)")
2) As of SIMATIC PDM V9.0, the license key for the "SIMATIC PDM Routing" add-on 

package is no longer used. Licensing for S7 DSGW is made via "SIMATIC PDM 
TAG". 
You can find information about this in the section "Options (Page 27)".

3) Only for special applications, not intended for wide-spread use: Use requires pro‐
gramming skills.

Components Product packages
 SIMATIC PDM stand-alone SIMATIC PDM system integrated

Minimum 
configura‐
tion

Basic con‐
figuration

Server Application-specific configurations

SIMATIC 
PDM Sin‐
gle Point

SIMATIC 
PDM Ba‐
sic

SIMATIC 
PDM 
stand-
alone 
server

SIMATIC 
PDM 
Service

SIMATIC 
PDM S7

SIMATIC PDM PCS 7

V9.1 V9.1 V9.1 V9.1 V9.1 V9.1 Server 
V9.1

FF V9.1

SIMATIC PDM TAG 
(license included in 
scope of delivery1))

1 4 100 4 + 50 4 + 100 4 + 100 4 + 100 4 + 100

SIMATIC PDM extension options
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Components Product packages
 SIMATIC PDM stand-alone SIMATIC PDM system integrated

Minimum 
configura‐
tion

Basic con‐
figuration

Server Application-specific configurations

SIMATIC 
PDM Sin‐
gle Point

SIMATIC 
PDM Ba‐
sic

SIMATIC 
PDM 
stand-
alone 
server

SIMATIC 
PDM 
Service

SIMATIC 
PDM S7

SIMATIC PDM PCS 7

V9.1 V9.1 V9.1 V9.1 V9.1 V9.1 Server 
V9.1

FF V9.1

Count Rel‐
evant Li‐
censes
(cumula‐
tive)

● 10 
TAGs

● 100 
TAGs

● 1000 
TAGs

Not ex‐
pandable

(can only 
be used 
for a sin‐
gle device 
and can‐
not be ex‐
tended 
with other 
options)

○2) ○ ○2) ○ ○ ○ ○

SIMATIC PDM Basic ● ● ● ● ● ● ●
SIMATIC PDM Exten‐
ded

○ ● ○ ● ● ● ●

SIMATIC PDM Integra‐
tion in STEP 7 / PCS 7

○ ● ○ ● ● ● ●

SIMATIC PDM Rout‐
ing2)

○2) ● ○2) ○ ● ● ●

SIMATIC PDM Server ○ ● ○ ○ ○ ● ○
SIMATIC PDM FOUN‐
DATION Fieldbus

○ ○ ○ ○ ○ ○ ●

HCF HART Server ○ ○ ○ ○ ○ ○ ○
SIMATIC PDM Com‐
mand Service3)

○ - ○ - - - -

Note
Devices subject to licensing

SIMATIC PDM only displays devices if a TAG license is installed for each device subject to 
licensing.
● Licenses are only required for devices that are subject to licensing.
● No licenses are required for remote I/O modules and channels.
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3.7.2 Options

Add-ons for SIMATIC PDM subject to licensing   

Note
SIMATIC PDM Single Point 
● SIMATIC PDM Single Point can only be used for a single device. 
● SIMATIC PDM Single Point cannot be extended with other functional or TAG options.

You can purchase the following options for SIMATIC PDM:

● SIMATIC PDM TAG

Note
Note TAG licenses

Maintenance projects use no TAG licenses; they only reserve TAG licenses. Multiprojects 
or other projects use TAG licenses.

If you want to use more TAGs for each multiproject or project than those provided in the 
standard package, the TAG options of SIMATIC PDM enable you to expand the TAGs to 
the required number. By combining multiple license keys, you can reach the required 
number of devices for licensing (TAG addition). See section "Establishing connections to 
field devices (Page 21)".
The "SIMATIC PDM Routing" option is not included in the SIMATIC PDM stand-alone 
product package. Licensing for use of the S7 DSGW (data record gateway) for gateways 
from the plant bus (Ethernet) to field buses (PROFIBUS) is performed via TAG licenses. 
TAG licenses are booked depending on the quantity according to the following rules:

– 10 TAG: per S7 DSGW with one PROFIBUS subnet

– 20 TAG: per S7 DSGW with more than one PROFIBUS subnet 

– 10 TAG: per IE/PB link

– 0 TAG: for Ethernet or PROFINET networks 

● SIMATIC PDM Extended
This option licenses and enables the use of the following additional functions:

– Import and export of parameter sets and project structures

– Print

– Document Manager

– Extended functionality of the LifeList

– Change log

– Calibration log for each field device

– Configuration of three time intervals (maintenance, servicing, calibration) for each field 
device
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● SIMATIC PDM integration in STEP 7 (PCS 7)
This option allows field devices and their associated networks to be configured using the 
STEP 7 hardware configurator (HW Config).

Note

The combination of SIMATIC PDM and the option "Integration in STEP 7" is referred to as 
SIMATIC PDM integrated in this documentation.

● SIMATIC PDM Routing
This option licenses and enables the use of the following gateways:

– Communication via an automation system which serves as a gateway

– Communication between Ethernet and PROFIBUS

– Communication between PROFINET and PROFIBUS

This option is not required for the following applications:

– For a PROFIBUS to PROFIBUS gateway

– For a PROFIBUS to HART gateway

– For a PROFINET to HART gateway

– For the SIMATIC PDM stand-alone product package

● SIMATIC PDM Server
This option licenses and enables the following applications: 

– Accessing functions of SIMATIC PDM using a browser

– Access with a maintenance client to the configuration interface of SIMATIC PDM for the 
selected field device 

– Enables SIMATIC PDM start on each client of the PCS 7 maintenance station and 
access to functions of SIMATIC PDM using a browser.

● SIMATIC PDM Client
This option licenses and enables access to the SIMATIC PDM Server via a browser on a 
separate PC station. The required data must be provided by the SIMATIC PDM Server.

● SIMATIC PDM FOUNDATION Fieldbus
This option licenses and enables configuration and communication of field devices on the 
FOUNDATION Fieldbus in SIMATIC STEP 7 and SIMATIC PCS 7 projects. 

● HCF HART Server
This option licenses and enables the use of the HCF HART Server and thereby HART 
multiplexers with connected HART field devices and wireless HART field devices.

● SIMATIC PDM Command Service
This option licenses and enables integration of SIMATIC PDM in additional automation 
systems. SIMATIC PDM projects and objects can be edited and operated through the 
associated interface. The use of this interface requires advanced programming skills.
If you want to use these interfaces, contact your Siemens representative.
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● SIMATIC PDM Logon
This option licenses and enables the use of the user management for the SIMATIC PDM 
Server.

● SIMATIC Logon 
This option licenses and enables the use of SIMATIC Logon.

Note

The "SIMATIC Logon" option requires licenses for the following applications:
● SIMATIC PDM stand-alone
● SIMATIC PDM integrated in STEP 7

No separate license is necessary within SIMATIC PCS 7.

3.7.3 Delivery contents

Scope of delivery
Information about the software packages that are delivered with SIMATIC PDM can be found 
in the pdmbase-readme file.

Device libraries   
Information on the devices contained in the SIMATIC PDM device libraries can be found:

● On the Internet pages of the device manufacturers
The updated versions of the device libraries and the HCF catalog are available in 
publications on the Internet.

● On the "SIMATIC PDM Device Library ..." DVD in the _manuals
\PI_Library_Documentation  folder > in the "index.html" file

Liability    

Note

Read the information in the section "Basis for using intelligent field devices (Page 19)".
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Installation 4
4.1 Compatibility

PDM V9.1 is compatible with STEP7 V5.6 and PCS 7 V9.0.

PCS 7 V8.0.2 is supported without the SIMATIC PDM FF option.
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4.2 Preparing SIMATIC PDM

Requirement
● SIMATIC PDM is installed.

You can find information on this in the section "Installing SIMATIC PDM (Page 33)"

● Project settings have been made.
You can find information on this in the section ""Options" menu (Page 256)".

● The settings have been made for the fieldbus interfaces.

● Field device planning has been completed.
You can find information on this in the section "Establishing connections to field devices 
(Page 21)"

● The device description files for the field devices used within a plant have been integrated 
into SIMATIC PDM. You can find information on this in the section "Integrating device 
descriptions (Page 51)".

Recommendation:

Hardware has been prepared (configuration, power supply, network connections).

Additional information
● For additional information on assigning a network, refer to the section "Setting the interface 

on the computer (Page 87)".

● For information on the particular issues relating to the distributed I/O, refer to the section 
"Modular PROFIBUS device (remote I/O) (Page 111)".
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4.3 Installing SIMATIC PDM
SIMATIC PDM must be installed before it can be started. The software package contains all 
SIMATIC PDM software. Depending on the use scenario, you only need to install certain 
applications. 

Licensing
In order to use the software you will need product-specific license keys (license agreements), 
which you install with the Automation License Manager. 
You can transfer the required license keys either prior to or following the installation. You can 
find additional information on this in the online help for the Automation License Manager.

Requirements
● The operating system has been installed.

● No version of SIMATIC PDM has been installed.

● All communications processors have been installed in the PC.

● You have administrator rights on the PC station.

If you install the software in a domain, be aware of group policies or other restrictions that may 
hinder the installation. Consult the appropriate Administrator as regards these settings and the 
required approvals and permissions.

Note
Display of the dialog elements

Dialog elements of SIMATIC PDM are only displayed correctly when the display settings in 
Windows are set to 100%. Bigger or smaller scaling lead to display errors.

Calling the setup program
1. Insert the program CD into the drive.

2. Double-click on "Setup.exe" to start the setup.

Note
Checking the installation requirements

The setup program automatically checks whether the software components needed for the 
installation are already installed on the PC. 
● Read the latest information about installation and the software and hardware 

requirements in the pdmbase-readme file on the program CD.
● If any software components are missing, a message informs you of this. The setup 

program is terminated after the message is confirmed . The setup will start again after 
you have installed the missing software components.

Installation
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Settings in the setup
Below you will find information on the settings made in the setup dialog boxes, listed in the 
order in which they are processed:

1. Setup language

– e.g. "English" and "Next"

2. Welcome

– "Next"

3. Product information 

– Read this if needed and "Next"

4. License agreement

– Select the check box "I accept the conditions of the above license agreement as well 
as the conditions of the Open Source license agreement. I confirm that I have read and 
understood the security information".

– "Next"

5. Setup type

– Activate the "Install" check box and "Next".

6. User information

– Enter the user information and click "Next".

7. Programs

– The options installed on the PC for this selection are listed in the display window. 
Select the add-ons you want to use and for which you have licenses or will later acquire. 
"Next"

Add-ons Required for:
SIMATIC PDM FOUNDATION Fieldbus Configuring and/or monitoring FF devices
SIMATIC PDM Command Service Integrating SIMATIC PDM in automation sys‐

tems 
Note: Not required for SIMATIC PCS 7

SIMATIC PDM Server Accessing functions of SIMATIC PDM via 
browsers or faceplates

SIMATIC PDM Logon Managing users for SIMATIC PDM Server
SIMATIC Logon Managing users for SIMATIC PDM and SIMAT‐

IC PDM Server
HCF HART Server Using HCF HART Server and HART compo‐

nents

Installation
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8. System settings
System settings are required for problem-free operation of SIMATIC PDM.

Note
Required system settings
● The settings in the exception list of the Windows firewall are applied to the area of the 

local network (subnet). If your PC stations are located in different networks (subnets), 
you need to change this area.

● The settings in the exception list of the Windows firewall are made when the Windows 
firewall is disabled.

● You can open the "Security Controller" dialog box again. To do this, select the following 
in the Start menu, Siemens SIMATIC programs: Security > Security Controller

9. Ready to install the selection. 
"Install" - The installation is performed.
Close the dialog box when the installation is complete.

10.Reboot the PC.

Device descriptions of field devices used
Following the installation of SIMATIC PDM, integrate the required device descriptions (EDD) 
for the field devices used. 

You can find information on this in the following sections:

● Section "Integrating devices into SIMATIC PDM (Page 41)"

● Section "Integrating device descriptions (Page 51)"
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4.4 Setting the language

Changing the language
1. In SIMATIC Manager, select the menu command Options > Settings…

.The "Settings" dialog box opens.

2. Open the "Language" tab. You can change the language on this tab page.

3. Select the language you want to work with in the "National language" field.

Note
SIMATIC PDM language versions

The drop-down list contains the languages in which SIMATIC Manager is installed.
If you select a language for which there is no matching SIMATIC PDM language version 
installed on the given computer, "English" is set automatically.
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4.5 Reinstalling / Removing SIMATIC PDM

Note

Observe the information on dealing with license keys, which can be found in:
● File pdmbase-readme
● Help for the Automation License Manager

Reinstalling
Reinstallation over the top of an existing SIMATIC PDM version is not possible. Remove 
SIMATIC PDM prior to installing the new version.

Note
Device descriptions

Following a new installation, the required device description must be integrated again.

The device descriptions included with SIMATIC PDM are available on the "Device Library" 
DVD.

You know the storage locations of additionally used device descriptions.

You can find information about integrating the device descriptions in the section "Integrating 
devices into SIMATIC PDM (Page 41)".

Removing
To remove SIMATIC PDM, use the Windows system function for removing programs.
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PDM Exportfile Converter 5
5.1 "PDM Exportfile Converter" dialog box

In the "PDM Exportfile Converter" dialog, you can convert export files from older PDM versions, 
enabling them to be imported into PDM again.

The export files from PDM versions V6.x and V7.x cannot be imported directly into SIMATIC 
PDM as of V8.0.
To enable importing of existing export files, the "old" export files are converted.
A structure file is generated in this case and stored along with the associated parameter import 
files in the corresponding subdirectory generated by the converter. These files can then be 
imported.

Note

During export in V6.x, you must ensure that the set SIMATIC Manager language matches the 
set system language of the computer. For example, when the character format is en-EN and 
the language is English.

Source-File
Navigate to the desired directory in the file system containing the export files to be converted. 

After the dialog is closed with OK and an export file is correctly selected, the structure it contains 
is displayed in the converter.

Destination-Dir
Navigate to the desired directory in the file system where the converted files are to be stored.

"Convert" button
Click "Convert". The selected source file is converted. 
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Integrating devices into SIMATIC PDM 6
6.1 Device Integration Manager

The field devices can only be configured if the device descriptions that are suitable for the field 
devices have been integrated into SIMATIC PDM. The Device Integration Manager is the 
SIMATIC PDM function for integrating device descriptions.

Liability
Siemens explicitly declines any liability for damages resulting from the use of the following 
device descriptions and use in conjunction with the associated devices:

● For device-specific device descriptions for non-Siemens devices, the Siemens warranty 
only applies up to the interface.

● For non-device-specific device descriptions, 
such as device descriptions that correspond to the PROFIBUS PA profiles or the HART 
universal or common practice commands.

● For device descriptions of the HCF library, FF library, and PI library from the "Device 
Library ..." DVD.

NOTICE

Important information about the device descriptions included with the SIMATIC PDM

The device descriptions of non-Siemens field devices were not developed by Siemens 
and are included with the shipped products free of charge. The licensee is entitled to use 
the device descriptions of these devices in the same manner as a trial license in 
accordance with the general terms and conditions for the supply of software for automation 
and drive technology. This right of use may be exercised by the licensee as long as the 
right of use for the PDM software is in effect.

Starting the Device Integration Manager
1. In the Windows Start menu under the Siemens SIMATIC programs, select the SIMATIC 

PDM > Device Integration Manager menu command. 
The "Device Integration Manager" dialog opens.

2. Read the license agreement. 
You must accept the license agreement in order to be able to work with the Device 
Integration Manager .

3. Click the "I accept the license agreement" button.
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6.2 "Device Integration Manager" main window

Introduction
The "Device Integration Manager" main window remains on the screen throughout the work 
session and is partially or totally covered by other activated dialog windows.

The main window has the following layout
Title bar (Page 43) The product name is displayed.
Menu bar (Page 43) You access the functions of the Device Integration Manager via the 

menu bar.
Toolbar (Page 44) The toolbar enables certain menu commands to be accessed quick‐

ly.
Source folder (Page 48) The "Source folder" box shows the storage location in which device 

descriptions are or were searched for.
Applying a filter (Page 49) You can apply filters to reduce the amount of information displayed 

in the device list.
Applying a project filter 
(Page 63) / Applying Filter File 
(Page 63)

Only those devices that are used in the selected project and for 
which an identical version has not yet been integrated are selected 
for integration.

Device list (Page 46) The device list displays information on devices that have been read 
in or integrated. 

Status bar (Page 48) Contains information on processes currently being performed.
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6.3 Views

6.3.1 Title bar
The title bar shows the name "Device Integration Manager".

6.3.2 Menu bar

Structure
Below you will find an overview of the Device Integration Manager menus.

Menu Submenu Function
File
 

● Read device descriptions 
from source directory 
(Page 57)

Select the storage location of the device descriptions to be read in.
Set the path to the device descriptions or navigate to the location.

● Read device descriptions 
from compressed source 
(Page 57)

Select the storage location of the compressed device descriptions to be read in.
Set the path and the file name for compressed device descriptions or navigate 
to the location.

● List of integrated device 
descriptions (Page 58)

The device descriptions integrated in the PC are read in to the device list.

● List of device descriptions 
used (Page 58)

The device descriptions used in the STEP 7 project are displayed.

● Save device list (Page 59) The displayed information of the current device list is saved.
Specify the storage location and file name for the file in which the device list is 
to be saved.

● Print device list (Page 59) The device list is sent to the selected printer.
● Deleting the device list 

(Page 60)
The displayed device list is emptied.
Application example: 
Clearing the device list before reading in device descriptions again.

● Exit (Page 60) Closes the Device Integration Manager.
View ● Split device list window 

(Page 60)
The device list window is split or the split is removed.
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Menu Submenu Function
Catalog ● Complete device 

information (Page 61)
If the software detects that relevant information is missing in a device description 
during its import, the "Device info incomplete" icon appears in the status column 
of the device list.
If you select an affected device in the device list, you can then complete the 
device information in a dialog.

● Integrate (Page 62) The device descriptions are integrated into SIMATIC PDM for those devices 
selected in the device list.
Requirement:
The check box for the required device is selected in the "Path" column of the 
device list.

● Creating user-specific 
device DVD (Page 62)

Your own device library is created.
Device libraries that were created in this way can be copied, compressed or 
burned to DVD. These libraries can be read in and integrated with the Device 
Integration Manager just like the SIMATIC PDM DVD "Device Library …".

● Applying Filter File 
(Page 63)

Select a filter file (previously saved device list) according to which the currently 
displayed device list is to be filtered.

● Applying a project filter 
(Page 63)

Select a project or multiproject to filter the currently displayed device list for 
components used in the project.

● Remove Filter File/Project 
Filter (Page 63) 

Filtering by means of a filter file or project filter is stopped.

● Messages (Page 64) The "Messages" dialog box opens.
● Find (Page 65) The "Find" dialog window opens.

? ● Help (Page 65) Opens the help for SIMATIC PDM.
● Info (Page 66) The following information is displayed:

● SIMATIC PDM version
● Information about the "Device Integration Manager" component

Additional information
Use SIMATIC Manager to make the settings for the Device Integration Manager.

You can find information on this in the following sections:

● Setting the language: Section Options > "Settings (Page 256)"

● Section Options > SIMATIC PDM > Settings > "Device Integration Manager" tab 
(Page 261)

6.3.3 Toolbar
The toolbar is located below the menu bar and contains a number of icons with which you can 
quickly perform frequently used menu commands without having to open a menu and select 
the command. 
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Icons     
Meanings of the icons used:

Icon Menu command Description
Read device descriptions 
from source directory 
(Page 57) 

Select the storage location of the device descriptions to 
be read in.
Set the path to the device descriptions or navigate to the 
location.

Read device descriptions 
from compressed source 
(Page 57)

Select the storage location of the compressed device de‐
scriptions to be read in.
Set the path and the file name for compressed device de‐
scriptions or navigate to the location.

Integrate (Page 62) The device descriptions are integrated into SIMATIC PDM 
for those devices selected in the device list. 

Print device list (Page 59) The device list is sent to the selected printer.

Deleting the device list 
(Page 60) 

The displayed device list is emptied.
Application example: 
Clearing the device list before reading in device descrip‐
tions again.

List of integrated device 
descriptions (Page 58) 

The device descriptions integrated in the PC are read in 
to the device list.

List of device descriptions 
used (Page 58)

The device descriptions used in the STEP 7 project are 
displayed.

Creating user-specific de‐
vice DVD (Page 62) 

Your own device library is created.

Save device list (Page 59) The displayed information of the current device list is 
saved.
Specify the storage location and file name for the file in 
which you want the device list to be saved.

Applying Filter File 
(Page 63)

Select a filter file (previously saved device list) according 
to which the currently displayed device list is to be filtered.

Applying a project filter 
(Page 63)

Select a project or multiproject to filter the device list for 
components used in the project.

Split device list window 
(Page 60)

The device list window is split or the split is removed once 
again.

Messages (Page 64) The "Messages" dialog box opens.

Using the Find function 
(Page 65) 

The displayed device list is searched.
Open the "Find" dialog box. Enter a character string and 
specify the search options.

Help (Page 65) The SIMATIC PDM help opens.

6.3.4 Device list
The device list in the "Device Integration Manager" dialog window contains tabular information 
on device descriptions and devices that can be interpreted by SIMATIC PDM with a device 
description.
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Columns

Column Description
Path Tree structure - The devices with device description are displayed in a hierarchical structure 

(catalog path).
Flat structure - The devices with device description are displayed without a hierarchical 
structure.
The devices are displayed in a hierarchical structure when you click the "Path" column 
header for sorting.
The devices are displayed in a flat structure when you click the header of any other column 
(except "Path").
● Select the check boxes for the devices whose device descriptions are to be integrated.

Communication
 Folder for device classes (actuator/sensor etc.)
 Manufacturer
 Device type, Component, Device version, Variant

Device name Device name
Manufacturer Manufacturer
Communication Communication type for the connection to the field device
Device class Catalog position (object name)
New version Version of the device description which was read in from a device description library
Integrated version EDD source version
Integrated on Installation date of the installed EDD
Description Attribute from device file
Type ID ID of the device type
GSD file Names of the GSD files
New DD revision Revision of the device description file of the imported device package
Integrated DD revision Revision of the device description file of the integrated device package
New device revision Device revision of the device with which the imported device package is compatible.
Integrated device revision Device revision of the device with which the integrated device package is compatible.
Device library Version number of the device DVD from which the device package was imported during 

integration
If the device package was supplied as a single package, this column is empty.

Additional information may be displayed.
● You can select the columns to be displayed in the SIMATIC Manager using the following menu command: Options > 

SIMATIC PDM > Settings... .
● You will find additional information on this topic in section "Device Integration Manager" tab (Page 261).

Status icons of the device description

Table 6-1 Meaning of icons before the status of the device description integration

Icon Meaning
Not (yet) integrated

Device info incomplete
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Icon Meaning
An identical or newer device description is integrated.

The device description is in the process of being integrated.

The device description has been integrated successfully.

The device description is used in the project but neither read in nor integrated.

Error; Observe the error details in the message window.

Warning; Observe the warning details in the message window.

Table 6-2 Meaning of icons after the device descriptions have been read in and before they have 
been integrated

Icon Meaning
The device description has been read in without any errors but has not yet been inte‐
grated. 
The device information is incomplete in the imported device description. The device 
description cannot be integrated correctly. 
You can find information on correcting this in the section "Completing a device descrip‐
tion (Page 52)".
An identical or newer version of the device description is integrated.

The device description is in the process of being integrated.

The device description has been integrated successfully.

Errors occurred while reading in the device description. The device description cannot 
be integrated.
For details regarding the error messages, see the message window.
Warnings generated. The device description has been read in and can be integrated. 

Table 6-3 Meaning of the icons after integration of the device description

Icon Meaning
The device description has not been integrated because the user did not select it for 
integration.
The device description was not integrated because an identical or a newer version was 
already installed. 
The device description has been successfully integrated without errors. 

The device description has been successfully integrated without errors. Warnings or 
errors occurred during the semantics check.
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Icon Meaning
An attempt was made to integrate the device description. The device description could 
not be integrated due to an error.
● Error messages:

For details, please refer to the message window.
● Potential cause: Device information incomplete during integration.
The device description has been integrated. The warnings indicate potential inconsis‐
tencies. 

Sorting
You can sort the contents of the table. Click on the cell in the header of the column based on 
which the contents should be sorted. Clicking on this cell again changes the sorting direction 
(ascending/descending).

6.3.5 Status bar
The status bar is located at the bottom of the main window. It displays the number of read in 
or integrated device descriptions.   

6.3.6 Source folder
The Source folder box is located underneath the toolbar. You use this box to select the path 
in which the device descriptions are located. The device list is created based on the device 
descriptions.

The source can be:

Icon Meaning
Folder

Compressed file (*.zip)

Device description file (*.xml)

The Source folder box gives you the option to display the history of the directories so far. Click 
the drop-down list icon on the right side of the box to display the last ten sources.

Changing the source folder
Procedure

1. Click the "Find folder" icon.
The "Change source folder" dialog box opens.

2. Navigate to the required directory in the file system.

3. Click "OK".

Alternatively, you can enter the path in the text box.
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All compressed files included in the selected source directory are searched for the device 
descriptions. Compressed files within a compressed file are also taken into consideration.

6.3.7 Applying a filter
The "Filter" box is located underneath the "Source folder" box. You can filter for up to three 
strings of your choice (filters 1, 2 and 3) simultaneously. When the filter is applied, all devices 
that include all specified strings in their device description are displayed. A distinction is not 
made between uppercase and lowercase letters.

Procedure
1. Click in the text box "Filter 1", "Filter 2" or "Filter 3".

2. Enter the required search term.

3. Confirm your entry with the "Enter" key.
The device list is searched for the search terms and updated.

Each input box gives you the option to display the history of the search terms so far. 

● Click the drop-down list icon to the right of the text box to display the history.

● To disable individual filters, click on the  of the respective filter.

Note

The filter (text boxes, filter files, project filter) does not only affect the display. The selections 
of all devices excluded by the filter are removed and no longer set when the filter is disabled.

See also
Applying a project filter (Page 63)

Remove Filter File/Project Filter (Page 63)

Applying Filter File (Page 63)

6.3.8 Filter file/Project filter
The "Filter file/Project filter" box is located underneath the "Source folder" box. It is only 
displayed when you use a filter file or the project filter.

The devices that match the data of the filter file or are contained in the project file are displayed 
when the filter is applied.

Applying a filter
The procedure for applying a filter file or a project filter is described under Filter file (Page 63) 
or Project filter (Page 63).
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See also
Remove Filter File/Project Filter (Page 63)
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6.4 Working with the Device Integration Manager

6.4.1 Integrating device descriptions
The Device Integration Manager is the SIMATIC PDM function for integrating device 
descriptions. 

Device descriptions of the "Device Library" DVD
Make sure the device descriptions are always integrated in SIMATIC PDM from the "Device 
Library" DVD provided with your version of SIMATIC PDM. Changes in the device descriptions 
and the catalog structure may exist between the different versions.

Note
FOUNDATION Fieldbus

The SIMATIC PDM option "FOUNDATION Fieldbus" must be installed to integrate device 
descriptions for devices on FOUNDATION Fieldbus.
You can find information on this in section "Installing SIMATIC PDM (Page 33)"

Upgrading SIMATIC PDM

Note
Checking for all device types used in the project

After integrating the device descriptions, you need to check the assignment of the device 
description (by opening the parameter assignment interface once).

Procedure
1. Close all SIMATIC programs that are open on the PDM PC.

2. Go to the Windows Start menu and select the menu command SIMATIC PDM > Device 
Integration Manager under the Siemens SIMATIC programs.
You must accept the license agreement to be able to use the Device Integration Manager .

3. Select the File > Read device descriptions from source directory...  or File > Read device 
descriptions from compressed source... menu command.

4. Navigate to the folder with the device descriptions in the tree structure.

Note
"Device Library" DVD

The "Device Library" DVD is supplied with SIMATIC PDM. Select the drive containing the 
DVD.
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5. Click the "OK" button.
The device descriptions found are displayed in the "Devices" list.
You can find additional information on this in the section "Device list (Page 45)".

6. Select the check boxes for the devices whose device descriptions are to be integrated. The 
check box is automatically selected for devices that have not been integrated or have been 
integrated with an older version. You can work with a split device list window (Page 60).

7. Select the Catalog > Integration... menu command.
The device descriptions are transferred to the PC.

Note
During the device description integration

Do not open any SIMATIC programs until the device description integration has completed.

Completing the information for a device description
If information is missing from a device description, e.g., regarding the classification, you can 
add this information yourself. You can find information on this in the section "Completing a 
device description (Page 52)".

Additional information
● Section "Delivery contents (Page 29)"

● Section "Messages (Page 55)"

● Section "Checking the device integration (Page 88)"

● Section "Replacing devices (Page 121)"

6.4.2 Completing a device description
If the software detects that information is missing in a device description during its import, the 
"Device info incomplete" icon appears in the status column of the device list. 

Recommendation:
Each device description marked in this way should be completed before it is integrated in 
SIMATIC PDM.

Note
Completing device information at a later date

If you need to complete any device information at a later date then please follow the procedure 
below.
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Procedure
1. Select an incomplete device description and then select the Complete device 

information... command in the shortcut menu.

2. Complete the device description.

3. Click "OK".

Note
Saving the changes
● If the device description is located on a read-only medium, changes cannot be made. 

In this case, copy the device description to a medium that is not write-protected and 
start the process again.

● The changes will remain available in the Device Integration Manager until the dialog box 
is closed. When you click the "OK" button, the changes are applied to the device 
description.

4. Click "Integrate".
The integration of the device description is performed.

Additional information
You can find information on the device list entries in the section "Device list (Page 45)".

6.4.3 Creating your own device library using the project filter

Introduction
You use the following procedure to create your own device library using the project filter. 

Project filter
Information on the project filter and its application is available in the section "Applying a project 
filter (Page 63)".

Procedure
1. Read in the device descriptions of a standard library.

2. Apply a project filter.

3. Select the Catalog > Creating user-specific device DVD... menu command.

4. Enter the destination path in the "Create own device library... " dialog box.

5. Enter the device library name or the version identification of the device library.
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Note
Devices without help files

If you are using a device without help files, you can integrate the help files at a later time. To 
do this, answer the "Missing Help Files" dialog box with "Yes".

Additional information
● Section "Integrating device descriptions (Page 51)"

● Section "Basis for using intelligent field devices (Page 19)"

6.4.4 Creating your own device library from a collection of device descriptions
You use the following procedure to create your own device library from a collection of device 
descriptions. 

Collection of device descriptions
You can find information about the availability of device descriptions and their application in 
the section "Basis for using intelligent field devices (Page 19)".

Procedure
1. Read in the device descriptions of a standard library.

2. Select the check box for the device descriptions that you need in your own device library.

3. Select the Catalog > Creating user-specific device DVD... menu command.

4. Enter the destination path in the "Create own device library... " dialog box.

5. Enter the device library name or the version identification of the device library.

Note
Devices without help files

If you are using a device without help files, you can integrate the help files at a later time. To 
do this, answer the "Missing Help Files" dialog box with "Yes".

Additional information
Section "Integrating device descriptions (Page 51)"
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6.4.5 Removing device descriptions

Shortcut menu
If you select objects in the list of integrated device descriptions, you can use the shortcut menu 
to remove the device description:

Removing integrated device descriptions 

Delete the selected objects from the list of integrated device descriptions via this menu 
command. The selected objects are also deleted from the catalog.

6.4.6 Update / upgrade of device descriptions (EDD update)

Procedure
1. Check the version of the integrated device descriptions.

You can find information on this in the section "Device list (Page 45)". 

2. Read in the new device descriptions and compare the new version with the integrated 
version.
You can find information on this in the section "Read device descriptions from source 
directory (Page 57)".

3. Select the required device descriptions and integrate the device descriptions. The check 
box is automatically selected for devices that have not been integrated or have been 
integrated with an older version.
Information on this is available in the section "Integrating device descriptions (Page 51)".

See also
Download to device (Page 231)

6.4.7 Messages

Message log
If errors occur during the actions or in the application of the Device Integration Manager, they 
are shown in the message log. The message log opens automatically when a warning or an 
error has occurred, but it can also be opened manually from any node in the device list. In this 
case, all messages of the nodes under this in the hierarchical order are displayed.

Additional information
Section "Message log (Page 156)"

Integrating devices into SIMATIC PDM
6.4 Working with the Device Integration Manager

Help for SIMATIC PDM (V9.1)
Operating Manual, 02/2017, A5E39027365-AA 55



6.4.8 Checking syntax and semantics.
You have two ways to check the syntax and semantics:

1. During the integration of the packages in the "Device Integration Manager".

2. After integration of the packages in the "Device Integration Manager" in the device list using 
the Check Syntax and Semantics shortcut menu.

Starting the check of syntax and semantics via the shortcut menu
1. Start the Device Integration Manager.

2. Select the menu command File > Menu > List of integrated device descriptions.

3. Select the desired device description or device descriptions.

4. In the shortcut menu, select the command Check Syntax and Semantics.
The syntax and semantics are checked.
Warnings and errors are displayed in the message log.

Possible results of the check
After the check, the results are indicated in the "Status" shown column by a symbol (Page 45).
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6.5 Menus and dialog boxes

6.5.1 File

6.5.1.1 Read device descriptions from source directory
Before devices can be configured in SIMATIC PDM, the associated device description files 
need to be read in using the Device Integration Manager. 

Requirement
The storage paths of the device description files can be accessed.

Procedure
1. Select the menu command File > Read device description files from source directory ....

In the tree structure, navigate to the storage path where the device description files are 
saved.

2. Click "OK".
The device description files are read in.

Note

If the compressed file is password-protected, a dialog appears for entering a password.

Shortcut menu
If you select objects in the list of read in device descriptions, you will find the following via the 
object-dependent shortcut menu commands below:

● Messages (Page 55)    
Open the message log via this menu command.

● Complete device information (Page 61)    
Open the "Complete device information..." dialog via this menu command.

6.5.1.2 Read device descriptions from compressed source

Introduction
Before devices can be configured in SIMATIC PDM, the associated device description files 
need to be read in using the Device Integration Manager. 

Requirement
The storage paths of the device description files can be accessed.
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Procedure
1. Select the File > Read device description files from compressed source ... menu command.

2. In the tree structure, navigate to the storage path of the device description files.

3. Click "OK".
The device description files are read in.

Note

If the compressed file is password-protected, a dialog appears for entering a password.

Shortcut menu
If you select objects in the list of read in device descriptions, you will find the following object-
dependent shortcut menu commands:

● Messages (Page 55)    
You use this menu command to open the message log.

● Complete device information (Page 61)    
You use this menu command to open the "Complete device information..." dialog.

6.5.1.3 List of integrated device descriptions

Displaying the device list
Displays the devices for which a device description file is saved on the PC.

Shortcut menu
If you select objects in the list of integrated device descriptions, you will find the following object-
dependent shortcut menu commands:

● Messages (Page 64)    
You use this menu command to open the message log.

● Remove integrated device description(s)  (Page 55)
You use this menu command to delete selected objects from the list of integrated device 
descriptions.

See also
Complete device information (Page 61)

6.5.1.4 List of device descriptions used

Displaying the device list
Display of the devices used in the project.
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The status column (Page 45) indicates whether or not the corresponding device description is 
integrated on the computer.

If you select a STEP 7 multiproject, all projects are always displayed, even when only a 
subproject is selected in the dialog box.

Shortcut menu
If you select objects in the list of integrated device descriptions, you will find the following object-
dependent shortcut menu commands:

● Messages (Page 64)    
You use this menu command to open the message log.

● Remove integrated device description(s)  (Page 55)
You use this menu command to delete selected objects from the list of integrated device 
descriptions.

See also
Complete device information (Page 61)

6.5.1.5 Save device list

Saving the device list
Specify the storage location and file name for the file in which you want the device list to be 
saved.

6.5.1.6 Print device list
You can print the device list that is currently being displayed.

Setting the printer options

Note
● The printer options depend on your computer's operating system and on the printer being 

used.
● The file is sent to the default printer.
● If the printout has more than one page, two periods are printed after the page number in 

the bottom right corner of the page. The last page does not have these periods, indicating 
no more pages are to follow.

Integrating devices into SIMATIC PDM
6.5 Menus and dialog boxes

Help for SIMATIC PDM (V9.1)
Operating Manual, 02/2017, A5E39027365-AA 59



Procedure
1. Select the menu command File > Print device list or click the "Print" button.

The "Print" dialog box opens.

2. Select the required options.

3. Click "OK".

6.5.1.7 Deleting the device list
Clearing the displayed device list.

Example of application
Clearing the device list before reading in device descriptions again.    

6.5.1.8 Exit
Exits the "Device Integration Manager".   

6.5.2 View

6.5.2.1 Split device list window
The device list window is split or the split is removed.   

When you select the menu command, the device list window is cut in half vertically. The right 
half shows an additional device list window with the same structure. This window includes all 
devices selected in the left device list window (check boxes are selected).

Note

The line selected with the mouse is displayed with a blue background in the active window. In 
the inactive window, the line is displayed with a gray background.

The check boxes in the left device list window are visible but cannot be operated. 

You can move the dividing line between the two device list windows with the mouse.  

The buttons for adding or removing selected individual devices or sub-trees are located 
between the two windows.  

The selection of devices in the device list window is used for
•    Integrating and 
•    Creating your own device library. 
With a device list window that is not split, a selection can be made by setting the check boxes 
in the line of the device.
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Mouse operation
By selecting a line in the left device list window and clicking the  button, you add individual 
devices or sub-trees to the right device list window.

By selecting a line in the right device list window and clicking the  button, you remove the 
individual devices or sub-trees added previously from the right device list window.

Keyboard operation
Use the "SHIFT + >" and "SHIFT + <" shortcuts to add or remove the selected devices to and 
from the right window. 

Rules for working with split device list windows
When a filter is used, it acts on both device list windows. 

Sorting can take place independently in each window. 

Searches are only conducted in the active window with the selected line having a blue 
background.

An export only includes the contents of the left window (with selection information).

Only one device list window is displayed after the Device Integration Manager is restarted.

Note

You cannot split the device list window when the list of integrated or used devices is displayed.

6.5.3 Catalog

6.5.3.1 Complete device information

Modifying the information in a device description file
The table below shows the information that can be completed in the "Device Integration 
Manager" dialog box using the "Complete device information" function. 

Column Explanation
Device name You can modify the device name in this input box.
Name of the device ver‐
sion

You can modify the version of the device description in this input field.

Manufacturer Manufacturer of the field device
Type ID Identifier for a device type in hexadecimal format

You can find information on this in IEC 61804-3.
Device revision Identifier for a device revision
Communication Communication type for the connection to the field device
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Column Explanation
Classification Class of the device - name of the object (e.g., SENSOR - FLOW - ULTRA‐

SONIC)
DD revision Version of the device description file

You can find information on this in IEC 61804-3.
EDD Name of the device version 

You can find information on this in IEC 61804-3.

6.5.3.2 Integrate
Use the menu command Catalog > Integrate to integrate the device description files of the 
devices into the device catalog of SIMATIC PDM for those devices with selected check boxes 
in the "Path" column of the device list.

Compiling device description files for SIMATIC PDM
You can find information about the possible settings in the description of the PDM setting in 
the section ""Device Integration Manager" tab (Page 261)".

Remove integrated device description(s)
Section "List of integrated device descriptions (Page 58)"

6.5.3.3 User-specific device DVD 

Creating user-specific device DVD
You can use the Catalog > Creating user-specific device DVD... menu command to create 
your own device library. You can copy created device libraries, save them as compressed 
archive or burn them on DVD and read in and integrate them with the Device Integration 
Manager just like the SIMATIC PDM DVD "Device Library …".

Additional information
Information on creating a device library from a collection of device descriptions is available 
here (Page 54).

Information on creating a device library using a project filter is available here (Page 53).

"Creating user-specific device DVD" dialog
Procedure 

1. Select the Catalog > Creating user-specific device DVD... menu command.
The "Create own device library ..." dialog box opens.

2. Enter the destination path, the name and a version identification of the device library.

3. Click "OK".
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6.5.3.4 Filter file

Applying Filter File
You can use the Catalog > Applying Filter File... menu command to apply predefined filter files 
(device lists in XML format saved in the Device Integration Manager beforehand) to the device 
library.

The "Filter file" box is displayed underneath the "Source folder" box if a filter file is loaded.

"Apply Filter File..." dialog box
Procedure

1. Select the Catalog > Applying Filter File... menu command.
The "Applying Filter File..." dialog box opens.

2. Select a file with an exported device list.

3. Click "OK".
The currently displayed device list is filtered as follows: 
•    Only devices that are read in and are included in the filter file are displayed. 
•    Only devices that are selected in the filter file can be selected for integration.

Remove Filter File/Project Filter
The Catalog > Remove Filter File/Project Filter menu command is used to stop the application 
of the filter file or a project filter. The complete device list is displayed once again when you 
revoke the filter.

6.5.3.5 Project filter

Applying a project filter
You can use the Catalog > Apply Project Filter… menu command to select a STEP 7 project 
or STEP 7 multiproject to filter the device list for the components used in the project.

The "Project filter" box is displayed underneath the "Source folder" box if a project is loaded.

By combining the "Create own device library" and "Apply Project Filter" functions, you can 
create a device DVD that is perfectly adapted to your project.
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If you select a STEP 7 multiproject, all projects are always selected, even when only a 
subproject is selected in the dialog box.

Note
Object status

Make sure that the status of each device contained in the project file is also integrated in the 
device library before you apply the project filter. You can determine this by the status icon in 
the "Icon" column of the device list. You can find a list of the icons under Device list (Page 45).

Additional information
Information on creating a device library using a project filter is available here (Page 53).

"Apply project filter..." dialog box

Requirement
A device list has been read in.

Applying a project filter
Procedure

1. Click the "Apply Project Filter..." icon in the menu bar.
The "Open Project" dialog box opens.

2. Select the required project in the "User project" tab.
If you want to open a multiproject, select the "Multiproject" tab.

3. If the required project file is located on an external source, click the "Browse" button and 
navigate to the required path.

4. Confirm your entry by pressing "Enter".
The device list is searched and updated.

To revoke the filter, click the  button.  

Remove Filter File/Project Filter
The Catalog > Remove Filter File/Project Filter menu command is used to stop the application 
of the filter file or a project filter. The complete device list is displayed once again when you 
revoke the filter.

6.5.3.6 Messages
Opens the "Messages" dialog box.
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Additional information
Section "Message log (Page 156)"

6.5.3.7 Find

Using the Find function
You can use the Catalog > Find menu command to find device description files.

"Find" dialog box
Procedure

1. Select the menu command Catalog > Find.
The "Find" dialog box opens.

2. Enter a string and define search options.

3. Click "Find".

Settings in the "Find" dialog box
● Entry field with drop-down list

You can enter any string. You can search for this string.

● Check boxes

– Match case
The writing style of the string entered for an object in the device list is observed.

– Match entire cell contents
The entire string must match for an object in the device list.

– Search up
If this option is enabled, the search begins at the selected point and continues until the 
start of the device list. 
If this option is disabled, the search begins at the selected point and continues until the 
end of the device list. 

● "Find" button
The system searches through the displayed device list.

6.5.4 ? (Help)

6.5.4.1 Help
This menu command displays the Help on SIMATIC PDM. 
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You can navigate to different help topics from the Table of Contents. The "Index" and "Find" 
functions enable you to display information on specific terms. 

6.5.4.2 Info
This menu command displays information about the version and the copyright.     
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Views 7
7.1 Introduction

PDM objects are displayed in the following views in SIMATIC Manager:

● Process Device Plant View
The process device plant view provides an overview of all configured devices in all 
configured networks.

● Process Device Network View
The plant topology is reproduced in the process device network view. The depicted objects 
are links to the objects in the plant view.

● PDM objects can be configured with HW Config. Open the SIMATIC PDM shortcut menu 
to assign parameters.

● The network links to the PDM objects are also listed in NetPro.

Working with SIMATIC PDM
License keys are required to use SIMATIC PDM. You will find information about this in the 
pdmbase-readme file.

Recommendation: Before you assign parameters to a field device with SIMATIC PDM, check 
whether you can reach the required device.

Additional information
Section "Settings" for the SIMATIC project (Page 85)"
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7.2 Views in SIMATIC Manager

7.2.1 Process devices plant view

7.2.1.1 Opening the process devices plant view
The process devices plant view provides an overview of all configured devices in all configured 
networks.

This view is used to obtain a quick overview of the configured devices. You cannot configure 
new networks in this view.

Opening the process device plant view
1. Select the View > Process device plant view menu command in SIMATIC Manager. 

The process device plant view opens. The table shows all devices which are subordinate 
to the current project.
If a project is part of a multiproject, the plant view of the multiproject opens.

7.2.1.2 Messages
Opens the "Messages" dialog box.

Additional information
Section "Message log (Page 156)"
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7.2.1.3 Adapting the process device plant view

Display devices only
1. To hide all signal modules, interface modules and link modules, select View > Display 

devices only in the process device plant view.
Only the AFDiSD modules are displayed.
The display is reset when the process device plant view is called again.

Display devices with same name
1. To only display devices with names that appear multiple times, select View > Display 

devices with same name in the process device plant view.
Devices with names that only appear once are hidden.
The display is reset when the process device plant view is called again.

7.2.2 Process devices network view
The process devices network view displays the devices in groups according to the network 
topology. 

You can configure smaller projects directly in the process devices network view, for example, 
for end-to-end connections between a PC and a device in the factory.

Opening the process device network view
1. Select the View > Process device network view menu command in SIMATIC Manager. 

The process device network view opens.

See also
"Settings" for the SIMATIC project (Page 85)
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7.2.3 Project synchronization

HW Config
In the course of device configuration in HW Config, an image of the plant structure, including 
all devices which can be configured using SIMATIC PDM, is transferred from HW Config to 
the process devices network view. 

After saving in HW Config, the changes made to the devices are applied in the following views:

● Process devices network view

● Process devices plant view

Changes cannot be incorporated into the process devices view if the higher-level objects are 
linked with HW Config to an existing S7 station.
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7.3 Views in SIMATIC PDM

7.3.1 Main Window "SIMATIC PDM"

Introduction
The "SIMATIC PDM" main window remains on the screen throughout the work session and is 
partially or totally covered by other activated dialog windows.

The main window is structured as follows:
Title bar (Page 72): The title bar shows the project name or the name of the object which was selected 
before SIMATIC PDM was opened.
Menu bar (Page 72): The menu bar can be used to call SIMATIC PDM functions and manufacturer-
specific device functions.
Toolbar (Page 73): The toolbar provides quick access to a few menu commands.
Structure view (Page 73): The objects dis‐
played depend on the object which was se‐
lected before SIMATIC PDM was started.

Parameter table (Page 74): The parameters for the ob‐
ject selected in the structure view are displayed in a ta‐
ble.

Status bar (Page 78): Contains information on the current processes.
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7.3.2 Title bar
The title bar shows the name of the object which was selected before SIMATIC PDM was 
called.

7.3.3 Menu bar

Structure
Below is an overview of the SIMATIC PDM menus.

Menu Submenu in parameter assignment mode
File ● Save (Page 175)

● Exporting (Page 230)
● Importing (Page 231)
● Print (Page 183)
● Exit (Page 183)

Device ● Download to device (Page 186)
● Upload to PG/PC (Page 188)
● Assign address and TAG (Page 191)
● Value comparison (Page 193)
● Object properties (Page 195)
● Calibration log (Page 199)
● Change log (Page 207)

View ● Process variables (Page 215)
● Start LifeList  (Page 145)
● Trends (Page 216) (depends on device)

Diagnostics ● Update diagnostics (Page 219)
Help ● Contents (Page 222)

● Help for device parameters (Page 222)
● Info (Page 222)
● Find (Page 222)
● Document Manager (Page 222)
● Device manual (depends on device)
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7.3.4 Toolbar
The toolbar is located below the menu bar and contains a number of icons with which you can 
quickly perform frequently used menu commands without having to open a menu and select 
the command. 

SIMATIC PDM mode Icons
Parameter assignment mode

Icons     
The icons are linked to the following commands:

Parameter assignment mode Menu command
Save (Page 175) 

Print (Page 183) 

Download to device (Page 231) 

Upload to PG/PC (Page 232) 

Value comparison (Page 193) 

Change log (Page 207) 

Device not checked (gray)/Device checked (Page 211) (green)

Process variables / Measured value display (depends on device) 
(Page 215) 
Update diagnostics (Page 219) 

Start LifeList (Page 145) 

Find (Page 222)

Contents (Page 222) 

7.3.5 Structure view
The left-hand section of the main window in the structure view contains a tree structure. The 
objects displayed depend on the object which was selected before SIMATIC PDM was started.

● If a single field device was selected, it will be displayed in the structure view. You can find 
information on this in the section "Stand-alone device view (Page 79)".

● If a network or gateway (e.g., DP/PA-Link) was selected, the tree structure is displayed with 
the associated devices in the structure view. You can find information on this in the section 
"Multiple devices view (Page 80)".
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Icons     
You can see the following status icons in front of the objects in the tree view:

Icon Meaning
The device has been loaded.

At least one parameter of the object has been changed.

At least one parameter of the object is defective.

Display
The following are displayed in the structure view:

● Objects with associated parameter groups

● Any available lower-level objects

The selected parameter group is displayed on a blue background. The parameter table shows 
the parameters of the selected parameter group. 

Objects that contain lower-level objects can be identified by the check boxes next to the object 
icon:

● Check box "+"

● Check box "-"

Note

Generally speaking, the table is only opened down to the structure view. 

Move the parameter table in order to view all the general information for a device.

7.3.6 Parameter table

The right pane of the main window is filled by the parameter table.

The parameter table shows a device's parameters in the order in which they are listed in the 
structure view. Unlike in the structure tree, no hierarchy is displayed here.

Device parameters
The parameters which can be edited depend on the device in question. Fields with a gray 
background cannot be edited.

Refer to the manufacturer device description for information on how to set the device 
parameters. 
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Display of the parameter table
The following columns are displayed in the parameter table:

● Parameter (Page 75)

● Value (Page 75)

● Unit (Page 76)

● Status (Page 76)

Each parameter group starts with a header with the name of the group on a gray background. 
The indented header text indicates the classification level of the header. The parameter lines 
are positioned underneath the header.

Operator input
Any entries and changes made must be loaded to the devices in order for them to take effect.

If you click an object in the structure view, the associated parameters are displayed in the 
parameter table.

Additional information
● Section "Display in the views (Page 79)"

7.3.6.1 "Parameter" column of the parameter table
The names of the individual parameters are listed in the "Parameter" column.     

7.3.6.2 "Value" column of the parameter table
This column displays the value of the parameter whose name is in the "Name" (Page 75) 
column. This can be a numerical value, a physical unit, a status, or a designation.       

The "Value" box can only be edited if it has a white background. A box with a gray background 
indicates that the parameter is read-only and cannot be modified or written. 

● Right-click on the value to display a list of possible value settings for selection, provided 
that these value settings are specified in the device description.

● Enter a new value here or select a new setting from the drop-down list box.
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Shortcut menu
Right-click inside the parameter table to open one of the following fields: 

● An information box is shown for static fields if the cursor is located over a parameter in the 
"Parameter" column. 
Information is displayed to explain the meaning of the field or to explain the associated 
entry in the "Value" column.

● Selection of values from drop-down lists
The drop-down lists open when you select a corresponding value with the cursor and click 
on it.
Select the correct setting for your plant- and device-specific conditions.

● Shortcut menu for input boxes

Menu command Explanations/operating instructions
Minimum value ... Displays the minimum permitted value of the parameter. *) **)
Maximum value ... Displays the maximum permitted value of the parameter. *) **)
Default value ... Displays the default value of the parameter. *) **)
Distributing parame‐
ters

Starts the quantity operation (distributing parameters)

*) Click the value to transfer it to the parameter table.
**) There can be several minimum, maximum and default values.

Additional information
● Section "Distributing parameters (Page 77)"

7.3.6.3 "Unit" column of the parameter table
The "Unit" column displays the engineering unit of the numerical value present in the "Value" 
(Page 75) column.    

7.3.6.4 "Status" column of the parameter table
The "Status" column displays the status of the parameter whose name is in the "Name" 
(Page 75) column.       

The table below shows the icons that can be displayed here:

Icon Meaning Action that can trigger the sta‐
tus

- empty -
 

Value (Page 75) corresponds to the offline data storage 
system.

Save

Initialization running or status "OK".
Value was never changed.

Open new PDM object

The parameter has been changed by means of operator 
input, import, or internal methods.
Value was changed by user.

● Edit
● Dialogs

Views
7.3 Views in SIMATIC PDM

Help for SIMATIC PDM (V9.1)
76 Operating Manual, 02/2017, A5E39027365-AA



Icon Meaning Action that can trigger the sta‐
tus

The parameter could not be converted.
Value could not be converted following a change in the 
unit.

Edit

A parameter's value is defective.
An illegal value was detected the validity check (e.g., val‐
ue too high or too low)

Validity check of value

The parameter has been successfully loaded.
There is no difference between the loaded and the con‐
figured parameter.

● Download to device
● Upload to PG/PC

The parameter cannot be loaded, as a communication 
error is present.
● Error message when downloading to the device
● Error message when uploading to PG/PC

● Download to device
● Upload to PG/PC

7.3.6.5 Distributing parameters

Requirement
The parameter view is open.

Distributing parameters
To distribute parameters, follow these steps:

1. Click a parameter in the parameter table.

2. Right-click to open the shortcut menu.

3. Select "Distribute parameters".
The "Distribute parameters" dialog opens. All relevant devices are displayed in a list.

4. Select one or more devices in the list.
To select individual devices, select the check box in front of the device.
To select all devices, select the top check box in the header of the list.

5. Click on "Start".
To cancel the action, click on "Cancel".
To stop the action, click on "Close".

The parameter is transferred for the selected devices.
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Message log
When the parameters have been distributed, a dialog box and a message log appear. The 
following messages and statuses are shown in a table:

Symbol Class Status text Message
Error Action finished. Mes‐

sages and errors oc‐
curred.

<Action identifier>: Action failed. Object is locked.

Error Action finished. Mes‐
sages and errors oc‐
curred.

<Action identifier>: Action failed. <Error text according to error code>

Error Action finished. Mes‐
sages and errors oc‐
curred.

<Action identifier>: Action failed. <Error text according to error code>

Error Action finished. Mes‐
sages and errors oc‐
curred.

<Action identifier>: Variable 'X' could not be set because it is outside the valid 
range.

Informa‐
tion

Action finished. Mes‐
sages occurred.

<Action identifier>: Variable 'X' could not be set because it has different con‐
figurations.

Informa‐
tion

Action finished. Mes‐
sages occurred.

<Action identifier>: Variable 'X' could not be set because it has different con‐
figurations.

Warning Action finished. Mes‐
sages and warnings 
occurred.

<Action identifier>: Variable 'X' could not be set to 'Y'. The value was auto‐
matically changed to 'Z'.

Informa‐
tion

Action finished. Mes‐
sages occurred.

<Action identifier>: Variable 'X' was set to 'Y'.

7.3.7 Status bar
The status bar is located at the bottom of the main window

Display 
The following information is provided in the status bar:

1. User that is currently using SIMATIC PDM

2. PDM object on which information is currently shown in the parameter list (  the object is 
locked for editing in the current view or another user is currently making changes to the 
object)
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3. Diagnostics activated / deactivated

4. Identity check activated / deactivated

5. Processing status

6. Connection status for the object currently selected in the tree structure

7.3.8 Display 

7.3.8.1 Display in the views

Operating principle
You can open SIMATIC PDM for a device from SIMATIC Manager or HW Config.

After you open SIMATIC PDM, the table displays the values saved in the project. These values 
are projected values and default values of the object, which was selected before SIMATIC 
PDM was started.

All objects for which parameters can be assigned are displayed in the structure view, including 
the lower-level objects. Only the parameter table of the root object is initially displayed and 
can be edited (fields on white background). 

● Select an object in the structure view; its parameters are then shown in the parameter table, 
where they can be edited.

●  If an object has already been opened by a different user, a message is displayed that 
identifies the user who opened the object and the PC from which the object was opened. 
All fields of the parameter table then have a gray background and cannot be modified.

Note

Changes made to an object opened in SIMATIC PDM only take effect when you select the 
menu command File > Save.

The displays in the status bar and title bar depend on the object you have currently selected. 

Setting options for SIMATIC PDM
You can find information on this in the section "Settings for SIMATIC PDM (Page 258)".

7.3.8.2 Stand-alone device view
SIMATIC PDM is opened in the stand-alone device view if a device was selected before 
SIMATIC PDM was started. The device represents the base of the tree in the structure view. 

The main window is structured as follows:
Title bar
Menu bar
Toolbar
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The main window is structured as follows:
Parameter table (on the right in the main win‐
dow)

Status bar

Additional information
● Section "Main Window "SIMATIC PDM" (Page 71)"

7.3.8.3 Multiple devices view
SIMATIC PDM is opened in the multiple device view if an object with lower-level objects was 
selected before SIMATIC PDM was started, e.g. an ET 200 station with connected field 
devices. The object represents the base of the tree in the structure view.

The main window is structured as follows:
Title bar
Menu bar
Toolbar

Parameter table (on the right in the main win‐
dow)

Status bar

Display
When the multiple device view is opened, only the parameter table of the root object is 
displayed at first. You can edit all the displayed objects and their lower-level objects without 
opening SIMATIC PDM again. 

Additional information
● Section "Main Window "SIMATIC PDM" (Page 71)"
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7.3.9 Keyboard operation

Key shortcuts
The tables below list the key shortcuts.

Selecting menus via keys   

Key shortcut Function
<CTRL + S> Save (File menu) (Page 175) 
<CTRL + P> Print... (File menu) (Page 183) 
<Alt + X> For the menu which contains the underscored letter X
Underscored letter in 
the menu command

Assigned menu command

Key operation in dialog boxes     

Key shortcut Function
<Tab> To the next input field, from left to right and from top to bottom
Arrow keys Selected in the drop-down list
Spacebar Selects an object or cancels a selection

Key operation in help programs

Key shortcut Function
<Alt + F4> Closes the help window, return to the tool window

Selecting menu commands using shortcut keys
You can execute many menu commands by pressing the associated ALT key shortcut. Press 
the following keys in succession:

1. <Alt> key

2. The underscored letter of the required menu (e.g. <Alt>, <D> for the File menu - if the menu 
bar contains a File command). The menu opens.

3. Letter that is underlined in the desired menu command.
The submenus of the corresponding menu commands will be opened in the next steps. 
Repeat these actions until you have selected the entire menu command by typing in the 
relevant letters. 
You trigger the menu command as soon as you have entered the last letter of the shortcut 
keys. 
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Example

Menu Key shortcut
File <Alt> + <D>
Help <Alt> + <H>
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Functions 8
8.1 Introduction

Before you can work with SIMATIC PDM, you must create a project containing at least one 
PDM object in the SIMATIC Manager. Below the term "PDM object" refers to those objects 
that can be configured, have parameters assigned, or diagnosed with SIMATIC PDM. PDM 
objects are:

● Field devices

● Remote I/O stations (with/without modules or field devices)

● Networks containing field devices

Information about the creation process
● For information on creating a project, refer to the PCS 7/STEP 7 help.

● For information on creating PDM objects, please refer to the section "Inserting devices 
(Page 92)".

Requirements for working with SIMATIC PDM
● SIMATIC PDM is installed.

● The necessary license keys are available.

● The device descriptions have been integrated.

● There must be a connection to the corresponding network for online functions. You can 
find information about this in the section "Establishing connections to field devices 
(Page 21)".

Note
Access to the hardware configuration 

Only one user at a time may access HW Config within a project. It does not matter whether 
one and the same or several S7 stations are being configured (see also the readme notes 
regarding use in PCS 7).

Calling SIMATIC PDM

Where Requirement Function
SIMATIC Manager 
● Process device network view
● Process device plant view

Project containing PDM object 
has been created.
Select object 

Edit > Open object

HW Config Device is created. Double-click device
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Scope of functions
● Configuration and parameter assignment

– Integrating field devices into plants and networks

– Making project engineering settings for and configuring connections

– Making project engineering settings for and configuring devices

● Mini control and monitoring system for field devices

– Controlling and monitoring field devices

● Diagnostics

– Performing diagnostics on field device functions

– Performing diagnostics on networks

– Evaluating logs

Hardware configurations
Integration into a SIMATIC project enables you to create SIMATIC stations and field devices 
in HW Config. You can open SIMATIC PDM directly on the networks and subordinate field 
devices listed below:

● PROFIBUS DP

● PROFIBUS PA

● PROFINET IO

● Ethernet

● HART modem

● FOUNDATION Fieldbus

Assigning parameters and loading
In the case of offline parameter assignment, data relating to entries and changes made in 
SIMATIC PDM is saved in the project data. 

The inputs and changes will only become active after uploading the project data to the device.

The option for online parameter assignment depends on the device and must be stored in the 
device description. 

Entries and changes made in SIMATIC PDM must be loaded into the project.
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8.2 Project editing

8.2.1 "Settings" for the SIMATIC project
You will find the following views in SIMATIC Manager after the installation of SIMATIC PDM:

● Process device plant view

● Process device network view

Project settings
The project settings are made in the SIMATIC Manager. These settings apply to the SIMATIC 
project and SIMATIC PDM.

● Language for the menus and dialog boxes

● Default project view

● Display

● Details in the columns

Make the project settings In SIMATIC Manager using the following menu command: Options 
> Settings...

Settings Tab Meaning
Language selection "Language" tab Language displayed in the menus and dialog boxes in the SIMATIC 

Manager and SIMATIC PDM
Default project view
 

"View" tab Start view for the SIMATIC Manager: Available views of SIMATIC 
PDM:
● Process device plant view
● Process device network view

Details in the columns "Columns" tab Views and object types in the parameter table

"Columns" tab
On the "Columns" tab, you can select the columns that you want to be displayed in a PDM 
view.

Select an object type in the tree structure. Then go to the "Visible Columns" list and activate 
the check boxes for the entries you want to be displayed for the selected object type.

Object types

● Type 1 in the tree structure

– Process device plant view

– Process device network view

● Type 2 in the tree structure

– Process device plant view > Devices
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● Type 3

– Process device network view > Networks

● Type 4

– Process device network view > Networks > PC

● Type 5

– Process device network view > Networks > Communication network

– Process device network view > Networks > Communication network > Object(on all 
subordinate levels)

 Visible columns
Object type Type 1 Type 2 Type 3 Type 4 Type 5
Object name Standard Standard Standard Standard Standard
Picture Name For OS Standard - - - -
LID
(Location identifier denotes the 
installation position of a device)

- Standard - - -

Address - x - Standard Standard
Description Standard Standard Standard Standard Standard
Message Standard Standard Standard Standard Standard
Device status - Standard - - Standard
Last communication - Standard - - Standard
Text1 x x x x x
Text2 x x x x x
Text3 x x x x x
Device - Standard x x Standard
PLT ID* - Standard - - x
Manufacturer - Standard - - Standard
Serial number - x - - x
Installation date - x - - x
Hardware version - x - - x
Software version - x - - x
Article number - x - - x
Object status - Standard - - Standard
DD revision - x - - x
Author x x x x x
Revision date Standard Standard Standard Standard Standard
Comment x x x x x

*Process control ID generated internally by PDM for identification of an object for connections 
to the Asset Management System (PCS 7 Maintenance Station and PDM Maintenance 
Station).

Functions
8.2 Project editing

Help for SIMATIC PDM (V9.1)
86 Operating Manual, 02/2017, A5E39027365-AA



● Type 6

– Settings for a multiproject

 Process device plant view (multiproject) Process device network view (multiproject)
Object name Standard Standard
Project language Standard Standard
UNC path Standard Standard
Path to "Computer" Standard Standard
Computer Standard Standard
Computer after removal Standard Standard
Path after removal Standard Standard

See also
Settings for SIMATIC PDM (Page 258)

Menus and dialog boxes for SIMATIC PDM in the SIMATIC Manager (Page 225)

8.2.2 Setting the interface on the computer
Use the interface settings of the project (SIMATIC PCS 7 or SIMATIC STEP 7).

The following interface types are used in SIMATIC PCS 7 and SIMATIC STEP 7:

● PROFIBUS DP interface

● Ethernet interface

● COM interface

Alternative communication channels in the case of redundant S7-400 stations
If SIMATIC PDM signals a connection failure due to a fault in the communication channel, an 
attempt is made to automatically establish a connection using the redundant S7-400 station 
via an alternative communication channel.

8.2.3 Plant-wide communication by means of routing

Overview   
In most automation systems, the programming device can only be operated via the bus cable 
(subnet) connected directly to the automation system. On larger networked plants you must 
connect the programming device to different bus cables (subnets) before you can go online to 
a remote automation system.
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Routing function
The routing function allows you to reach automation systems online across subnet boundaries 
from a central point (Engineering Station) with the programming device or PC, in order, for 
example, to download user programs or a hardware configuration or to perform test functions. 

Requirements
The following conditions must be met for S7 routing: 

● STEP 7 as of version 5.5 and SIMATIC PDM, i.e., SIMATIC PDM, are integrated.

● The communication-capable modules (CPUs or CPs) which establish gateways between 
subnets must support "S7 routing".

● All the automation devices or communications partners that can be reached in a plant 
network are configured and downloaded within an S7 project.

● The SIMATIC S7 station required is networked and can be reached via the network nodes.

● The last communication interface (CPU, CP) supports the "Dataset gateway" function.

● The modules are downloaded together with the configuration information, which contains 
the current "knowledge" on the complete network configuration of the project.
Reason: All the modules involved in the gateway must receive information on which subnets 
can be reached over which routes (routing tables).

● The programming device or PC to which you want to establish an online connection via a 
gateway is configured in the network configuration and assigned to your programming 
device.

Additional information
SIMATIC documentation; SIMATIC PDM; pdm-readme

8.2.4 Checking the device integration
You can check in a project whether the required device descriptions are integrated for all 
objects to be displayed in SIMATIC PDM. 

These situations serve as examples for this:

● A project has been copied to the PDM computer.

● Device descriptions have been deleted on the computer.

● A computer has been reinstalled and the device descriptions were not integrated.

Requirement
SIMATIC PDM is installed.
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Procedure
1. Open the process devices plant view in SIMATIC Manager.

2. Open the "Devices" folder in the tree.

3. Check whether devices are there that are labeled as follows:

Icon Meaning Note
Deactivated No device description is integrated in SIMATIC PDM for the 

device.

4. If deactivated devices have been found, select the View > Details menu command.

5. Check the information in the "Object name" column.

Information in the "Ob‐
ject name" column

Meaning Further procedure

"TAG" or "Default" A device description from the 
device catalog has not yet 
been assigned to the device.

Assign the required device description 
to the device. 
Section "Device selection (Reassign) 
(Page 233)" 

Plant-specific object 
name

The device description that 
has been assigned to the de‐
vice cannot be found or is no 
longer functional (e.g. acci‐
dentally deleted). 

Integrate the required device descrip‐
tion.
Section "Integrating device descriptions 
(Page 51)"

Additional information
● Section "Overview of Device Icons (Page 140)"

● Section "Replacing devices (Page 121)"

● Section "Completing a device description (Page 52)"

● Section "Cleaning the project (reorganization)  (Page 90)"

8.2.5 Print
You can print out the parameter list for a device. 
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Setting the printer options

Note

Note the following:
● The printer options depend on your computer's operating system and on the printer being 

used.
● The file is sent to the default printer.
● If the printout has more than one page, two periods are printed after the page number in 

the bottom right corner of the page. The last page does not have these periods, indicating 
no more pages are to follow.

Requirements
● SIMATIC PDM is open.

● In the structure view, an object is selected in the root folder of a device.
You can find information on the structure view in the section "Stand-alone device view 
(Page 79)".

Procedure
1. Select the menu command File > Print or click the "Print" button .

The "Print" dialog box opens.

2. Select the required options.

3. Click "OK".

8.2.6 Cleaning the project (reorganization) 
PDM objects can be contained in copied SIMATIC projects. If SIMATIC PDM will no longer be 
used in the project, you can remove the requirement for TAG licenses in the project using the 
"Reorganize" function. 

Note

SIMATIC PDM must be closed before you use the "Reorganize" function.

The time it takes to perform reorganization depends on the data movement required, and it 
can be a long time. The function is therefore not carried out automatically (for example, when 
closing a project).

Procedure
In SIMATIC Manager, select the menu command File > Reorganize.
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8.2.7 Saving the configuration
Changes that are made with SIMATIC PDM are always stored in the SIMATIC project.

Save the SIMATIC project to save the changes. Stop SIMATIC PDM before you save an entire 
SIMATIC project.

Procedure
Select the menu command File > Save As in the SIMATIC Manager.

Additional information
● STEP 7 Online Help

● PCS 7 Online Help
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8.3 Device management 

8.3.1 Inserting devices

8.3.1.1 Inserting objects
You can use the "Insert New Object" function to perform the following:

● Create networks, including network components

● Insert objects into a configured network:

– Insert an individual device or module

– Insert multiple devices or modules at the same time

Note

This function is only available for the following devices:
● PROFIBUS devices
● PROFINET devices
● HART modem devices
● HART devices downstream of a remote I/O

Configure FOUNDATION Fieldbus devices in HW Config.

Requirements
● The project is open in the process device network view.  

● The PDM folder called "Networks" is available in the tree structure. 
If the folder structure has not yet been created, select the menu command Insert New Object 
followed by Networks.

Note

Licenses for SIMATIC PDM are required for further processing.
Without license keys, you can configure a maximum of 4 devices (demo mode).

Inserting a network, a header module, modules, and a field device
Follow the steps below to insert objects into higher-level objects one after the other. You will 
find more information on object types that can be inserted in an object in the section ""Insert 
Object - Assign Device Type" dialog box (Page 94) ". 

Procedure
1. Select the higher-level object in the tree structure in the window on the left.

2. In the shortcut menu, select the menu command Insert New Object > Object. 
The "Insert Object - <...>" dialog box opens.
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3. Make the relevant settings for the inserted object. You can find information on this in the 
section ""Insert object - ..." dialog box (Page 93)"

– "Object name" input box

– "<Address>" input box (e.g., PROFIBUS address or PROFINET IP address)

– "Number" input box

4. Click the "Assign Device Type" button. 
The "Insert Object - Assign Device Type" dialog box opens.
You can find additional information on this in the section ""Insert Object - Assign Device 
Type" dialog box (Page 94)".

5. Select the object to be added from the tree structure.

6. Click "OK".
The objects are inserted.

7. Correct the assigned addresses if necessary.
You can find additional information on this in the section "Setting the bus address in HW 
Config (Page 99)".

Additional information
Section "Device selection (Reassign) (Page 233)".

8.3.1.2 "Insert object - ..." dialog box
Make the settings for inserted objects in the "Insert Object - <...>" dialog box.
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Setting parameters
You must set the following parameters in order to insert objects:

● Object name
Specify the name of the inserted object.
The entered name is the base name when creating several objects.

● <Address>  (e.g., PROFIBUS address or PROFINET IP address)

Note

This setting cannot be changed when HART devices are added.

– Enter the address for the inserted object.

– If you wish to create multiple objects, enter the first address of the objects to be inserted.

● Number 

Note

This setting cannot be changed when HART devices are added.

Adjust the number of objects to be added when adding several objects. Please note that 
the value depends on the network being used and other factors.
A certain number (n) of objects of one type is created in accordance with these parameters. 
The object name is generated as follows:

– If the number is equal to 1, the address does not appear in the object name that is 
generated (<name>).
<name><address>

– If the number is greater than 1:

PROFIBUS devices and modules Channels of remote I/O
<address><name> <name><address>
... ...
<address +(n*-1)><name> <name><address +(n*-1)> 
*: n corresponds to the number of objects to be inserted

"Assign Device Type" button
The "Insert Object - Assign Device Type" dialog box opens.
Assign a specific object type to the object you want to insert in the project. The possible object 
types are listed in the tree structure. The object types displayed depend on the location at 
which an object was inserted. 

8.3.1.3 "Insert Object - Assign Device Type" dialog box
Select the device description file of the desired device in this dialog box. 
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The devices are structured by the device types in a tree structure. 

Note
Integrated devices

You can only select devices for which a device description file has been integrated via the 
Device Integration Manager.

Object types
When assigning objects, select the object type. The following object types can be assigned, 
depending on the nature of the higher-level object:

Higher-level object Object to be inserted
PDM "Networks" folder Communications network

● As part of the assignment process, select the 
communications network via which the PDM objects 
are to be connected.

● Selection:
– PROFIBUS DP network
– PROFIBUS link
– PROFINET network
– MODBUS
– Ethernet
– HART modem network
– HART server
– FOUNDATION Fieldbus network

Header module 
● Selection:

– Remote I/O
– PROFIBUS Link
– PROFIBUS DP device
– PROFIBUS PA device
– HART device

Remote I/O Modules 
● Selection:

– Module
Modules 
● Selection:

– Module

Field device 
● HART device

"Device identification" Button
When you click this button, a connection to the device is established and an attempt is made 
to read the information from the device. If not all the required information could be read out, 
the tree structure includes a preselection with paths designed for the device. Select one of 
these paths. 
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Device identification procedure:

● For PA devices:
Select the "PROFIBUS PA" folder and then press the "Device identification" button

● For DP devices:
Select the "PROFIBUS DP" folder and then press the "Device identification" button
If device identification is not unique, select the required device in the result list and click 
the "Device identification" button again. 

● For HART devices:
Select the "HART" folder and then press the "Device identification" button

Additional information
● Section "Integrating devices into SIMATIC PDM (Page 41)"

8.3.1.4 Integrating a device in HW Config
Below, you will learn how to insert devices in the project using HW Config: 

● Inserting a DP device

● Inserting a DP remote I/O system (distributed I/O)

● Inserting a PA device at a DP/PA coupler

● Inserting a PA device at a DP/PA-Link

● Inserting a PA remote I/O system (distributed I/O)

● Inserting a remote I/O system (PROFINET)
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Requirement         
PROFIBUS DP master system or PROFINET IO system
Options for creating the PROFIBUS DP master system:

● In HW Config:
If the DP master system is not displayed, select the menu command Insert > Master 
system at the required PROFIBUS module.

● In the process device network view:

– Open the process device network view in SIMATIC Manager.

– Double-click the "Networks" object in the right window to insert a PROFIBUS DP 
network. Select "Networks" in the left window, and select the menu command Insert 
New Object > Object in the shortcut menu.

– Click the "Assign Device Type" button.
The "Insert object - Assign device type" dialog box opens.
You can find additional information on this in the section ""Insert Object - Assign Device 
Type" dialog box (Page 94)".

– Select the PROFIBUS DP network from the tree structure.

– Click "OK".
The PROFIBUS DP network is inserted.

Note
Representation in HW Config

Objects created in the process device network view are not displayed in HW Config.

Inserting a DP device
PROFIBUS devices can be inserted directly into the PROFIBUS DP master system. 

1. Select the device you require under "PROFIBUS DP" in the hardware catalog and drag it 
onto the DP master system.

Inserting a DP remote I/O system (distributed I/O) 
Integration is described based on the example of ET 200iSP . 

1. Place the head-end station "IM152-1" you have selected from the hardware catalog under 
"PROFIBUS DP > ET200iSP" at the DP master system.
The slots of the head-end station are displayed in the detail view in the table below the 
graphic. 

2. You can insert the required analog and digital modules in slot 4 and higher.
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Inserting a PA device at a DP/PA coupler 
1. Select a device in the PROFIBUS-PA folder of the hardware catalog.

This can be, for example, a SITRANS P pressure transmitter listed under "PROFIBUS-PA 
> Siemens > Sensors > Pressure > SITRANS P" or a device profile listed under "PROFIBUS-
PA > Other".

2. Position it at the PROFIBUS DP master system.
You have to select the device for some objects. You can find information on this in the 
section ""Insert Object - Assign Device Type" dialog box (Page 94)".

Note

The DP/PA coupler does not need to be configured; you only need to set an appropriate 
bus transmission rate (for example, 45.45 kbps for the Siemens coupler) for the DP master 
system.

Inserting a PA device at a DP/PA-Link 
1. Place the "IM 153-2" you have selected from the hardware catalog under "PROFIBUS DP 

> DP/PA-Link" at the DP master system. (The IM 153-2 replaces the IM 157, but both types 
can be used as PROFIBUS-Link ).
HW Config creates a PA master system for the DP/PA-Link . 

2. Drag-and-drop the PA devices to this PA master system.
For certain objects it is necessary to select the device. You can find information on this in 
the section ""Insert Object - Assign Device Type" dialog box (Page 94)".

Inserting a PA remote I/O system (distributed I/O) 
Integration is described based on the Pepperl+Fuchs example. 

1. You can find the "RSD-GW-EX1.PA" head-end station in the hardware catalog under 
"PROFIBUS-PA\REMOTE I/O\PEPPERL+FUCHS GmbH\ P+F I/O System".
Place the head-end station on the DP master system (with DP/PA coupler, see above) or 
on the PA master system (with DP/PA-Link, see above).
The slots of the head-end station are displayed in the detail view in the table below the 
graphic. 

2. Place one of the modules listed in the hardware catalog under "PROFIBUS-PA > P+F I/
O SYSTEM > RSD-GW-EX1.PA" in a free slot.

Inserting a remote I/O system (PROFINET) 
The integration is described using ET 200M as an example. 

1. Place the head-end station "IM153-4" you have selected from the hardware catalog under 
"PROFINET IO > I/O > ET200M" at the IO system.

2. The slots of the head-end station are displayed in the detail view in the table below the 
graphic. You can insert the required analog and digital modules in slot 4 and higher.
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8.3.1.5 Setting the bus address in HW Config
Make sure the bus addresses of all field devices are entered correctly in HW Config. 

Bus addresses can only be set for field devices on a PROFIBUS network.

Procedure
Proceed as follows to edit the settings:

1. Select a field device in HW Config. In the shortcut menu, select the menu command Object 
Properties.
The "Properties - ..." dialog box opens.

2. Click the button for the associated bus system in the "Node/ ...system" area.
The "Properties - ...Interface <field device>" dialog box opens.

3. Enter the desired bus address. 
HW Config automatically assigns addresses in the order in which objects are created. You 
may need to correct these addresses, depending on the device used (refer to the device 
manual).
Click the "OK" button to save the address.

4. Click "OK" to close the "Properties - ..." dialog boxes.

5. Save the project with the menu command Station > Save.

8.3.1.6 Integrating a HART device in a HART modem network

Figure 8-1 HART modem

The following describes how to integrate a HART device in a HART modem network. 

Requirements
● A project has been created.

● The device description files (EDD) for planned or already installed field devices are available 
in SIMATIC PDM.

● An access point of the computer is set to the COM port to which the HART modem network 
is connected.
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Integrating a HART device in a HART modem network 
1. Open the project in the process device network view.

2. Right-click the "Networks" object in the tree structure. In the shortcut menu that opens, 
select the menu command Insert New Object > Communication network.
The "Insert Object(s) - <...>" dialog box opens.

3. Click the "Assign Device Type" button.
The "Insert Object(s) - Assign Device Type" dialog box opens. You can find additional 
information in the section "Insert Object - Assign Device Type" dialog box (Page 94).

4. To set the network properties, select the inserted HART modem network in the right window 
and right-click. Select the entry Object Properties in the displayed shortcut menu. 

5. Enter the device-specific information in the "Communication" tab of the Properties dialog 
for the HART modem network. 
Set the master type (primary or secondary, usually secondary):
Here, you can select the "Prefer 'Long address'" check box.

6. To check if the correct network and the correct port are assigned to the COM interface, 
double-click the "PC" object in the right window. Select the "COM interface" object in HW 
Config, and select the Object Properties menu command in the shortcut menu. 

Note

The COM port is almost always "1" for notebooks. Since most PCs have two COM ports, 
you must specify the port to which the HART modem is connected in this tab. Check whether 
the settings for the FIFO buffer of the COM port are suitable, or immediately use a USB 
HART modem.

7. To insert the HART device, select the "HART modem network" object in the right window 
and right-click. In the displayed shortcut menu, select the Insert New Object > Object 
command. 
In the displayed dialog box, enter the name of the HART device.

8. To set the device address, select the inserted HART device in the right window and right-
click. Select the entry Object Properties in the displayed shortcut menu. 

9. Enter the device-specific information (long address) in the "Communication" tab of the 
Properties dialog for the HART device.

Note
Address with HART

The information must correspond to the connected device.
● The short address must be entered for HART devices. This address must correspond 

to the connected HART device. The short address is always "0", unless the device is in 
the multi-drop function.

● For a HART interface, enter the long address. This address contains the following 
device-specific information: 
– Manufacturer
– Device type
– Device name
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10.To change the device address, select the inserted HART device in the right window and 
then select the Object properties menu command in the shortcut menu. Select the 
"Communication" tab in the displayed dialog and enter the new short address.

Note

The address must correspond to the connected device. The short address for HART 
devices is always "0" unless the device is in the multi-drop function.

11.Start SIMATIC PDM by double-clicking the newly inserted HART device in the right window. 
Select the relevant device in the tree view (only required the first time the device is called), 
and assign parameters for the device.

Note
Multiple PCs in one project

If there are several PCs in your project, you have to define one of them as the current one. 
To do this, select the desired "PC" object in the left window and then select the menu 
command Options > Define Current PC.

8.3.1.7 Integrating a MODBUS device in a MODBUS network

The following paragraph describes how you integrate a MODBUS device in a MODBUS 
network. 

Requirements
● A project has been created.

● The device description files (EDD) for planned or already installed field devices are available 
in SIMATIC PDM.

Integrating a MODBUS device in a MODBUS network 
1. Open the project in the process device network view.

2. Right-click the "Networks" object in the tree structure. In the shortcut menu that opens, 
select the menu command Insert New Object > Communication network.
The "Insert Object(s) - <...>" dialog box opens.

3. Click the "Assign Device Type" button.
The "Insert Object(s) - Assign Device Type" dialog box opens. You can find additional 
information in the section "Insert Object - Assign Device Type" dialog box (Page 94).

4. To set the network properties, select the inserted MODBUS network in the right window 
and right-click. Select the entry Object Properties in the displayed shortcut menu. 
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5. Enter the device-specific information in the "Communication" tab of the Properties dialog 
for the MODBUS network.

MODBUS communication type: Serial or IrDA (infrared)
Serial The interface must be set accordingly on the PC station.
IrDA No additional setting required.

Once the device is within range, it is available for MODBUS communication.
Only one infrared device can be coupled to MODBUS at a given time. Several 
devices can be coupled under Windows.

Response time General timeout within which the device is allowed to report. If the timeout is too 
long, the communication is slowed. If it is too short, some devices may not be 
found.

6. To check if the correct network and the correct port are assigned to the COM interface, 
double-click the "PC" object in the right window. Select the "COM interface" object in HW 
Config, and select the Object Properties menu command in the shortcut menu. 

Note

The COM port is almost always "1" for notebooks. Since most PCs have two COM ports, 
you have to specify which port the device is connected to in this tab.

7. To insert the MODBUS device, select the "MODBUS network" object in the right window 
and right-click. In the displayed shortcut menu, select the Insert New Object > Object 
command. 
In the displayed dialog box, enter the name of the MODBUS device.

8. To set the device address, select the inserted MODBUS device in the right window and 
right-click. Select the entry Object Properties in the displayed shortcut menu.

9. Enter the device-specific information (MODBUS address 0-247) in the "Communication" 
tab of the Properties dialog for the MODBUS device.

10.To change the device address, select the inserted MODBUS device in the right window 
and then select the Object Properties menu command in the shortcut menu. Select the 
"Communication" tab in the displayed dialog and enter the new short address.

11.Start SIMATIC PDM by double-clicking the newly inserted MODBUS device in the right 
window. Select the relevant device in the tree view (only required the first time the device 
is called), and assign parameters for the device.

Note
Multiple PCs in one project

If there are several PCs in your project, you have to define one of them as the current one. 
To do this, select the desired "PC" object in the left window and then select the menu 
command Options > Define Current PC.

8.3.1.8 Integrating an S7 DSGW gateway
The procedure for integrating an S7 DSGW gateway is described below. 
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Requirements
● A project has been created.

● The device description files (EDD) for planned or already installed field devices are available 
in SIMATIC PDM.

Integrating an S7 DSGW network component
1. Open the project in the process device network view.

2. Right-click the "Networks" object in the tree structure. In the shortcut menu that opens, 
select the menu command Insert New Object > Communication network.
The "Insert Object(s) - <...>" dialog box opens.

3. Click the "Assign Device Type" button.
The "Insert Object(s) - Assign Device Type" dialog box opens. You will find additional 
information in the section "Insert Object - Assign Device Type" dialog box (Page 94).

4. To set the network properties, select the inserted ETHERNET network in the right window 
and right-click. Select the entry Object Properties from the displayed shortcut menu. 

5. In the Properties dialog of the ETHERNET network, enter the device-specific data in the 
"Communication" tab.
The subnet ID is the same as was configured in HW Config.

6. To insert the S7 DSGW network component, select the "ETHERNET network" object in the 
right window and right-click. In the displayed shortcut menu, select the Insert New Object > 
Object command. In the dialog box that opens, enter the name of the S7 DSGW network 
component.

7. To set the device address, select the inserted S7 DSGW network component in the right 
window and right-click. Select the entry Object Properties from the displayed shortcut menu.

8. Enter the device-specific information (IP address) in the "Communication" tab of the 
Properties dialog of the S7 DSGW network component.

Creation of the "PROFIBUS DP network" object
Insert the "PROFIBUS DP network" object into the "S7 DSGW" object.

Importing/creating the project structure
1. Create the plant structure or import the DP structure of a project.

2. Configure the communication properties of the "PROFIBUS DP network" object.

– Subnet ID (the same ID that was configured in HW Config)

– PROFIBUS CP slot (slot number of the CP DP master)

– DP master address (DP address of the CP DP master)

Communication
Check whether communication is possible (e.g. Upload to PG/PC, download to device, online 
view).
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8.3.1.9 Integrating a HART server network
You can use SIMATIC PDM to configure HART devices for the following networks:

● Multiplexer networks  

– Multiplexer network with panel (for example, MTL multiplexer)

– Multiplexer network without panel (for example, P+F multiplexer)

● Wireless Hart gateway 
You configure a wireless HART gateway as a HART multiplexer. 

You need a HART server application in the project to integrate and manage these networks. 
You can find detailed information on the HART server in the description or the online help for 
this product.

● You can address multiplexers using the HART server. You can obtain more information 
from the device manufacturers.

● The HART server of SIMATIC PDM does not support multimaster operation. Jobs have to 
be coordinated to avoid conflicts. The coordination must take place on the multiplexer 
network level.

Requirement
● A HART server is installed on the computer.

● A multiplexer network has been integrated in the HART server.

● A project has been created in the SIMATIC Manager.

● The HART network is physically connected to the PC station.

Note
Integrating a HART multiplexer network

In the HART server, a project has to be created for the multiplexer in order for the 
configuration data of the multiplex to be available in the process device network view.

Starting the HART server application

Note
HART server

The HART server application should always be open before you configure or integrate HART 
devices.

Functions
8.3 Device management 

Help for SIMATIC PDM (V9.1)
104 Operating Manual, 02/2017, A5E39027365-AA



You have the following options for starting the HART server application:

● In SIMATIC Manager, select the menu command Options > SIMATIC PDM > HART server.

● In the Windows taskbar, select the menu command Start > Programs > HART server > 
HART server (path of the HART server created by SIMATIC PDM setup).

Note
Network address of the HART multiplexer

Enter the network address of the HART multiplexer in the HART server application when 
you create an I/O system in the HART network.

Starting the HART server application for the first time
To configure communication between SIMATIC PDM and the HART server, proceed as follows:

1. Select the HART server project. Select the menu command File > Preferences.
The "HART Server Preferences" dialog box opens.

2. In the "New Configuration Will Use" section, select the check box according to your settings 
in SIMATIC PDM.

3. Apply this setting also to the existing project, if required. After it has been applied to an 
existing project, the devices must be read in again with "Learn".

Note
SIMATIC PDM default settings

The default settings for HART communication in SIMATIC PDM correspond to the "8 char 
(HART 5), 32 char (HART 6 +)" check box. 
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Configuring the HART server
1. Select the HART server project. Right-click and select the shortcut menu command Add 

Network. In the dialog box that opens, select the type of network through which the objects 
are connected:

– Single Port RS485

– Single Serial Port

– TCP/UDP

2. Enter a name in the "Network Properties" field.
SIMATIC Manager later identifies the network based on this name. 
Set the properties of the interface under "Properties" and confirm your entries with "OK". 
The network is inserted in the project.

Note
TAG names

Ensure that the TAG names of the components do not contain a "." (dot).

3. You can read in the multiplexer data automatically or configure them manually.
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– Automatic reading:
Select the higher-level object. Right-click and select the shortcut menu command Learn. 
All data (multiplexers and devices) of the selected object are read. A dialog box shows 
the progress. 
While the addresses (multiplexer, etc.) are being checked, the status of all assigned 
addresses changes from "not responding" to "responding". If this does not happen, there 
is a connection error, such as incorrect polarity.

Note
Learning process in a HART server project

You can start the learning process on any level.
● When you select a network, you start the learning process for the entire configuration 

tree.
● If you select a panel, you start the learning process for the selected partial 

configuration, meaning for the instruments below the panel level.

Figure 8-2 Example 1: HART server project with serial multiplexers 

Figure 8-3 Example 2: HART server project with wireless HART gateway
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– Manual configuration:
If you want to create the configuration manually, select the project, followed by the 
shortcut menu command Add Device (or Add IO-System for Ethernet networks). Enter 
the required information in the dialog box.
Continue this procedure until all the devices have been configured.
The HART server automatically checks whether a HART multiplexer can be reached at 
the selected address: 
- If you reach a HART multiplexer, its properties are displayed. 
- Otherwise, a message is displayed stating that no connection could be established.
HART multiplexer with panel: Configure the address information for the panel before 
you configure the HART devices.

Inserting a HART server in a multiplexer network
1. Check whether the HART server is started.

2. Open the project in the process device network view.

3. Right-click and select the following shortcut menu command: Insert New Object > 
Communication network.
The "Insert Object - <Networks...>" dialog box opens. 

4. Click the button "Assign Device Type" > Object. 
The "Insert Object - <Networks...>" dialog box opens. Select "HART server" as the network 
type and click the "Assign Device Type" button.

5. Select the following shortcut menu command: SIMATIC PDM > Synchronize.
If you select the "Object with all subordinate objects and networks" option, all devices and 
multiplexers detected in the HART server are automatically applied to the project.
The hierarchy is transferred to the SIMATIC Manager. The levels shown there depend on 
the selected multiplexer (e.g. one or two levels). 

6. In the process device network view of SIMATIC Manager, insert the HART server in the 
HART multiplexer network and edit the individual devices.

Configuring the devices
Note the following:

● You can start a learning process for identification of the devices on the multiplexer and 
assign the device description files (EDD) automatically.

● You can manually configure the multiplexer and the devices. For this purpose, the devices 
and the computer must be connected and the device names and addresses must be known.

Changing the configuration
If, for example, you change an existing multiplexer network by inserting a new device or 
replacing a device (must be followed by reconfiguration in the HART server), you can compare 
the changes in the HART server with the menu command Edit > SIMATIC PDM > 
Synchronize. The synchronization function takes into account the following:

● New hierarchy and devices are inserted.

● Hierarchies and devices that no longer exist are removed.

● Renamed devices are also renamed in PDM.
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Wireless HART device on a Wireless HART gateway     
Wireless HART devices are integrated into HART multiplexer networks the same way as HART 
devices. 

IE/WSN-

PA LINK

SITRANS

AW210

SITRANS

AW200

SITRANS 

AW210

SITRANS 

TF280

SITRANS 

P280

Wireless 

HART

PDM

Ethernet

Renaming devices downstream from a HART server project
If you want to rename a device on a HART multiplexer, observe the order in which the actions 
must be performed:

1. Open the device with SIMATIC PDM.

2. Enter new TAG in PDM.

3. Select the following shortcut menu command: SIMATIC PDM > Download to device...

4. Save in PDM.
Saving automatically applies the changes to the HART server.

Additional information
Information on configuring the HART server application supplied with PDM can be found in 
the online help HART Server Help(Start > Programs > HART Server > HART Server Help).

For information on the structure, configuration, and commissioning of wireless HART devices 
on an IE/WSN PA link (WSN-PA Link link), refer to the following documentation:

● Operating instructions titled SIMATIC NET; IE/WSN PA Link
● Operating instructions titled SIMATIC NET; IE/WSN PA Link (Compact)
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8.3.1.10 Compact PROFIBUS device (sensors and actuators)

Procedure
To integrate a PROFIBUS device (PROFIBUS DP device, PROFIBUS PA device or 
PROFIBUS remote I/O), proceed as follows: 

Creating a network
1. Open the process device network view in SIMATIC Manager.

2. Select the "Networks" folder in the tree structure in the left window and select the Insert 
New Object > Object command from the shortcut menu.
The "Insert Object" dialog box opens.

3. Click the "Assign Device Type" button.

Inserting a PROFIBUS device or remote I/O
Follow the steps below to insert objects into higher-level objects one after the other.

Higher-level object Object to be inserted
"Networks" folder Type of network via which the field devices are connected 

to the automation system (e.g., PROFIBUS DP network).
PROFIBUS DP network PROFIBUS DP device / PROFIBUS PA device
Header module (selection: remote I/O) Modules (selection: module)
Modules (selection: module) Field device (selection: HART device)

1. Select the higher-level object in the tree structure in the window on the right.

2. In the shortcut menu, select the menu command Insert New Object > Object. 
The dialog box "<... SIMATIC PDM – Insert Object(s)" opens.
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3. In the dialog box that opens, enter the name of the process tag.

Note

Configure the PROFIBUS PA devices directly on the PROFIBUS network if you are using 
a PROFIBUS DP/PA coupler. The coupler itself is not configured (the DP/PA couplers with 
diagnostic capability as of 6ES7157-0AC84-0XA0 can be configured as a stand-alone 
device).

4. As an alternative, you can insert a PROFIBUS-Link (Y-Link or DP/PA-Link) in a 
PROFIBUS DP network. After the PROFIBUS-Link , you can insert PROFIBUS devices but 
no additional PROFIBUS-Link .

Note

The address of the PROFIBUS device that you set in the "Insert SIMATIC PDM Object(s)" 
dialog box can be changed afterwards on the "Communication" tab of the "Object 
Properties" dialog box.

Configuring devices with SIMATIC PDM
1. Select the inserted PROFIBUS device in the process device network view.

2. Select the Open object command in the shortcut menu.
SIMATIC PDM opens. The PROFIBUS device is shown in the structure view.

3. Set the required parameters for the function in the parameter table.

4. Make the necessary settings and save the object.

8.3.1.11 Modular PROFIBUS device (remote I/O)

Creating a network
1. Open the process device network view in SIMATIC Manager.

2. Double-click the "Networks" object in the right window to insert a PROFIBUS DP network. 
Select the "Networks" folder in the left window, and select the Insert New Object > 
Communications Network command in the shortcut menu.
The "Insert Object(s) - <...>" dialog box opens.

3. Click the "Assign device type" button.
The "Insert Object - Assign Device Type" dialog box opens.
You can find additional information on this in the section ""Insert Object - Assign Device 
Type" dialog box (Page 94)".

4. Select the PROFIBUS DP network from the tree structure.

5. Click "OK".
The PROFIBUS DP network is inserted.
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Adding remote I/O, module, and PROFIBUS device
Follow the steps below to insert objects into higher-level objects one after the other.

Higher-level object Object to be inserted
PROFIBUS DP network Header module (selection: remote I/O)
Header module (selection: remote I/O) Modules (selection: module)
Modules (selection: module) Field device (selection: PROFIBUS device)

1. Select the higher-level object in the tree structure in the window on the left.

2. In the shortcut menu, select the menu command Insert New Object > Object. 
The "Insert Object(s) - <...>" dialog box opens.

3. Make the following settings for the inserted object.
You can find additional information on this in the section "Inserting objects (Page 92)".

4. Select the object. Select the Object properties command in the shortcut menu.
The "Properties - <Inserted object>" dialog box opens.

5. Select the "Communication" tab.

6. Make the necessary settings depending on the inserted object in the input fields:

– Remote I/O: Enter the PROFIBUS address.

– Module (device module): Enter the slot.

– PROFIBUS devices: Do not make changes to the channel settings.

7. Repeat these steps until all remote I/O, modules, and PROFIBUS devices have been added.

Configuring devices with SIMATIC PDM
1. Select the PROFIBUS DP network in the process device network view, which is of a higher 

level than the added PROFIBUS devices.

2. Select the Open object command in the shortcut menu.
SIMATIC PDM opens. The PROFIBUS DP network is represented in the structure view.
You can find the remote I/O, modules, and PROFIBUS devices by opening the tree 
structure.

3. Assign a function individually to the added objects (corresponding with the actual 
configuration in HW Config and the connected equipment):

– Open the object by selecting its icon in the structure view.

– Select the parameters required for the function in the parameter table.
Make the required settings and save the object.
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Downloading
To transfer the configuration and parameters, select the "<Remote I/O>" object and then select 
the Device > Upload to PC/PG... menu command.

Note

The automatic detection of the <modules> depends on the type of <remote I/O>, the 
<modules>, and the device description.

8.3.1.12 Connecting a field device to PROFINET
To integrate distributed I/O devices (e.g. ET 200M) or links for connecting intelligent DP or PA 
field devices (e.g. IE/PB link) via PROFINET, follow these steps: 

       

Creating a network
1. Open the process device network view in SIMATIC Manager.

2. Select the "Networks" folder in the tree structure in the left window and select the Insert 
New Object > Object command from the shortcut menu.
The "Insert Object" dialog box opens.

3. Click the "Assign Device Type" button.

Inserting a field device or remote I/O
Follow the steps below to insert objects into higher-level objects one after the other. 

Higher-level object Object to be inserted
"Networks" folder Type of network via which the field devices are connected 

to the automation system (e.g., PROFINET network).
PROFINET network Header module (selection: remote I/O)
Header module (selection: remote I/O) Modules (selection: module)
Modules (selection: module) Field device (selection: HART device)

1. Select the higher-level object in the tree structure in the window on the right.

2. In the shortcut menu, select the menu command Insert New Object > Object. 
The dialog box "<... SIMATIC PDM – Insert Object(s)" opens.

3. In the dialog box that opens, enter the name of the process tag.
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Alternatively, you can add a IE/PB-Link  to a PROFINET network. Downstream of the IE/PB-
Link , you can then insert PROFIBUS devices . IE/PB-Links are only supported in HW Config 
in V8.0.

Note

The address of the PROFINET device that you set in the "Insert SIMATIC PDM Object(s)" 
dialog box can be changed afterwards on the "Communication" tab of the "Object Properties" 
dialog box.

Network topology

Configuring devices with SIMATIC PDM
1. Select the inserted PROFINET device in the process device network view.

2. Select the Open Object command from the shortcut menu.
SIMATIC PDM opens and the PROFINET device is shown in the structure view.

3. Set the required parameters for the function in the parameter table.

4. Make the necessary settings and save the object.

8.3.1.13 HART device on remote I/O
You can connect the HART devices to a suitable remote I/O module.
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Remote I/O with HART devices (PROFIBUS DP)

Creating the PDM basic folder called "Networks"
1. Open the process device network view in SIMATIC Manager.

2. If the "Networks" object has not been inserted in the tree structure, select the menu 
command Insert New Object and select the "Networks" object.

Note
PDM basic folder called "Networks"

SIMATIC PDM licenses must be available in the project when this folder is created.

Creating a communications network
1. Open the process device network view in SIMATIC Manager.

2. Select the "Networks" folder in the tree structure in the left window and select the Insert 
New Object > Object command from the shortcut menu.
The "Insert Object - <...>" dialog box opens.

3. Click the "Assign Device Type" button.

Inserting an object (creating a communications network; remote I/O, module, and HART device)
Follow the steps below to insert objects into higher-level objects one after the other.

Higher-level object Object to be inserted
"Networks" folder Type of network via which the field devices are connected 

to the automation system (e.g., PROFIBUS DP network or 
PROFINET).

PROFIBUS DP network Header module (selection: remote I/O)
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Higher-level object Object to be inserted
Header module (selection: remote I/O) Modules (selection: module)
Modules (selection: module) Field device (selection: HART device)

1. Select the higher-level object in the tree structure in the window on the left.

2. In the shortcut menu, select the menu command Insert New Object > Object. 
The "Insert Object - <...>" dialog box opens.

3. Make the following settings for the inserted object.
You can find additional information on this in the section "Inserting objects (Page 92)".

4. Select the object. In the shortcut menu, select the menu command Object Properties.
The dialog box "<Inserted Object> Properties" opens.

5. Select the "Communication" tab.

6. Apply the following settings to the input boxes:

– For the remote I/O: Enter the PROFIBUS address or the PROFINET IP address.

– For the module (HART module): Enter the slot.

– For the HART device: Do not make changes to the channel settings.

7. Repeat these steps until all remote I/O, modules, and HART devices have been added.

Configuring devices with SIMATIC PDM
1. In the process device network view, select the PROFIBUS DP network or the PROFINET 

network that is the higher-level network of the inserted HART devices.

2. Select the Open object command in the shortcut menu.
SIMATIC PDM opens. The PROFIBUS DP network or the PROFINET network is 
represented in the structure view.
You can find the remote I/O, modules, and HART devices by opening the tree structure.

3. Assign a function individually to the added objects (corresponding with the actual 
configuration in HW Config and the connected equipment):

– Open the object by selecting its icon in the structure view.

– Select the parameters required for the function in the parameter table.
Make the required settings and save the object.

Note

Objects can be detected automatically if an online connection exists to the devices. The 
automatic detection of the modules depends on the type of remote I/O, the modules 
used, and on the device description.
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Downloading
To transfer the configuration and parameters, select the "<Remote I/O>" object and then select 
the Device > Upload to PC/PG... menu command.

Note
Slot function settings

The automatic detection of the <modules> depends on the type of <remote I/O>, the 
<modules>, and the device description.

Configure lower-level objects
There may be instances where you have to assign a specific device from the catalog to an 
object before you can configure lower-level objects. You have to start SIMATIC PDM for the 
object to make the assignment (context-sensitive menu command "Open object").

Example: 

You insert a remote I/O and assign the respective device to it, for example, an ET 200iSP 
header module. Then, you configure the remote I/O module. Only after you have assigned a 
HART-capable module to this module can you insert a channel and a HART device. The pre-
defined module "unused slot" cannot include HART devices or channels.

8.3.1.14 Inserting a HART device at a HART module
The integration procedure is explained using the example of a HART device on an ET 200iSP 
HART module:         

Inserting a HART device based on the example of an ET 200iSP HART module 
1. Position an "IM152-1" you have selected from the hardware catalog under "PROFIBUS DP

\ET 200iSP" at the DP master system.
The detail view in the table below the graphic object displays the slots of ET 200iSP. 

2. Insert a HART module "4  AI  2WIRE  HART" from the hardware catalog under 
"PROFIBUS DP\ET 200iSP\IM 152-1\AI", into a free slot.
The HART module with 4 channels is shown in the detail view. 

3. Place the object listed in "...\AI\4  AI  2WIRE  HART\HART field device" in the detail view.
The PDM dialog "Device selection (Reassign) (Page 94)" opens.

4. Assign the device type to the inserted device (device description).

8.3.1.15 Integrating an FF field device
FF devices can be configured using SIMATIC PCS 7 from PCS 7 version 8.0 Update 1. 

Information on this can be found in the following documentation:
SIMATIC Process Control System PCS 7, PCS 7 - FOUNDATION Fieldbus
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8.3.2 Field devices with redundant bus connection 

8.3.2.1 Connecting field devices to a redundant bus system

Redundant connection of field devices with SIMATIC PDM
Some field devices allow redundant connection in the automation system. If information about 
this feature is stored in the device description, SIMATIC PDM can recognize this.

You can determine whether this feature can be configured in the "Properties" dialog box of the 
process device network view. With these objects, you will see a "Redundancy" area in the 
"Communication" tab.

Procedure
1. Configure an object for each of the bus addresses of a field device that can be connected 

redundantly.

Note
Applying the configuration

You are allowed to fully configure one object only (this is referred to as the "master field 
device" in the following). The other object must not contain substructures. This also applies 
if redundant partners have been configured in HW Config. In the case of remote I/O (e.g., 
P+F LB/FB RemoteIO), therefore, you should configure the modules in HW Config only 
after the redundancy selection.

For the second object, you only need to configure the bus address (this is referred to as 
the "partner field device" from this point forward). You can display only the master field 
device on the partner field device. You can find information on this in the section 
""Communication" tab (Page 197)".

2. Open the "Object Properties" dialog for the configured master field device in the process 
device network view. 

3. Open the "Communication" tab.

4. In the "Redundancy" section, click "Select Object".
The list of configured devices opens.

5. Select the partner field device.

6. Click "OK".
The list of configured devices closes. The "Enable redundancy" check box is selected in 
the "Redundancy" section and the partner field device is displayed.

Result
The master is the object on which the substructures are displayed, and redundancy can be 
deactivated again (deactivation only works if the redundant partners have not been configured 
in HW Config). No substructures are displayed at the partner.
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Canceling redundancy   
● Delete the partner field device.

● The master maintains all substructures and loses its master status.

Additional information
● Section ""Select object" dialog box (Page 119)"

● Section ""Properties - Find object" dialog box (Page 119)"

8.3.2.2 "Select object" dialog box
Use this dialog box to select the required comparison objects or partner objects. 

8.3.2.3 "Properties - Find object" dialog box
Some field devices can be connected to a redundant bus system. Two field device objects are 
created for these field devices.

The dialog box opens only if a partner object has been specified for the selected field device 
object.

Note

The partner object is labeled in the table after the dialog box opens.
● The dialog box provides information only. 
● You cannot make any changes in it.

See also
Connecting field devices to a redundant bus system (Page 118)

8.3.3 Using unspecified PROFIBUS PA devices as placeholders
This method can be used to configure PROFIBUS devices in a system, even though the type 
of device is not yet set at the time of configuration.

Create a placeholder for unknown devices. You should know the profile of the device to be 
used in the form of manufacturer information.

Device profiles:

● Profile3

● Profile I&M
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Basic preparation
1. Insert a number of objects for PROFIBUS profile devices of the appropriate type at the 

desired addresses in the process device network view in a PROFIBUS PA network. 
Examples:

– Sensor > Temperature > PROFILE3 > Profile3

– Siemens > SIEMENS > Profile I&M

2. Configure the ID data for the PROFIBUS devices in the object properties:

– TAG

– Description

– Message

Commissioning PROFIBUS devices
1. Connect the PROFIBUS devices in the automation system.

2. Select a device configured as a placeholder in the process device network view or in HW 
Config.

3. Download the configuration to the device (section "Download to device (Page 186)").

4. Assign the required device description to the device (section "Device selection (Reassign) 
(Page 233)"). Recommendation: Use the "Device identification" function.

5. Where required modify the device's online parameters.

6. Load the data from the device into the configuration (section "Upload to PG/PC 
(Page 188)").

7. Repeat steps 2 through 6 until all devices are configured.

8. Save the data in the project.

8.3.4 Creating typicals for parameters (import without ID data) 
You can use the following procedure to assign the parameters of an already configured device 
to identical devices.

Procedure
1. Open the process device network view.

2. Select a configured device or the network in which the configured devices are located.

3. In SIMATIC Manager, select the menu command Edit > SIMATIC PDM > Export.

4. Select the data for export.
You can find information on this in the section "Exporting (Page 175)".

5. Perform the export.
A set of device-specific data is created for each device.
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6. Select a device to which new parameters are to be assigned in the process device network 
view or in HW Config.

7. Select the Import... command in the shortcut menu.
The "Import..." dialog box opens.

8. In the "Import file" input box, enter the XML file that contains the data for the required device.
The check for consistent device types is performed.

– Clear the "Import Identification data" check box. 
You can find information on this in the section "Importing (Page 179)".

9. Click the "Import" button.
The data record of the import file is not imported into the device completely. 
The following data is excluded from import:

– Device name

– Description

– Message

8.3.5 Replacing devices
You have several options for replacing devices with SIMATIC PDM.

Replacement of a device with one of the same type
This type of replacement involves replacement with compatible devices.
The device to be replaced can be operated with the device description of the device to be 
integrated (for example, after a firmware update). 

● The configuration can be downloaded to the device you want to integrate.
You can find information on this in the section "Download to device (Page 186)".

Replacing a device with a similar one
This type of replacement involves incompatible devices.

Parameters for which identical names are entered in the device description are applied in the 
configuration of the new device.

● You can find information on this in the section "Device selection (Reassign) (Page 233)"

Replacement via address change

Note
Typical service scenario

Manufacturers generally set devices to the service address 126 or deliver them with a user-
specific configuration.
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This type of replacement involves compatible devices. You can use this function to assign the 
address of a configured device to a device with the service address 126. 

● The device to be replaced can be operated with the device description of the device to be 
integrated (for example, after a firmware update).

● The configuration can be loaded to the device to be integrated.

Procedure (for PROFIBUS devices and FF devices)

Note
Restart

Changing the address will restart the device.

● Option 1 

– You use the "LifeList" function in order to find the replacement device.

– You assign the configuration to the replacement device via the LifeList function "Assign 
address and TAG...".

You can find additional information on this in the section ""LifeList - Assign address and 
TAG..." dialog (Page 152)".

● Option 2 

– You use the "Assign address and TAG..." function for a configured device in SIMATIC 
PDM.

– In the "Online" area enter the address of the replacement device located in the system 
(with service address 126).

You can find additional information on this in the section "Assign address and TAG 
(Page 190)".

8.3.6 Inserting plant-specific documents for process mode
You can assign up to 10 documents to one PDM object in the Document Manager.

To assign the documents, select the menu command Device > Object Properties > Document 
Manager.

To open the documents, select the SIMATIC PDM menu command Help > Document 
Manager. Use the mouse to select the required document from the submenu.
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Requirements
The following requirements must be met in order to assign and display documents:

● The documents are stored locally on the PC or are located on a connected network drive 
(designated by means of a letter). 
Connections involving http, ftp, and UNC paths are not supported.

● A display program is assigned to the document type in Windows on the PC.

● The user who wants to open a particular document has read rights to the document (as a 
minimum).

Procedure
To assign specific documents to a device, proceed as follows:

1. Open the object properties of the device.

2. Select the "Document Manager" tab.
Rows for a maximum of 10 documents are displayed.

Actions on the "Document Manager" tab

Action To execute
File 1. Click the "..." button.

2. Navigate to the document required.
3. Click "Open".

The storage path and file name of the selected file is displayed in 
the "File" box.

Title Enter a name for the document.
Test whether a document can be displayed. Select the menu command Open.
Remove a document from the list Select the menu command Delete.

8.3.7 Operating modes of field devices

Modes
Each device supports specific, different operating modes which can or cannot be toggled using 
SIMATIC PDM (depends on the interlock setup of the device).

The following operating modes are available:

Operating mode Description
Automatic The device is operating in cyclic mode on an AS master or is ready for this mode.
Manual The device is still operating in cyclic mode, however, the AS master rejects all 

additional process values. Working information is transferred "in situ" to the de‐
vice or by means of a dialog box in SIMATIC PDM.
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Operating mode Description
Simulation SIMATIC PDM provides a dialog box where you can set up the device as follows:

● The default sensor values are valid as output variables and are transferred 
to the AS master

or
● The actuation information for actuators is specified by SIMATIC PDM. The 

reaction is similar to that of "Manual" mode.
Test mode The test mode represents an extended type of internal simulation in the actual 

device. For sensors, for example, the actual sensor value is manipulated instead 
of the output value to the AS master. All calculations generated in auto mode are 
executed in the device and the device transfers all of its configured diagnostics 
messages to the AS master.

Failsafe The device goes into the failsafe mode if an error was detected during acquisition 
of a process variable.

The diagnostics icon of the device identifies the current operating mode. 

Additional information
You can find an overview of the diagnostics icons displayed in SIMATIC PDM in the section 
"Overview of Device Icons (Page 140)".

8.3.8 Deleting devices
An object is deleted from all the SIMATIC PDM configuration views as soon as you delete it 
from any of the following views: 

● HW Config
Devices that have been inserted in a project via HW Config can only be deleted in HW 
Config (Edit > Delete menu command).

● Process device network view and process device plant view
You can delete devices used once in both process device views. The synchronization 
between the process device views is done automatically. 

Note
Exception of objects used more than once  

Objects that can be used more than once (e.g., a device that can be configured with 
redundancy)
●  To remove redundancy, delete the partner configured as the slave. If you want to delete 

both redundant partners, both objects must be manually deleted.

8.3.9 Assigning parameters and downloading to devices
You assign parameters to devices in the parameter table.
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The data relating to entries and changes made in SIMATIC PDM is always created offline 
(saved in the project data). The data does not take effect in the device until the "Load to 
Devices" function has been performed. 

"Download to device" function
Downloads all device variables of a device object from the offline data storage to the devices. 
You can find information on this in the section ""Download to device - ..." dialog box 
(Page 187)".

Additional information
● Section "Parameter table (Page 74)"

● You will find information on FF devices in the section: "AUTOHOTSPOT" as well as in the 
PCS 7 FOUNDATION Fieldbus commissioning manual.

8.3.10 Interconnecting and downloading FF devices

8.3.10.1 "Interconnection Editor" dialog box

Note
Menu command "Start Connection Editor"         

The "Start Connection Editor" menu command is only enabled in HW Config for the bus link 
(FF Link or Compact FF Link) if the "PDM Foundation Fieldbus" license key is available.

You organize the interconnections for internal FOUNDATION Fieldbus communication in this 
dialog. The automation system does not participate in this communication. The name of this 
function is "Control in the Field" (CiF). CiF can be used to execute technological functions in 
an FF segment. 
Configure each CiF interconnection (hereafter referred to simply as interconnection) in the 
"Connection Editor" dialog. 

Internal device interconnections
FF devices have internal device blocks, such as measuring sensor, controller. The internal 
device interconnection of these blocks means that there is no communication load on the FF 
segment.

Structure
The "Connection Editor" dialog box is divided into the following columns:
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"Inputs and interconnections" area

● "Input" column
This column shows the FF devices and the available inputs in the network view of the FF 
segment. Inputs are the target of an interconnection.

● "Internal interconnection" column
This column displays a list of interconnections that were configured for the FF segment.
Layout: Output of the FF device > Function Block > Signal

"Outputs" area

● "Output" column
This column shows the FF devices in the network view of the FF segment and the available 
outputs. Outputs are the source of an interconnection.

Buttons

Button Function
Add interconnec‐
tion

Click this button to add an interconnection to the column "Interconnections".

Delete intercon‐
nection

Click this button to delete an interconnection.

Close Click this button to close the dialog box.
A message informs you if changes have not yet been saved.

Save Click this button to save configured interconnections in the SIMATIC project. 
Download Click this button to open the CiF interconnection.

NOTICE!
Use this button only if no other changes have been made to the FF segment since 
the last download of the device.

Icons

Icon Displayed object 
FF segment 

Bus link (FF Link or Compact FF Link)

FF device

Block within an FF device

Inputs and outputs Status
Analog input Not interconnected

Analog input Interconnected

Digital input Not interconnected

Digital input Interconnected

Analog output Not interconnected

Analog output Interconnected
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Icon Displayed object 
Digital output Not interconnected

Digital output Interconnected

Locked inputs or outputs

Inputs or outputs can be locked for the interconnection. Causes:

● The input or output is interconnected internally. 

● An I/O address from the process image is already assigned in HW Config for the input or 
output. 
You can find information about this in the Process Control System PCS 7, FOUNDATION 
Fieldbus documentation; section "How to replace an FF device".

Example of the representation:
The symbol indicates a locked input.

8.3.10.2 Downloading objects in the FF segment
You have to download the following data for the function of the FF devices in a system: 

● CPU data

– Hardware configuration of a CPU with connected FF segment (to the CPU)

– Program and connections (to the CPU)

● Schedule, bus parameters and interconnections (to the FF segment)

● Device parameters (to all FF devices)

Note
Downloading function blocks

It is not necessary to download an entire device if there are only minor changes.

You can download a group of function blocks or one individual function block for an FF device.

Replacing devices
You have the following options for replacing devices with SIMATIC PDM:

● Replacement of a device with one of the same type

● Replacing a device with a similar one
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Requirements
You will have to read in the device parameters to the Engineering System before you assign 
the parameters of the FF devices for the first time. 

Note

Observe the following if you have inserted new FF devices on the FF segment or if you want 
to use the parameters of additional function blocks:
● First, configure all interconnections.
● If the complete FF segment is loaded (option for bus link: "Always load FF Link and FF 

devices"), loading is briefly stopped.
● If the FF segment is being loaded incrementally (option for bus link: "Only load FF Link and 

FF devices when modified"), the loading continues.
● If necessary, correct the macro cycle settings.

Download
Use the following menu commands to download the respective data to the system:

Menu command CPU data Schedule, bus parameters and in‐
terconnections

Device pa‐
rameters

Always download the hardware config‐
uration in HW Config for the selected 
CPU: 
PLC > Download to Module

Hardware 
configura‐
tion is 
downloa‐
ded 

Downloading
Note: 
Downloading FF segments can on‐
ly be carried out via HW Config.

-

The menu command PLC > Compile 
and Download Objects... in the SIMAT‐
IC Manager.

Program 
and con‐
nections 
are down‐
loaded 

- -

Select the bus link in SIMATIC PDM 
Device > Download to device 
Select the following check box in the 
"Download to device" dialog:
"Object with all subordinate objects 
and networks".

- - All FF devi‐
ces are 
downloa‐
ded.

Select the bus link in SIMATIC PDM 
Device > Download to device 
Select the following check box in the 
"Download to device" dialog:
"Object with all subordinate objects".

- -
Only when replacing a device with 
one of the same type: 
Select the check box "Load Sched‐
ule to Device".

The FF de‐
vice is loa‐
ded

Note

You can download changes to the automation system in "RUN" mode. 
Read the following paragraph: Settings for "Load FF Segment"
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Settings for "Load FF segment" 
In HW Config, you can adapt the object properties of the bus link that are taken into 
consideration when loading the AS. 

Perform the following steps:

1. Open the hardware configuration in SIMATIC Manager.

2. Open the object properties of the bus link.

3. Select the "Load FF Segment" tab.

4. Make the settings in accordance with the following table:

Note
Bus link - downloading changes after the "Calculate schedule" action

If you have configured the setting "Only load FF Link and FF devices when modified" in the 
bus link, you must observe the following:
● Only a complete download is possible after executing the action "Calculate Schedule" 

in "Properties - Foundation Fieldbus -> Macro cycle".
● A complete download is made possible by changing the bus link parameter assignment 

to "Always load FF Link and FF devices".

Check box Application Effect
Only load FF 
Link  and FF de‐
vices when 
modified

Exclude FF segment during 
AS loading
Example: You configure no 
changes for the FF seg‐
ment.

If only changes are downloaded, the FF segment 
continues running during loading.

Always load FF 
Link and FF de‐
vices

Complete download of an 
FF segment

The FF segment is stopped when it is downloaded 
completely.
Recommendation
After a complete download of an FF segment, se‐
lect the option "Only load FF Link and FF devices 
when modified".

Exclude FF Link 
and FF devices 
from loading

Function for commissioning 
only

This function supports you during commissioning 
of other bus links on the same PROFIBUS.
NOTICE! 
STOP of the FF segment possible
Undefined states may occur in the FF segment 
when you use this setting. 
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8.4 Communication

8.4.1 Saving/reading the device data
The "Download to device (Page 186)" and "Upload to PG/PC (Page 188)" functions are used 
to update the data storage system.

● The "Upload to PG/PC" function is used to load all device tags of a device object from the 
device to the offline data storage.

● The "Download to device" function is used to load all configurable device tags of a device 
object from the offline data storage to the device.

Procedure
To download data in the network view, plant view or PDM parameter view, follow these steps:

1. Select the device and then select the Download to device or Upload to PG/PC menu 
command from the shortcut menu.

2. Select the required settings in the open "Download to device" or "Upload to PG/PC" dialog.

3. Click "OK" to save your entries.

During the download, a dialog is displayed that shows the objects you have edited beforehand 
in a tree structure similar to that of SIMATIC Manager. If any errors occur for a device, the 
function is aborted for this device. The action continues where possible.

The dialog is updated during the load process. As long as the operation is active, the title bar 
displays the "In progress" status and the "Result" status after the operation has been 
completed.

Loading options
Within the configuration layer of the SIMATIC Manager you can download the data of 
configured devices to the entire plant, to units, or to single devices, or upload this data to the 
PG/PC without having to open SIMATIC PDM separately for each device.

You have the following options for loading data:

● "Download to device" or "Upload to PG/PC" of the selected device

● "Download to device" or "Upload to PG/PC" of the selected device and the devices on the 
first level under the selected device (only for remote I/O)

Note

At least two connections must be supported simultaneously for remote I/Os to enable 
communication with the connected HART process devices.

● Download to device/Upload to PG/PC of the selected device and of all the devices under 
the selected device
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Errors and messages
During the loading, all errors and messages are shown immediately. Any errors occurring in 
a device do not cause the entire action to be aborted; they only apply to the device that is 
currently being processed. Errors and other messages are saved and can be displayed at a 
later time. 

Suppressing message dialogs

You can suppress message dialogs during the loading. Select the "Execute 'Load' without info 
dialogs" check box. You can find additional information using the Options > SIMATIC PDM > 
Settings > The "Load" tab (Page 260) menu command.

Loading time
The time required to load the parameter assignment depends on the device in question, so it 
can take quite some time to load data from multiple field devices.

The total time required for this process depends on the following parameters:

● Number of devices

● Communication mode

● The volume of parameters to be transferred

Note
User action required

There are some devices for which confirmation of loading operations is required. 

If none of the devices you are using requires any action on the part of the user during 
loading, you can start the loading process before an extended absence.
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8.5 Export / Import

8.5.1 Introduction
You can export and reimport the configuration and parameter assignment data of projects with 
PDM objects to a different project or a different PDM computer, for example. 

You can export individual objects as well as modular software objects or modular hardware 
objects and networks with embedded objects (e.g., field devices).

Export
You can export object data from the following environments:

● From SIMATIC PDM

● In the process device network view in SIMATIC Manager

● In the process device plant view in SIMATIC Manager

● In HW Config

You can export the configuration and parameter assignment data of the following objects:

● Devices

● Modular devices (e.g., remote I/O stations)

● Networks with subordinate devices

Files are created during the export based on the export object:

● Parameter export files

● Structure export files

Note

Devices with a redundant interconnection are configured multiple times in the network and 
exported in the same number during the export of a network (you can find information on this 
in the section ""Select object" dialog box (Page 119)").

Parameter export 
If only one object is selected for export, only one parameter export is performed to the export 
directory. 

Parameter export files are created only for device objects. No parameter export files are stored 
for networks or similar objects.

The parameter export file is labeled with the prefix "Param$".
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Structure export 
If a set of objects (an object with subobjects) is selected for export, a structure export is also 
performed to the export directory. 

Along with the structure export file, a folder of the same name containing the parameter export 
files of the exported objects is then generated.

Along with the structure export file, a folder of the same name containing the parameter export 
files of the exported objects is generated:

Export directory

● Struct$<Plant-specific device name>$<Date(YYYYMMDD_hhmmss)>.xml

● Directory Struct$<Plant-specific device name>$<Date(YYYYMMDD_hhmmss)

– Param$<Plant-specific device name>$<Date(YYYYMMDD_hhmmss)>.xml

When exporting object structures, a structure export file is created in addition to the parameter 
export files of each object. The structure export file contains the object topology information 
including all information required to generate the exported object structure again or to expand 
an existing object structure. The structure export file is labeled with the prefix "Struct$. 

Import
The export of data of a PDM object generates files in XML format. For the import, you can 
select an XML file and choose whether a parameter import or structure import is be performed.

Parameter import 
Parameter export files can only be imported at device objects or "placeholder objects". A 
"placeholder object" is an object that is produced by the "Insert object" command without a 
specific type selection.

In principle, the parameter import works as a comparative import. 

No objects are deleted by the import process.

Structure import 
Structure export files can only be imported for objects of a compatible type or for "placeholder 
objects". A "placeholder object" is an object that is produced by the "Insert object" command 
without a specific EDD selection.

The structure import works as an additive import. The address or the slot of the object is most 
important. 

This means that non-existing objects are created, the EDD is assigned, and the parameters 
are imported.  

If objects already exist, the parameters are imported.

No objects are deleted by the import process.
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Export/import file (*.xml)                   
During export, the data is saved in an XML file. 

The name of each file generated during the export is structured as follows:

● Parameter export
Param$<plant-specific device name>$<date(YYYYMMDD_hhmmss)>.xml

● Structure export 
Struct$<plant-specific device name>$<date(YYYYMMDD_hhmmss)>.xml

Note

The parameter export files are identified with the described prefix only in PDM V8.0.2 and 
higher.

Creating a plant-specific HTML format information file (HTML transformation file)
You can control how the parameter export files are formatted by using an HTML format 
information file (XSL file for transformation into HTML). You can use the HTML format 
information file (XSL file for transformation into HTML) to convert formats, for example, and to 
prepare the file for the purpose of using external tools. 

To create a plant-specific HTML format information file, use the default file as your starting 
point. 
Once you have created devices in PDM, you can find the path and name of the HTML 
representation file supplied with SIMATIC PDM in the export dialog. 
Default setting: <Path>\<Name>.<File format>

● Path: Program Files\Siemens\Automation\SIMATIC_PDM\Templates
● Name: PDM<version>_ExportTransformation
● File format: xsl

Additional information
● Section "Exporting (Page 175)"

● Section "Importing (Page 179)"

8.5.2 Exporting configuration and parameter assignment data
You can run the "Export" function for the following objects:

● Devices

● Modular devices (e.g., remote I/O stations)

● Networks with subordinate devices
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Export environment
You can export object data in the following environments:

● From SIMATIC PDM

● In the process device network view in SIMATIC Manager

● In the process device plant view in SIMATIC Manager

● In HW Config

Procedure
1. Select a PDM object and choose the associated menu command:

– The menu command File > Export... in SIMATIC PDM.

– The shortcut menu command SIMATIC PDM > Export... in SIMATIC Manager, in the 
process device network view or process device plant view.

– The shortcut menu command SIMATIC PDM > Export... in HW Config.

2. Make the settings for exporting the device data:
You can find additional information on this in the section ""Export - ..." dialog box 
(Page 176)".

3. Click "Start".

Result
The configuration and parameter assignment data for the selected device (or for the devices 
that are subordinate to the PDM object) is exported. 
The progress of the export is shown in the list of devices during the export process.

Display
The dialog box is updated during the export process. 

Status display

● During the process, the display field shows the entry "Export: action started".

● Once the process is complete, the display field shows the entry "Export: action completed 
without error".

Message log
The message log shows all warnings, errors and information related to the export. You can 
find information on this in the section "Message log (Page 156)".

Functions
8.5 Export / Import

Help for SIMATIC PDM (V9.1)
Operating Manual, 02/2017, A5E39027365-AA 135



8.5.3 Importing configuration and parameter assignment data
Depending on the selection, the export generates parameter export files and structure export 
files in XML format. For the import, you can select an XML file and choose whether a parameter 
import or structure import is be performed. 

Import environment
You can import data from the following environments:

● From SIMATIC PDM

● In the process device network view in SIMATIC Manager

● In the process device plant view in SIMATIC Manager

● In HW Config

The import is always started for an object, e.g., via the menu bar or via the shortcut menu in 
SIMATIC Manager. The name of the object for which the import dialog was opened appears 
in the name field of the dialog.

Object consistency check
A consistency check of the device types and objects is performed automatically during the 
import process.

● Imported object
Type of object from which the import file is generated.

● Existing object (target object)
Type of object that is selected in the configuration as the target object of the import.

The remaining steps depend on the results of the check:

● Object types are the same
The import can continue immediately.
The entire import file can be imported to the target object. During import, all the data 
contained in the import file is overwritten.

● Object types are different (parameter import)
The import process is interrupted by the following message dialog box:
"Different device types. Only attributes with the same name will be imported."
If you continue the import, you will see the following result:

– No parameters will be deleted or added.

– Only those parameters with the same name will be overwritten on the target object.

● Object types are different (structure import)
The import cannot be started.

Note
Assigned device description file

The target device is not assigned a new device description file.
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Procedure
1. Go to one of the specified environments and select the device for which you want data to 

be imported from the XML file.

2. Select the relevant menu command in accordance with the environment that you have 
decided to use:

– The menu command File > Import... in SIMATIC PDM.

– The shortcut menu command SIMATIC PDM > Import... in the process device network 
view or process device plant view in SIMATIC Manager.

– The shortcut menu command SIMATIC PDM > Import... in HW Config.

3. A dialog box opens. In the "Import file" input box, enter the path and location of the XML 
file that contains the data you want to import. 
The device type consistency check is performed.

4. Select the setting for the "Import identification data" check box.

– "Import identification data" check box activated (default)
The following data of the import file are imported:
- Device name
- Description
- Message

– "Import identification data" check box deactivated
The device name, description, and message are excluded from the import.

5. Select the setting for the "Import device parameters" check box:

– "Import device parameters" check box selected (default)
The data record of the parameter export file is completely imported.

– "Import device parameters" check box cleared
The data record of the parameter export file is not imported.  

6. Click the "Start" button.
The status of the import is displayed while it is in progress.

Display
The dialog box is updated during the import. 

Status display

● During the process, the display field shows the entry "Import: action started.".

● Once the process is complete, the display field shows the entry "Import: action completed 
without error.".

Message log
The message log shows all warnings, errors and information related to the import. You can 
find information on this in the section "Message log (Page 156)".
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Additional information
● Section "Replacing devices (Page 121)"
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8.6 Diagnostics

8.6.1 Field device diagnostics

Description     
SIMATIC PDM provides a detailed diagnostics for integrated field devices.

The icons are assigned when the devices are configured. When a connection is established, 
device-specific diagnostic information is automatically classified and indicated by the 
corresponding icons. You will find information on the icons in the section "Overview of Device 
Icons (Page 140)".

This diagnostic information is automatically saved in the project, even if the assigned 
parameter data are not saved.

When an online connection is being established, an identification check is performed initially. 
After this, the device status is determined, and the device is depicted with the corresponding 
icon.

Note

It is possible to disable the diagnostics update.

Diagnostic information
The diagnostics provides the following categorized information:

● Communication

– Communication with the device was good

– Communication was good, but the device does not support further diagnostics

– Communication faulty

– Device assignment error

● Process

– Device unchecked

– Device deactivated

– Measured value alarm

– Measured value warning

– Measured value tolerance

● Maintenance

– Maintenance alarm

– Maintenance warning

– Maintenance required
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● Configuration

– Configuration error

– Configuration warning

– Configuration changed

● Operating mode

– Manual mode

– Simulation or substitute value

– Out of service

Device status

Note

When checking the status of a device, sometimes the diagnostic information cannot be fully 
determined because not all devices support the full scope of this function. 

Additional information
Section "Identity check (Page 143)"

Section "Updating diagnostics (Page 143)"

8.6.2 Overview of Device Icons
The following table explains the meaning of the possible icons for the devices configured in 
SIMATIC PDM. The statuses of these icons may not be fully supported by all devices. 

The corresponding icons are assigned to the devices during configuration. 
The displayed icons are updated as follows:

● When a connection is established to field devices

● When a picture is changed

The diagnostic information is automatically saved in the project, even if the parameter data is 
not saved.
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Display of the icons
The icons are displayed in the following views:

● In SIMATIC Manager

– Process device network view

– Process device plant view

● In SIMATIC PDM in the tree structure

● In the LifeList in the tree structure

Icons               

Icon Description
Deactivated
No device description (EDD) from the device catalog has yet been assigned to the field device / Field device 
cannot be accessed.
Not validated
A device description from the device catalog has been assigned to the field device.

Communication faulty
Communication error, communication has been interrupted or no communication could take place with the 
device at the configured address. The device cannot provide detailed diagnostic information.
Assignment error
The field device is incompatible with the configured field device or the device has been configured incorrectly. 
The device cannot provide detailed diagnostic information. 
Maintenance alarm
Maintenance is required immediately as there is a device fault.

Maintenance demanded
Maintenance is required to prevent a possible device fault from occurring.
Additional diagnostic information is available.
Maintenance required
Maintenance must be scheduled.
No functional restriction has been diagnosed for the field device, service is requested. 
Additional diagnostic information is available.
Manual mode
There is a communication connection with the field device. The device is in manual mode.

Simulation mode
There is a communication connection with the field device. The device is in manual mode.
For example, the device is in manual "simulation mode".
Out of service
There is a communication connection with the field device. The device is in manual mode.
For example, the device is in manual "Out of service" mode.
Configuration error
Field device fault due to a parameter/interconnection error or configuration error in the hardware compo‐
nents. A maintenance alarm is triggered automatically.
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Icon Description
Configuration warning
Field device warning due to invalid parameters for which substitute values are used. A maintenance request 
is triggered automatically.
Configuration changed
The parameters set for the device do not match the parameter data saved in the project. Communication 
with the device is possible to carry out a value comparison or to change parameter settings.
Unknown diagnostics status
Unknown field device status due to invalid parameters for which substitute values are used. A maintenance 
request is triggered automatically.
Process value alarm
At least one process value has exceeded or fallen below a hardware interrupt limit whose parameters were 
assigned in the device. Communication with the device is possible.
Process value warning
At least one process value has exceeded or fallen below a process warning limit whose parameters were 
assigned in the device. Communication with the device is possible.
Process value tolerance
At least one process value has exceeded or fallen below a process tolerance limit parameter set in the 
device. Communication with the device is possible.
No messages
No functional restrictions or diagnostic information known.

No diagnostic check
No functional restrictions known. The field device does not support additional diagnostic information.

Test mode (background color of diagnostics icon)
The device is in local test mode. All the displayed information or diagnostics may be simulated. The infor‐
mation transferred to the automation systems (measured values and status) may also be simulated.

Icons for FF device blocks
The icons for FF device blocks are based on the device icons.

Icon Description
FF block icon

The block icon is a device icon expanded by the block character. It has an equivalent meaning.
Example: 
FF block not functional (Out of service)
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8.6.3 Connection diagnostics

Description       
When you establish an online connection to a device in SIMATIC PDM, the following points 
are checked while the connection is being established: 

● Device type

● Device (TAG)

● Changes made to the device that have not yet been saved in the project

If a connection is aborted, SIMATIC PDM automatically attempts to establish a new connection. 
Any errors that occur are displayed and logged.

If a device has not accepted the data in an identical manner, the values that are written to the 
device and the actual values read back from the device can be displayed.

You can then decide whether or not to use the changed values in your project. 

Additional information
● Section "Overview of Device Icons (Page 140)"

● Section "Communication Problems (Page 291)"

8.6.4 Identity check
The identification check verifies consistency between the connected and the configured 
device. The scope of the identification check depends on information from the device 
description of the respective device.

Once the identification check is complete, the device status is determined and a corresponding 
icon is assigned to the device.

If the identification check determines a difference between the connected device and the 
configured device, an informational dialog is displayed with information about the connected 
device and the configured device.

8.6.5 Updating diagnostics
If online communication with the currently selected object is established, SIMATIC PDM is able 
to carry out a device diagnostic of the field devices. 
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Enabling device diagnostics
1. Select the Options > SIMATIC PDM > Settings menu command in SIMATIC Manager.

The "Settings" dialog opens.

2. Select the "Communication" tab.

3. Activate the "Diagnosis Update" check box in the "Device diagnostics" area.

See also
"Communication" tab (Page 259)

"Update diagnostics - ..." dialog box (Page 219)

Overview of Device Icons (Page 140)
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8.7 LifeList

8.7.1 Working with the LifeList

Introduction

LifeList makes it possible to identify active field devices without configuration. With LifeList , 
you perform a scan on one of the following PDM objects:

● PROFIBUS DP network

● PROFIBUS PA network

● HART modem network

● Foundation Fieldbus network

Note
Scanning a network

The selected network is analyzed during a scan with LifeList . A separate scan is required for 
subordinate networks.

Starting LifeList 
If the project is opened in SIMATIC Manager, you can start LifeList from the following views:

● Starting from HW Config

– Select a PDM object containing the field devices.

– Select the shortcut menu command SIMATIC PDM > Start LifeList . 
SIMATIC PDM starts. LifeList is opened.

● Starting from the process device network view

– Select a PDM object containing the field devices.

– Select the menu command Edit > SIMATIC PDM > Start LifeList .

● Starting from SIMATIC PDM

– Requirement: A PDM object containing the field devices is selected.

– To open the LifeList , select the menu command View > Start LifeList .

Stopping LifeList 
When the LifeList is open, click "Close".
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Setting the address range for scan operation
When the LifeList is opened, the scan range is set to the complete address range according 
to the protocol of the network on which the LifeList was started.

PROFIBUS Address 0 to 126
FF Address 20 to 251 (minimum value 16, default val‐

ue 20)
HART modem Address 0 to 63

Recommendation:

Limit the address range for the scan operation.

A scan operation across a large address range takes longer.

The address range is set via the toolbar or via the "Settings" dialog in the "Options" menu.

This setting cannot be stored centrally since it is network-specific. The setting must be made 
again each time the LifeList is opened.

Scan without diagnostics
The "Start Scan" function is used to start a new scan operation. 

Any previous scan result is deleted. 

During the first phase of the scan operation, the list of assigned communication addresses is 
determined based on the selected address range. 

For each assigned address, the scan table contains an object whose icon is initially determined 
by whether or not the object is a (bus) master. 

Icon Meaning
Network

(Bus) "master" device

"Local master" device (own PC)

Device without EDD assignment

Communication error

Device with EDD assignment

Device after diagnostics run (result: Good)
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Icon Meaning
Device after diagnostics run (result: no diagnostic support)

Additional icon meanings can be found in Overview of Device Icons (Page 140)

Note

The first phase of the scan operation cannot be interrupted.

During the second phase of the scan operation, identification data is called and entered in the 
scan table for each address at which no (bus) master was detected.

For PROFIBUS devices, information is also read from the GSD file and entered in the table, 
e.g., the device family. 

Note

The second phase of the scan operation can be interrupted. The current object will still be 
completed.

Depending on available licenses (Page 149), automatic EDD assignment also occurs in this 
phase.

When identification data is successfully called, it is entered in the table and an attempt is made 
to make an EDD assignment with this information: 

● If the EDD assignment is successful, the object is marked with a blue device icon .

● If the associated EDD cannot be explicitly determined, no assignment is made and the 
object retains its gray device icon  from the first phase.

● If communication problems occur, the object receives the corresponding icon .  

Scan with diagnostics
The "Start scan with diagnostics" function is used to start a new scan operation with 
diagnostics. 

Any previous scan result is deleted.

The first two phases are the same as for the scan without diagnostics.

In the third phase, the diagnostic function is executed for the objects with EDD assignment 
and the result is entered in the table. 

The diagnostic icon appears and the message text is entered in the "Device status" column.

Note

The third phase of the scan operation can be interrupted. The current object will still be 
completed.

This function is available only when the appropriate licenses (Page 149) are installed.
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Scan result
The devices found appear in the tree view with their object name (TAG).

Other information determined is displayed in additional columns. 

The additional information that is displayed depends on the type of network on which the 
LifeList was started.

Column header PROFIBUS FF HART modem
Available nodes + + +
Address + + +
Manufacturer + + +
Device type + + +
Device ID + + +
Hardware revision + + +
Software revision + + +
Installation date + + +
Ident number + - -
Device family + - -
Profile revision + - +
GSD file + - -
Long address - - +
Device status + + +

Update diagnostics
The "Update diagnostics" function is used to once again determine the diagnostic information 
for the object selected in the scan table. 

This function is available only when the appropriate licenses (Page 149) are installed.

Assign address and TAG
If you want to assign a new address or object name to a device, select the "Assign address 
and TAG" function for the selected object.

The "Assign address and TAG..." (Page 152) dialog opens.

Here, you can enter a new object name and a new address and then transfer them directly to 
the connected device using the "Transfer" button.

Device Selection (Reassign)
If there has not been an automatic EDD assignment of objects, you have the option of making 
the assignment manually.

Manual assignment is appropriate for objects for which you want to start diagnostics or export 
the results.

Manual EDD assignment uses the "Device Selection (Reassign)". function.

Functions
8.7 LifeList

Help for SIMATIC PDM (V9.1)
148 Operating Manual, 02/2017, A5E39027365-AA



This function is only available when the appropriate licenses (Page 149) are installed.

Object properties
If you start the "Properties" function from the LifeList, the "Object Properties (Page 248)" dialog 
appears, but without the "Communication" and "Document Manager" tabs.

● "General" tab (Page 195)

● "Device" tab (Page 196)

● "Diagnostics" tab (Page 196)

Note

If the "Object Properties" dialog is started from the LifeList, the "Communication" and 
"Document Manager" tabs are not displayed and the "Update Diagnostics" button is not visible 
in the "Diagnostics" tab.

LifeList via Ethernet routing
The following requirements have to be met to apply the LifeList to objects via Ethernet routing:

● An S7 hardware project can communicate with the automation system via HW Config.

● The hardware project has been downloaded to the automation system along with the 
corresponding PROFIBUS-Link .

If these conditions are met, communication can be established via Ethernet routing with 
networks of the following types:

● PROFIBUS DP network

● PROFIBUS PA network

● FONDATION Fieldbus via FF Link at PROFIBUS DP

You can find information on the required hardware in the file PDM-readme.

8.7.2 Licensing
The functional scope of the LifeList is determined by the installed licenses as follows:

Function Single Point Basic Extended
Set address range for scan + + +
Automatic EDD assignment - + +
File Export - - +
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Function Single Point Basic Extended
Edit Start 'Scan' + + +

Start 'Scan with di‐
agnostics'

- - +

Start 'Update diag‐
nostics'

- - +

Device Update diagnostics - - +
Assign address 
and TAG

+ + +

Device Selection 
(Reassign)

- + +

Properties + + +

8.7.3 Menus and dialog boxes

8.7.3.1 "File" menu

Export
Exports the determined network, including all of its devices. 

The devices identified as bus master objects (e.g. PCs) are not exported. 

The "Export" function is used to open the "Export - ..." dialog box (Page 176).

Note

If the "Export" dialog is started from the LifeList, the "Document Manager" check box is cleared.

A structure export file is generated during the export from the LifeList.

The parameter export files can only be generated for objects with EDD assignment.

Note
Access to SIMATIC PDM via SIMATIC PDM Server

Export from the LifeList is not available in the browser view of SIMATIC PDM.

Close
Closes the change log or LifeList.
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8.7.3.2 "Edit" menu

Start "Scan"
Starts a scan operation. 

The accessible devices of the network on which the LifeList was started are determined. 

Any previous scan result is deleted. 

Automatic EDD assignment then takes place, depending on available licenses.

Start "Scan with diagnostics"
Starts a scan operation. 

The accessible devices of the network on which the LifeList was started are determined. 

Any previous scan result is deleted. 

Automatic EDD assignment then takes place, depending on available licenses.

A diagnostics run is started at the conclusion of the automatic EDD assignment. 

This determines the diagnostic status of all objects with EDD assignment.

Stop
The current scan operation is stopped. 

This function can only be selected if an action is being executed. 

You can determine whether an action is being executed from the active progress display.

Start "Update diagnostics"
The diagnostics run is started for the current scan result without starting a new scan operation.

8.7.3.3 "Device" menu

Update diagnostics
The diagnostic information is re-determined for the object selected in the scan table. 

The icons are updated and the message text is entered in the table.

This function can only be called automatically or manually for objects with EDD assignment.

Assign address and TAG
The "LifeList - Assign Address and TAG" dialog opens. 

This dialog can be used to assign a new address and a new object name to the selected object.
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"LifeList - Assign address and TAG..." dialog
When the LifeList has been determined, you can perform the following for the device displayed 
in the "Online" area in the "LifeList - Assign address and tag..." dialog box:

● Change object name

● Change address

● Change object name and address

Buttons

Button Function
Select object Select this button in the following cases:

● You want to assign an existing device configuration to a replacement 
device with default address.

● You want to assign an existing device configuration to an unspecified 
device.

Transfer You can only select this button if changes were made in at least one text 
box and both text boxes were selected. 
The information in both boxes is identical if the operation was successfully 
completed (status \"Transfer successful\").

Reset address
(only available for FF de‐
vices)

● The "Reset address" button is only available for FF devices.
● The function "moves" the device to the area for temporary FF devices 

(reserved address range for FF devices - addresses 248 to 251). The 
name (TAG) remains unchanged.

● You can verify execution with LifeList .

Note
Address or name (TAG) occupied

If the address or name (TAG) is occupied, then the action will not be performed. A 
corresponding message will be displayed.

Device information
In this area, the following data is displayed for the detected device (online) and for the new 
settings:

● Manufacturer

● Device type

● Device revision

See also
"Assign address and TAG..." dialog box (Page 191)
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Device Selection (Reassign)
This function is used to manually assign a device type and thus an EDD for the selected object.

See also
Creating your own device library using the project filter (Page 53)

Creating your own device library from a collection of device descriptions (Page 54)

Properties
Opens the dialog window containing the properties of the selected object.

See also
Working with the LifeList (Page 145)

8.7.3.4 "View" menu

Messages...
Opens the "Messages" dialog box.

Additional information
Section "Message log (Page 156)"

8.7.3.5 "Options" menu

Settings
Opens the dialog window for setting the address range.

This setting cannot be stored centrally since it is network-specific. 

The setting must be made again each time the LifeList is opened.

8.7.3.6 "Help" menu

Help
Displays the help on SIMATIC PDM LifeList. 

You can navigate to different help topics from the Table of Contents. The "Index" and "Find" 
functions enable you to display information on specific terms. 
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About...
This menu command displays information about the version and the copyright.

8.7.4 Menu bar

Structure
Below, you will find an overview of the LifeList menus.

Menu Submenu 
File
 

● Export (Page 150)
● Close (Page 150)

Edit ● Start "Scan" (Page 151)
● Start "Scan with diagnostics" (Page 151)
● Stop (Page 151)
● Start "Update diagnostics" (Page 151)

Device ● Update diagnostics (Page 151)
● Assign address and TAG (Page 151)
● Device Selection (Reassign) (Page 153)
● Properties (Page 153)

View ● Messages... (Page 153)
Options ● Settings (Page 153)
Help ● Help (Page 153)

● About... (Page 154)

8.7.5 Toolbar
The toolbar is located below the menu bar and contains several buttons. You can use the 
buttons to execute frequently used menu commands without having to open the menu. 

Icons     
Meanings of the icons used:

Icon Menu com‐
mand

Description

Start "Scan 
with diagnos‐
tics" 
(Page 151) 

A scan operation is started.
A diagnostics run is started at the conclusion of the automatic EDD 
assignment. 

Start "Scan" 
(Page 151) 

A scan operation is started.
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Icon Menu com‐
mand

Description

Stop 
(Page 151) 

The current action (scan or diagnostics) is stopped.

Start "Update 
diagnostics" 
(Page 151) 

At the current scan result, a diagnostics run is started without starting 
a new scan

Min. address - Start of range for scan operation
Max. address - End of range for scan operation

Export 
(Page 150) 

The determined network, including all of its devices, is exported.

Settings 
(Page 153) 

The "Settings" dialog box opens.
You can adapt the LifeList according to your requirements and pref‐
erences in this dialog box.

Messages... 
(Page 153) 

The "Messages" dialog box opens.

Help 
(Page 153) 

The help on SIMATIC PDM LifeList opens.

8.7.6 Status bar
Information about current actions is displayed in the status bar.

The active progress display on the right is shown when an action is currently active. 
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8.8 Logs

8.8.1 Message log
Information about events in SIMATIC PDM is displayed in the message log.

Events in the message log
The message log contains information on the following events:

● Events in online dialogs

● Events when executing "Upload to PG/PC..." and "Download to device..."

● Events when executing "Update diagnostics"

● Events when executing the LifeList

● Events when executing Export and Import

● Events in Device Integration Manager

Note
Device-specific log functions

The device description is used to determine the events to be reported and the log entries 
to be displayed in the message log. 

Message log
The message log contains the following columns:

● Index

● Date and time
Displays the date and time in UTC format, including the local time difference.
YYYY-MM-DD HH:mm:ss +/-HH:mm

● Message class

● Context

● Message
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Filtering the message log
You can filter the events shown in the message log according to the following categories. 
Select one of the following settings from the drop-down list:

● Without filter
All information is shown.

● Errors only 
Only errors are shown.

● Errors and warnings only
Only warnings and errors are shown.

File saving and formats     
You can save the message log in CSV format (*.csv).
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8.9 Graphical displays

Note

Functions for the graphical display of values are available in SIMATIC PDM, if they are provided 
by the manufacturer of the device description.

Chart dialog window
When working with field devices, please note that:

● The following cannot be changed:

– The contents of the chart dialog window

– Process values

● If the device description can be edited, you can use SIMATIC PDM to change the following 
data in the chart dialog window:

– Variables

– Constants

Functions and possible representation 
The following functions can be displayed by SIMATIC PDM:

● Monitoring process values

● Monitoring measuring signal raw values

● Monitoring status or wear values inside the device

● X-Y trends, e.g. envelope trends for radar level gauges

● Trends (for multiple process variables, measured values)

● Calibration functions

● Zero point settings

● Min/max pointer

● Diagnostic states

● Restore factory settings

● Mode changes

● Online parameter assignment

● Simulation of process variables, statuses, and diagnostics messages

● Classification of device-specific diagnoses
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Additional information
● IEC 61804-2

● IEC 61804-3

8.9.1 Graphical display of values

Online functions
The following is defined in the device description with regard to online functions:

● Process variables and measured values that can be visualized or used online

● Type of display and content of the online dialogs

● Possible online operations

The values and parameters appear on standardized online displays, which are coordinated 
with different functions.

Note
Online functions are active (orange bar)

When a function accesses online values, an animated orange bar is shown in the dialog boxes 
at the top dialog margin.

The animation is constant for values that are updated cyclically and sporadic for values that 
are not updated cyclically.

Displaying information in the chart 
Device description files can include the following information on displaying values/parameters 
in charts:

● Source of values/parameters

● Chart type

● Value ranges

Charts for process values
● Trend chart (Page 160)

Multiple values/parameters can be displayed in a chart at the same time.

– Y-T charts

● Tachometer chart (Page 163) 
Each value/parameter is displayed in a separate chart.

● Bar chart (Page 217) 
Multiple values/parameters can be displayed simultaneously in a chart.
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Trend chart for variables and constants
Multiple variables/constants can be displayed in a chart at one time.

● Trend chart (Page 160)
Multiple variables/constants can be displayed in a chart at one time.

– Y-T charts

– X-Y charts

The following data is displayed:

● Online values

● Data from files

● Data read from the device

Trend chart for digital values
Digital values can be shown in a trend chart.

The representation of the values depends on the device description.

Additional information
● Section "Charts and trends (depends on device) (Page 216)"

● Section "Displaying process variables and measured values  (Page 217)"

● IEC 61804-2

● IEC 61804-3

8.9.2 Trend chart
The following may be displayed in the trend charts:

● Display of several trends

● Display of one x axis and several y axes

● Display of one y axis with several trends

The way in which trends are displayed is derived from the device description:

● Trend colors

● Visual highlighting of individual trends (e.g. line width)

y-t chart   
In y-t charts, the trends are updated incrementally.

The following display modes are usually used:

● Automatic scrolling along the time axis.

● If the trends have reached the right-hand margin, they continue to be recorded starting from 
the left again, and the old trends are overwritten one after the other.
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● If the trends have reached the right-hand margin, the trend display is cleared and the trends 
start again from the left.

● The time interval is not updated.

x-y chart   
The way in which information is displayed with x-y charts depends on the specifications in the 
device description. The following displays are typical:

● Representation of static trends

● Representation of parameters that change at certain events

Display mode
The trend display mode can be selected in the trend charts by using the toolbar that is available 
in the "Display mode" drop-down list. 

In the x-y diagram, this option is not available and the "Static" option is automatically selected.

Modes:

● Strip

– The most recent value is always shown on the far right of the chart.

– The user can change the length of the time interval.

● Scope 

– The time axis shows a defined time interval.

– The first value for the current time interval is always shown on the left-hand side of the 
chart. The subsequent values are always assigned to a time that falls within the time 
interval shown. The final value for the time interval that is being displayed is always 
shown on the right-hand side of the chart.

– As soon as a time interval expires, the displayed values are deleted.

– The first value for the subsequent time interval is always shown on the left-hand side of 
the chart.
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● Sweep

– The time axis shows a defined time interval.

– The first value for the current time interval is always shown on the left-hand side of the 
chart. The subsequent values are always assigned to a time that falls within the time 
interval shown. The final value for the time interval that is being displayed is always 
shown on the right-hand side of the chart.

– The values that are displayed in the chart get overwritten by the values for the 
subsequent time interval.

● Static 

– The time interval is not updated.

– The user can change the displayed range however he or she likes.

– Recommendation: 
Use this display mode to display static values.

8.9.3 Bar chart

Note

Functions for the display of process variables and measured values are available in SIMATIC 
PDM, if they are provided by the manufacturer of the device description.

Process variables and measured values are displayed in bar charts. A bar chart always shows 
current values.

The following may be displayed in the bar charts: 

● Name of the chart

● Names of the variables

● Limit (for the warning range)

Note

The value range of the axis can be moved with the mouse.
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Example
The figure below shows an example of a dialog window with a bar chart.     

1,5

0.000 5.000

Additional information
● Section "Trend chart (Page 160)"

● Section "Tachometer chart (Page 163)"

● Section "Icons and buttons (Page 164)"

● Section "Work with trends (Page 167)"

● Section "Editing trends (Page 168)"

8.9.4 Tachometer chart
In SIMATIC PDM, only one value is displayed in a tachometer chart. 

Limits can be assigned to the displayed value. These are highlighted in color in the chart.   

Chart
The chart can show the following elements:

● Name of the chart

● Inscription for the tachometer

● Name of the variable

● Min/max pointer (marks the maximum or minimum value reached since the start of 
monitoring)

● Warning ranges (represented by hatching)

● Limit (for a warning range)

● Current value (represented as a needle on the tachometer and as a numeric value below 
the tachometer)
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● Inscription of the axis

● Unit

Example
The figure below shows an example of a dialog window with a tachometer chart.     

8.9.5 Icons and buttons

Icons and buttons on the toolbar

Icon Description
Zoom in horizontally
Use the "Zoom in" button to enlarge the trend area.
Zoom out horizontally
Use the "Zoom out" button to make the trend area smaller.
Zoom in vertically
Use the "Zoom in" button to enlarge the trend area.
Zoom out vertically
Use the "Zoom out" button to make the trend area smaller.

Functions
8.9 Graphical displays

Help for SIMATIC PDM (V9.1)
164 Operating Manual, 02/2017, A5E39027365-AA



Icon Description
"Display mode (Page 160)" - Allows you to set the trend display mode
● Strip
● Scope
● Sweep
● Static
Trend Manager - Allows you to make settings for the trends and markers shown
● You can use the check box in the "Trend Manager" drop-down list to hide/show trends. In the legend, 

hidden trends are grayed out.
● Each trend is automatically assigned a marker (trend symbol) with its own color and appearance. 

You can use the check box to hide/show the marker.
● An editable trend is always selected via the Trend Manager.
Export
Trends can be exported in .csv file format. You must first select the trend to be exported in the Trend 
Manager.
Import
Once a trend has been exported, the resulting .csv file can be imported.
Imported trends are shown with their own x and y axes. To allow an imported trend to be compared 
with recordings that are currently in progress, the X axis of the imported trend can be linked to an existing 
axis.

 Link axis
Once a trend has been imported, the new X axis (axis B) for the imported trend can be linked to the 
existing X axis (axis A). Axis B is then synchronized with axis A to run simultaneously, but it can be 
adjusted without affecting axis A. This makes it possible to compare trends that were recorded and 
displayed previously with the current trend.

"View" drop-down 
list

"View" drop-down list - for displaying/hiding elements in the user interface
● Legend
● Ruler
● Table (values tables)
● Marker (symbol assigned to a trend)
Print
There is a Print dialog that allows you to print out the current trends. You can enter a comment for the 
printout.

Icons, buttons, and information displayed in the trend chart

Icon Description
Open padlock 
You can change the value. 
The value represents a limit for the values that are displayed on the relevant axis. 
Closed padlock
You cannot change the value. 
The value represents a limit for the values that are displayed on the relevant axis.
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Icon Description
Legend Each trend is identified by means of its name and a symbol with the same color as the line. The legend 

displays the following information consecutively for the trends shown in the chart
(format: Symbol Name Date:Time: Value): 
● Trend symbol
● Trend name
● Date:Time (format: DD:MM:YYYY hh:mm:ss.sss
● Value

– Value currently being read in (measuring lines not activated)
– Cursor points to a measuring line (active measuring line): Value at the intersection of the trend and 

measuring line (the values at the intersection point are underlined)
Measuring line Measuring lines

SIMATIC PDM makes a measuring line available in trend charts. The measuring line symbol identifies the 
current position of the measuring line. 
● Legend for measuring line

– The value at the intersection of the trend and measuring line is shown at the intersection
– Active values are underlined
– Interpolated values are not underlined

● Using the measuring line
– Pull the measuring line to the required position
– Removes a measuring line (park position).
– Remove measuring line (Alt-Click)
– Duplicate measuring line (Ctrl-Click)

White Active
Or‐
ange

Pas‐
sive

Shaded trend Cause: Data reduction 
The trend includes a large number of data points within the displayed range. The individual values cannot 
be displayed.

Dotted trends There are no measured values in a range.
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8.9.6 Work with trends

Interaction
The following functions are available in dialog boxes with trends:

● Adjust display range  
You can increase or decrease the range of a trend shown in the chart to meet your needs. 

– Select a range
Select the starting point with the mouse and, keeping the left mouse button pressed, 
select the end point of the range to be displayed. Display is stopped and the desired 
range is shown.

– Display minimum and maximum of all trends
Double-click the Y axis. The minimum and maximum of the Y axis are set in such a way 
that the values of all trends associated with this Y axis are completely visible in the 
interval displayed on the X axis.

– Display the entire time range
Double-click the X axis. The X axis is set in such a way that all trends are included, from 
the first to last point.

– Adjust the left display range
You can stretch or compress the corresponding axis by holding down the left mouse 
button. The right or upper scale value remains unchanged in this case.

– Adjust the right display range 
You can stretch or compress the corresponding axis by holding down the right mouse 
button. The left or lower scale value remains unchanged.

– Move the display range 
You can move the corresponding axis range by keeping the center mouse button 
pressed.

● Capture trend 
You can capture all trend areas. 
Double-click in the trend area. The values for all trends are displayed in the selected area 
(currently selected time range / X axis).

● Move the ruler
You can move the ruler. 
Select the ruler with the mouse and move it by keeping the left mouse button pressed. The 
changing x-position is displayed in the bottom right of the chart. Moving the "handles" is 
depicted as a numeric value. Once the left mouse button is released, the Y value associated 
with the X position is displayed.   
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● Move axis 
You can move an axis.
Hold down the "Ctrl" key. Click on an axis in the chart and move it via drag-and-drop. 
The grid within the chart is based on the scale shown to the left of the chart.

● Link axes
This function is used for comparing trend values.
Requirement: A file containing exported trend values is available.   

– Select the "Static" entry from the "Display mode" drop-down list.
 The time axis is stopped.

– Import the values for a trend.

– Align both axes of the displayed and imported trends in order to match up suitable points 
of reference. To do this, use the "Move axis" function and adapt the display range of the 
axes.

– Click the "Link axes" button on the toolbar.

– Select the "Strip" entry from the "Display mode" drop-down list.
The axes now move simultaneously and you can compare the values. Changing the 
leading axis affects the following axis, but not vice versa.

● Display help    

– Device-specific help on trends can be integrated in the device description. You can open 
this help by clicking the "Help" button.

– Any existing tooltip help for an object is displayed when you hover the mouse pointer 
over an object.

● Print functions

● Export and import function

– You must first select the trend to be exported (as well as a trend that is to be edited) in 
the Trend Manager.

8.9.7 Editing trends
The manufacturer of a device determines which values/parameters can be visualized and 
used. The device description is used to specify how SIMATIC PDM shows data that is to be 
displayed in charts. You can only edit data (variables and constants) in charts with SIMATIC 
PDM if this is permitted by the device description. Before you can edit a trend, it must be 
selected in the Trend Manager.

Editing in the Trend Manager
Once you have selected the trend in the Trend Manager, the following is displayed for the 
editable trend:

● Black trend points
Trend points that can be edited
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Note

You can only edit trend points if the respective function is allowed by the device description.

● Adding trend points
Hold down the "Ctrl" key. Click the drawing area in the chart.

– If the point you have clicked in the chart features on the trend line, the new point is 
inserted into the trend between two existing points.

– If the point you have clicked in the chart falls outside the trend line, the new point is 
added at the end of the trend.

● Deleting trend points

– Press and hold down the "Alt" key. Click a trend point in the chart. The trend point is 
deleted.

– Once a trend point has been selected, you can delete it by pressing the "Del" key.

– For multiple trend points:
Press "Ctrl" + "Alt" and click on the trend points to be deleted.

● Moving trend points
Hold down the "Ctrl" key. Click on a trend point in the chart and move it via drag-and-drop.

Note

The grid and other trend points have a magnetic effect on the point to be moved.

● Selecting multiple trend points
The trend points are captured by using a selection rectangle. 
Click with the left mouse button to select the starting point for your rectangle. Then drag 
the cursor across the chart while keeping the mouse button pressed. All the trend points 
that fall within this rectangle are marked with a red dot. 

● Define the zoom area
The zoom area is captured using a selection rectangle. 
Click with the left mouse button to select the starting point for your rectangle. Then drag 
the cursor across the chart while keeping the mouse button and SHIFT key pressed. The 
area inside the rectangle is part of the zoom area.

● "Monotonic entry" check box
To enter monotonic data values, activate the "Monotonic entry" check box. The arrow 
indicates the direction (monotonically ascending or monotonically descending).

Additional information
● Section "Icons and buttons (Page 164)"
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8.10 Asset management

8.10.1 Asset management 
Asset management covers all activities and measures which help to preserve or increase the 
value of a plant. As well as production management, process control, and process optimization, 
above all this includes maintenance work designed to preserve and increase a system's value, 
known as "plant-level asset management".

Asset management with SIMATIC PDM
SIMATIC PDM supports you in performing plant-level asset management with functions for 
configuring, assigning parameters for, commissioning, diagnosing, and maintaining intelligent 
field devices and components.

Asset management functions of SIMATIC PDM
SIMATIC PDM can supply extended information for the Asset Management for devices that 
are described by a device description (EDD/DD), for example: 

● Detailed diagnostic information (manufacturer information, information on fault diagnostics 
and troubleshooting, further documentation)

● Change information (audit trail log)

● Parameter information

● Diagnostic and status information for all devices is labeled and displayed with standardized 
symbols.
You can find information on this in section "Overview of Device Icons (Page 140)".

● Data is sent to an asset management system (e.g. PCS 7 maintenance station) upon 
request from the system.

● Export interface
You can find information on this in section "Exporting (Page 175)".

● Device-specific information and profile information is displayed in multiple languages, 
provided that such information can be extracted from the device description files.

NOTICE

Limited functionality

For use of the HART Server functionality, you must be logged onto the SIMATIC PDM Server 
locally.
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8.10.2 Use with the PCS 7 Maintenance Station

Maintenance Station Standard and Maintenance Station Basic
Process control of a maintenance station is started in the same way as the process control of 
an Operator Station. 

When using an MS multi-user system and SIMATIC PDM, the Engineering Station must be 
switched on and the PDM Server manager started so that PDM device data is delivered. 

Note

When PDM is integrated in PCS 7 and Asset Management is used, we recommend that you 
do not activate the function "Transfer maintenance alarm to MS station". Alarms that are only 
recorded by PDM and not transferred via the status of the process value could lead to the 
failure of process tags. However, if you wish to actively monitor HART field devices and also 
record diagnostic events that are not shown in the HART status, this function must be activated.

SIMATIC PDM Maintenance Station
Before activating process control, check the setting for the WinCC project type in WinCC 
Explorer. A single-user station project must be set as the project type. 

Activate process control in WinCC Explorer using the "Activate" icon.

Activate SIMATIC PDM ASSET Service 
You can display the diagnostics of field devices in faceplates with SIMATIC PCS 7 and 
SIMATIC PDM. Assign the current diagnostics project in SIMATIC PDM to be able to use the 
diagnostics function of SIMATIC PDM.

Requirements

● The Windows user using the ASSET must be a member of the "SIMATIC HMI" Windows 
group.

● Configuration of the PCS 7 multiproject/project is complete.

● SIMATIC PDM is installed on ES.

● Field device parameter assignment is complete.

● A PDM application is inserted into the PC station of the engineering station.

Procedure 

1. Select the PCS 7 multiproject/project in the component view of SIMATIC Manager.

2. Select the menu command Options > SIMATIC PDM > Settings... .

3. Select the "Maintenance" tab.
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4. Check the configured path.
If the configured path is not the desired path, select the path using the "Assign current 
project" button.

5. Click "OK".

Start SIMATIC PDM ASSET Service

Note

Note that you must manually restart the SIMATIC PDM ASSET Service in the SIMATIC PDM 
ASSET Service Manager on the engineering station once in order to receive data from PDM.

1. Click the following icon in the information area of the task bar of the operating system:
Start/stop the SIMATIC PDM ASSET Service.
The "SIMATIC PDM Asset Service Manager" dialog box opens.

"Stop" button

When you click this button, the SIMATIC PDM Asset Service stops.

"Start" button

When you click this button, the SIMATIC PDM Asset Service starts.

"Allow automatic start/stop" check box

If this check box is selected, the Asset Service can be started and stopped by other components 
(e.g. WinCC RTO, SAM, project archiving).

During archiving, the Asset Service is stopped and given a "lock flag" so that other components 
cannot start the Asset Service and thereby interrupt the archiving.

● If the Asset Service was activated prior to the archiving, it is started again automatically 
once archiving is finished and the "lock flag" is removed.
Start and stop commands of the Asset Service Manager always have higher priority, for 
example, they can start the Asset Service during ongoing archiving.

● If this check box is not selected, the Asset Service can only be started and stopped by the 
Asset Service Manager. The following applies then:

– If the Asset Service is started, archiving will fail.

– If the Asset Service is stopped, all faceplate queries via SAM are rejected with an error.

Editing several PCS 7 projects with PDM
If you edit several projects in SIMATIC Manager with a PDM computer, you have to observe 
the following sequence when you change between projects:

1. Stop the SIMATIC PDM ASSET Service on the PDM computer.

2. Stop the process mode on the maintenance station of the current project.
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3. Open the required project in SIMATIC Manager.

4. Set the maintenance project in the SIMATIC Manager.

5. Start the SIMATIC PDM ASSET Service on the PDM computer.

6. Start the process mode on the maintenance station of the current project.
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Menus and dialog boxes in SIMATIC PDM 9
9.1 "File" menu 

The menus and dialog boxes can contain other device-specific menu commands.

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, device-specific functions are grayed out in the second window and can only be 
accessed in the window that was opened first.

Note

Device-specific menu items and help for these menu items are derived from the device 
description assigned to the object. You will find device-specific information in the online help 
and in the documentation provided by the device manufacturer. The PDF file associated with 
this documentation does not contain any device-specific information.

9.1.1 Save
This menu command is used to save the current parameter settings from the parameter table 
in the project (Offline data storage) on hard disk.     

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, this menu item is grayed out in the second window and can only be accessed in the 
window that was opened first.

9.1.2 Exporting

This menu command starts the export of device data of a PDM object to an XML file.       

Make the settings for the export of device data in the "Export - <object name>" dialog.

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, this menu command is grayed out in the second window and can only be accessed 
in the window that was opened first.

See also
"Export - ..." dialog box (Page 176)
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9.1.2.1 "Export - ..." dialog box
Use the "Export - <Object name>" dialog box to make the settings for exporting device data 
and start the export function.

Selecting the export path and transformation file
● Export path

Enter the path for storing the generated XML files in the input box. The name of each 
exported XML file is structured as follows:

– Parameter export
Param$<plant-specific device name>$<date(YYYYMMDD_hhmmss)>.xml

– Structure export
Struct$<plant-specific device name>$<date(YYYYMMDD_hhmmss)>.xml

Note

The parameter export files are identified with the described prefix only in PDM V8.0.2 and 
higher.

● HTML transformation file

– XSL file that contains the information for display in HTML format.

– In this input box, you can specify a file containing reference data for the appearance of 
the export file (XML format). To create plant-specific HTML transformation files, use the 
default file as your starting point.

Selecting data for export
The following information can be included in the parameter export:

● Device parameters
Device parameters of the devices selected before export.

● Diagnostics
Table listing diagnostic parameters plus the associated diagnostic text.

● Document Manager
Table listing the names of the documents that have been assigned to a device.

If all three check boxes are cleared, only the structure export file is created. A folder containing 
parameter export files is not created.

The structure export file contains information on the object topology with all details required to 
generate the exported object structure again or to correspondingly expand an existing object 
structure. 
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Export file
To export, select the following categories for the export, which are listed in different sections 
in the export file:

Category Description
<Device> Contains information about the device
<Id> The PDM-internal object ID of the device.
<Type> The PDM-internal object type of the device.
<Class> The PDM-internal object class of the device.
<ObjectPath> The placement of the device in the communication path.
<OnlineValues> Specifies whether an online export is present.
<CatalogPath> The placement of the device in the EDD catalog.
<ObjectName> The object name of the device. 
<Section> The PDM-internal classification of the device.
<DeviceParame‐
ters>

Contains the parameters of the device.

<Documents> Attributes of the document manager
<Diagnostics> Attributes of device diagnostics

An individual attribute contains the following elements:

Attribute Description
Name Name of the attribute
Type Data type of the attribute
Label Identifier of the attribute
ParamViewMem‐
ber

Specifies whether the attribute is visible in the parameter view of PDM.

DisplayValue The value of the attribute that is used for the display.
Import Specifies whether the attribute is taken into account during the import.
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Attribute Description
State Status of the attribute Bit array whose value is formed from the following decimal 

values:
● 0: OK
● 1: Invalid value
● 2: Reserved by the system
● 4: Reserved by the system
● 8: Changed by the user
● 16: Changed by the communication
● 32: Initial value
● 64: Readable values only
● 128: General error
● 256: Unit conversion failed
● 512: Values could not be updated by the communication
● 1024: Value could not be transferred to the device
● 2048: Reserved by the system
● 4096: Reserved by the system

Unit Unit of the attribute

"Select" area - Selecting an object
If the object selected prior to the export contains subordinate objects, you can create a separate 
export file for each subordinate object. Use the option buttons in the "Selection" area to make 
your selection.

● Object
Only the selected object (parameter export)

● Object with all subordinate objects
Only the selected object/device with directly subordinate substructures (networks are not 
considered) (parameter and structure exports)

● Object with all subordinate objects and networks
The selected object/device, including all subordinate substructures (parameter and 
structure exports)

List
The list in the dialog box shows the objects for which an export file is to be generated, based 
on the option selected in the "Selection" area.

The following icons are used to indicate the processing status:

Icon Status
The export was performed without error.

Messages and warnings occurred during the export.

The export was not performed due to an error.
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Icon Status
The object is currently being processed elsewhere.

The export was not performed for this device.

The function is not supported by this device.

Export is currently underway for this device.

Display
The dialog box is updated during the export process. 

"Status" display

● During the process, the display field shows the entry "Export: action started.".

● Once the process is complete, the display field shows the entry "Export: action completed 
without error.".

Messages
Errors and warnings are entered in the message log.

Start
Starts the export.

Stop
Stops the export.

The object currently being processed will be completely processed.

Close
Closes the dialog box.

9.1.3 Importing

This menu command starts the import of device data from an XML file to a PDM object.       

Make the settings for the import of device data in the "Import - <object name>" dialog. 

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, this menu command is grayed out in the second window and can only be accessed 
in the window that was opened first.
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See also
"Import - ..." dialog box (Page 180)

9.1.3.1 "Import - ..." dialog box
In the "Import - <Object name>" dialog box, make the settings for the import of device data 
and start the import function.

The import assigns the data created for a device of network by the export to XML files to an 
existing device or network. You can select these XML files as the import file.

Import file   
In the "Import file" input box, enter the XML file that contains the data of the required device 
or network.

As soon as you enter the import file (parameter import file or structure import file), a device 
type consistency check is performed automatically. You can find information on this in the 
section "Importing configuration and parameter assignment data (Page 136)".

"Import identification data" check box
You can use the "Import identification data" check box to make the following settings:

● "Import identification data" check box activated (default)
The following data of the parameter export file are exported:

– Device name

– Description

– Message

● "Import identification data" check box deactivated
Certain identification data, i.e., device name, description, and message, are excluded from 
the import.

"Import device parameters" check box
You can activate the "Import device parameters" check box to make the following settings:

● "Import device parameters" check box selected (default)
The data record of the parameter export file is completely imported.

● "Import device parameters" check box cleared
The data record of the parameter export file is not imported.  

Parameter import
If the file to be imported is a parameter export file, only the exported object appears in the tree 
view. The object is shown with a blue icon because the object model was not adapted in the 
project. The object is prepared for the parameter import, which is started using the "Start" 
button.
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Parameter export files can only be imported to device objects or "placeholder objects. A 
"placeholder object" is an object that is produced by the "Insert object" command without a 
specific type selection.

Note

For FF devices, the type of the object to be imported must correspond exactly to the type of 
the start object. If they do not match, a corresponding message is displayed in the "Status" 
text box and the import cannot be started.

The actual import is started using the "Start" button.

The import is interrupted by the following message dialog box if the object types are different.
If you nevertheless want to continue the import, you can expect the following results:
–    No parameters will be deleted or added.
–    Only parameters with the same name will be overwritten in the target object.

Structure import
If the file to be imported is a structure export file, the structure of the exported object appears 
in the tree view. All device objects are "grayed out". This is an indicator that these objects have 
not yet be included in the configuration.

Structure export files can only be imported for objects of a compatible type or for "placeholder 
objects". A "placeholder object" is an object that is produced by the "Insert object" command 
without a specific EDD selection.

The import operation is started using the "Start" button.

Phase 1

First, the object structures in the project data storage are adapted as needed:

● Missing objects are generated. For device objects, the check to determine whether an 
object is 'missing' relies exclusively on address information and not on the name information.

● Adaptation of the type assignment after a positive consistency check.

● If the "Import identification data" check box is selected, the identification data is adapted.

Note

During Phase 1, the import cannot be canceled.

Phase 2

The object structure based on the file to be imported is structured after conclusion of "Phase 
1". All device objects are shown in "blue" to indicate that they have been incorporated in the 
configuration.
If problems occur during the creation of the object structure, the relevant import objects are 
marked in the tree and messages are generated. These can be called up using the "Messages" 
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button. 
In Phase 2, the parameter import occurs for all objects in the file to be imported. 

Note

During "Phase 2", the import can be canceled. The object currently being processed will be 
completely processed.

After the conclusion of "Phase 1", "Phase 2" starts automatically.  The parameter import then 
follows for all import objects for which an error was not signaled during the first pass.

List
During the import process, the "Import" dialog box shows which objects have been processed 
so far in a tree. 

The following icons are used to indicate the processing status:

Icon Status
The import was performed without error.

Messages and warnings occurred during the import.

The import was not performed due to an error.

The object is currently being processed elsewhere.

The import was not performed for this device.

The function is not supported by this device.

The import is currently running for this device.

Display
The dialog box is updated during the import. 

"Status" display

● During the process, the display field shows the entry "Import: action started.".

● Once the process is complete, the display field shows the entry "Import: action completed 
without error.".

Messages
Errors and warnings are entered in the message log.

Start
Starts the import.
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Stop
Stops the import.

The object currently being processed will be completely processed.

Close
Closes the dialog box.

9.1.4 Print
You can print out the parameter list for a device. 

Setting the printer options

Note

Note the following:
● The printer options depend on your computer's operating system and on the printer being 

used.
● The file is sent to the default printer.
● If the printout has more than one page, two periods are printed after the page number in 

the bottom right corner of the page. The last page does not have these periods, indicating 
no more pages are to follow.

Requirements
● SIMATIC PDM is open.

● In the structure view, an object is selected in the root folder of a device.
You can find information on the structure view in the section "Structure view (Page 73)".

Procedure
1. Select the menu command File > Print or click the "Print" button .

The "Print" dialog box opens.

2. Select the required options.

3. Click "OK".

9.1.5 Exit

This command closes the "SIMATIC PDM" program.   
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If changes have been made in the current session, a prompt appears giving you the option of 
saving the file before closing the program. 

9.1.5.1 "Save changes?" dialog box
This dialog box indicates that changes have been made, which have yet to be saved. 

● Click "Yes" if you want to save the changes.

● Click "No" if you want to discard the changes.

● Click "Cancel" if you do not want to exit SIMATIC PDM yet.
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9.2 Editing (depends on device)
The menus and dialog boxes can contain other device-specific menu commands.

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, device-specific functions are grayed out in the second window and can only be 
accessed in the window that was opened first.

Note

Device-specific menu items and help for these menu items are derived from the device 
description assigned to the object. You will find device-specific information in the online help 
and in the documentation provided by the device manufacturer. The PDF file associated with 
this documentation does not contain any device-specific information.
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9.3 "Device" menu
The menus and dialog boxes can contain other device-specific menu commands.

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, device-specific functions are grayed out in the second window and can only be 
accessed in the window that was opened first.

Note

Device-specific menu items and help for these menu items are derived from the device 
description assigned to the object. You will find device-specific information in the online help 
and in the documentation provided by the device manufacturer. The PDF file associated with 
this documentation does not contain any device-specific information.

9.3.1 Download to device

This menu command writes the parameters shown in the parameter table to the device.           

If you are not yet online, SIMATIC PDM makes an online connection at this time. 

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, this menu command is grayed out in the second window and can only be accessed 
in the window that was opened first.

Errors and messages
During the loading, all errors and messages are shown immediately. Any errors occurring in 
a device do not cause the entire action to be aborted; they only apply to the device that is 
currently being processed. Errors and other messages are saved and can be displayed at a 
later time. 

Suppressing message dialogs

You can suppress message dialogs during the loading. Select the "Execute 'Load' without info 
dialogs" check box. You can find additional information using the Options > SIMATIC PDM > 
Settings > The "Load" tab (Page 260) menu command.

Additional information
You can find information on loading FF devices in the PCS 7 FOUNDATION Fieldbus 
commissioning manual

See also
"Download to device - ..." dialog box (Page 187)
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9.3.1.1 "Download to device - ..." dialog box
In this dialog box, you enter the desired settings for downloading the configuration data to the 
devices. 

"Select" area
If the object selected prior to loading contains subordinate objects, you can load the 
configuration to all subordinate objects. Use the option buttons in the "Select" area to make 
your selection.

● Object

● Object with all subordinate objects

● Object with all subordinate objects and networks

Field Explanations/operating instructions
Object Loads only the data of the selected object. 
Object with all subordi‐
nate objects

Loads the data of the selected object, including all subordinate objects.
Note: 
The tree structure can be expanded and collapsed for objects with subordi‐
nate objects.

Object with all subordi‐
nate objects and net‐
works

Loads the data of the selected object, including all subordinate substruc‐
tures.

"Load changed parameters only" check box
If this check box is selected, only the changed parameters are transmitted to the devices.

List   
The list in the dialog box shows the objects that are to be loaded in accordance with the option 
button that has been activated in the "Select" area.

The processing status is indicated by the following icons:

Icon Status
Loading was performed without error. 

Messages and warnings occurred during the loading.

Loading was aborted due to an error.

The object is currently being processed elsewhere.

Loading has never been performed for this device.

Loading was not performed because the action is not supported by the device type.

Loading is currently underway for this device.
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Display
The dialog box is updated while the data is being loaded.

Status display

● During the process, the loading progress is indicated as a percentage for the relevant 
device.

● Once the process is complete, the display field shows the entry "Result".

Message log
● The message log shows errors and warnings or outputs from the EDD.

See also
Overview of Device Icons (Page 140)

9.3.2 Upload to PG/PC

This menu command reads the parameters of the device and displays them in the parameter 
table.           

If you are not yet online, SIMATIC PDM makes an online connection at this time. 

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, this menu command is grayed out in the second window and can only be accessed 
in the window that was opened first.

Note

Before uploading to PG/PC from remote I/Os, you need to add a corresponding number of 
empty modules below the head module in the configuration.

Errors and messages
During the loading, all errors and messages are shown immediately. Any errors occurring in 
a device do not cause the entire action to be aborted; they only apply to the device that is 
currently being processed. Errors and other messages are saved and can be displayed at a 
later time. 

Suppressing message dialogs

You can suppress message dialogs during the loading. Select the "Execute 'Load' without info 
dialogs" check box. You can find additional information using the Options > SIMATIC PDM > 
Settings > The "Load" tab (Page 260) menu command.
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Additional information
You can find information on loading FF devices in the PCS 7 FOUNDATION Fieldbus 
commissioning manual

See also
"Upload to PG/PC - ..." dialog box (Page 189)

9.3.2.1 "Upload to PG/PC - ..." dialog box
In this dialog box, you enter the desired settings for uploading the data from the devices to the 
configuration data. 

"Select" area
If the object selected prior to loading contains subordinate objects, you can load the 
configuration to all subordinate objects. Use the option buttons in the "Select" area to make 
your selection.

● Object

● Object with all subordinate objects

● Object with all subordinate objects and networks

Field Explanations/operating instructions
Object Loads only the data of the selected object. 
Object with all subordi‐
nate objects

Loads the data of the selected object, including all subordinate objects.
Note: 
The tree structure can be expanded and collapsed for objects with subordi‐
nate objects.

Object with all subordi‐
nate objects and net‐
works

Loads the data of the selected object, including all subordinate substruc‐
tures.

List     
The list in the dialog box shows the objects that are to be loaded in accordance with the option 
button that has been activated in the "Select" area.

The processing status is indicated by the following icons.

You can find more detailed information on icons in the section "Overview of Device Icons 
(Page 140)".

Icon Status
Loading was performed without error.

Messages and warnings occurred during the loading.

Loading was aborted due to an error.

Menus and dialog boxes in SIMATIC PDM 
9.3 "Device" menu

Help for SIMATIC PDM (V9.1)
Operating Manual, 02/2017, A5E39027365-AA 189



Icon Status
The object is currently being processed elsewhere.

Loading has never been performed for this device.

Loading was not performed because the action is not supported by the device type.

Loading is currently underway for this device.

Display
The dialog box is updated while the data is being loaded.

Status display

● During the process, the loading progress is indicated as a percentage for the relevant 
device.

● Once the process is complete, the display field shows the entry "Result".

Message log
● The message log only shows errors and warnings or outputs from the EDD.

9.3.3 Assign address and TAG

In the "Assign address and TAG" dialog box, you can assign new addresses and device names 
to a device:

● PROFIBUS field devices

● FF field devices

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, this menu command is grayed out in the second window and can only be accessed 
in the window that was opened first.

Changing the address and TAG online
For devices that can be reached online you can execute the following changes via the "Assign 
address and TAG" menu command:

● Move devices to any address within the segment or to a configured place

● For FF field devices: Change device name
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Consistency check
● The name or the address cannot be changed in the object.

● The target address is occupied and/or is located in an unauthorized area.

● The device name is unauthorized and/or already present in the segment.

Procedure
1. Open SIMATIC PDM for a configured device:

– In the process device view, select the Edit > Open object menu command.

– Double-click the device in HW Config.

2. Select the Device > Assign address and TAG ... menu command.

3. In the "Online" area, enter the following for the device located in the plant:

– The address (mandatory with PROFIBUS devices)

– Only possible with FF field devices: 
The device designation (TAG) of the field device in the plant configuration

4. Click "Find":

– A search is performed for a device at the online address entered.

– If a device is found, the online data is displayed.

– The "Transfer" button is now enabled.

5. Click "Transfer".

Note
Restart

Changing the address will restart the device.

Additional information
● Section ""Assign address and TAG..." dialog box (Page 191)"

● Section "Working with the LifeList (Page 145)"

9.3.3.1 "Assign address and TAG..." dialog box

Requirement
An online connection to the field device must be available to execute this function.   
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Required steps
The application of the function consists of the following steps:

1. Find
Establish an online connection to a device with the relevant device address.

2. Transfer
Transfer address and TAG to the device to which the online connection has been 
established.

Buttons

Button Function
Find
Button in the 
target device 
area (online)

You can use the search function to search for a device address online. 
Search criterion:
● For PROFIBUS devices: Online address only
● For FF devices: The online address or the device name
The name and address of an online device found is displayed.

Transfer
(Device: 
Project) area

If there is an online connection to a device, you can transfer the project data entered in the "Name/TAG" 
and "Address" input boxes to the device.
If the operation is successful (status \"Transfer succeeded\"), the same information is in both boxes.

Reset address
(only available 
for FF devices)

● The "Reset address" button is only available for FF devices.
● The function "moves" the device to the area for temporary FF devices (reserved address range for FF 

devices: Addresses 248 to 251). The name (TAG) remains unchanged.
● You can verify execution with LifeList .

Note
Restart

Changing the address will restart the device.

Note
Address or name (TAG) occupied

If the address or name (TAG) is occupied, then the action will not be performed. A 
corresponding message will be displayed.
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Device information
In the dialog box, the following data is shown for both the device in the project (source) and 
the detected device (online):

● Manufacturer

● Device type

● Device revision

See also
Working with the LifeList (Page 145)

9.3.4 Value comparison

Starts the comparison of device parameters. 

You make the settings for comparing device parameters in the "Value Comparison" dialog 
box (Page 193).

See also
Parameter table (Page 74)

9.3.4.1 "Value Comparison" dialog box

Purpose   
You start the comparison of device parameters in this dialog box. The value comparison is 
always based on the device parameter values saved in the project.

The device parameter values saved in the project can be compared with the following data 
types: 

● Offline data
Device parameter values saved in the project.

● Online data
Parameter values currently saved in the device.
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Comparisons
The following comparisons are possible:

● Comparison of the parameters of one device (offline/online parameter comparison)

● Comparison of the parameters of two devices:

– Offline/online parameter comparison

Selecting check boxes
The loaded object is the one which is currently selected in SIMATIC PDM in parameter 
assignment mode.

Comparison object Check box Additional information
Online data of the loa‐
ded object

Compare with online data of 
the loaded object

1. Click "Apply". The online data is read in 
from the device.

2. Click "OK".
Offline data of another 
object

Compare with offline data of 
another object

1. Click "Select object" dialog box 
(Page 194). 
The dialog box opens.

2. Select the comparison object that you want 
to search for.

3. Click "Apply". The online data or offline 
data of the comparison object is read.

4. Click "OK".

Online data of another 
object

Compare with online data of 
another object

Display
The Parameter table (Page 74) is expanded by the columns for value, unit and status of the 
comparison object. These columns cannot be edited.

Display Meaning
No color difference in columns The respective parameters and the associated values are iden‐

tical for both devices.
A yellow box in the value or unit col‐
umn of the comparison object.

The parameter is available in both devices. The associated 
values are different.

Yellow box in the parameter column The parameter is only available in one device.
A plant-specific value check must be carried out. Automatic 
analysis is not possible.
The value has been changed.

9.3.4.2 "Select object" dialog box
Use this dialog box to select the required comparison objects or partner objects. 
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9.3.5 Object properties

Displays general information about the selected object. 

This information is stored together with the parameter set. 
Depending on the device, some of this information can be transferred to the device, for 
example:

● TAG

● Message

● Description

● Address

● ...

9.3.5.1 "General" tab

Purpose   
On this tab you will find information on the PDM object and you can enter additional information, 
if you so wish. 

You can find information on this in the section ""Options" menu (Page 256)".

Field Explanations/operating instructions
Object name (TAG)* The name of the PDM object assigned during configuration is entered here 

as a default. 
You can enter a new object name. The change is applied everywhere where 
reference is made to the object name. The name is only visibly updated once 
the change has been saved or (in some cases) when the object concerned 
is next opened.

Description* Enter a comment for the object here, e.g. plant area and function, or leave 
the field blank.

Message* Enter a message here for a service technician, for example, or leave the field 
blank. 

Text 1*  
Enter additional information here or leave the field blank.
 

Text 2*
Text 3*
Author Displays the name of the author.
Date created Displays the date on which the PDM object was created.
Last change Displays the date on which the last change was made.
Comment* Enter a comment here or leave the field blank.
"System configuration" 
check box

If this option is activated, the object is linked with the system for hardware 
configuration (e.g. with STEP 7/HW Config).

License information Shows the utilization of the TAG licenses (number of tags used and licensed 
TAGs).
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Field Explanations/operating instructions
Priority* Select an object marking here (nothing, important, SIF).

This value is then displayed in a "Priority" column in the plant view.
Device checked Shows the time stamp for when the attribute "Device checked (Page 211)" 

was activated.
Project-specific write 
protection

Shows the time stamp for when the attribute "Project-specific write protec‐
tion (Page 250)" was activated.

* Entry can be changed.

9.3.5.2 "Device" tab

Purpose   
You display the device data in this tab. 

The contents of the fields cannot be changed. The contents are derived from the device 
description assigned to the object provided they are entered in this description. 

Some entries are displayed as codes instead of plain text.

Field Explanations/operating instructions
Device type Shows the device type as specified in the "Device Selection" dialog box.
Manufacturer Shows the manufacturer.
Order number Shows the order number of the device.
Catalog path Shows the catalog path.
Device DDL Shows the device description file assigned to the object.
EDD revision Shows the version of the device description file (hexadecimal format).
Device revision Shows the hardware version of the device (hexadecimal format).

9.3.5.3 "Diagnostics" tab

Purpose 
This tab shows information about the communication of the device. The icon shown for the 
device depends on the information available. If communication is disrupted, the device status 
and the date of the last test are empty.

Field Explanations/operating instructions
Communication status Shows whether the communication is good or faulty.
Last communication Shows the date on which the last communication with the device took place.
Message text Shows detailed information about the communication as well as communi‐

cation errors or connection problems.
Device status Shows specific information about the status of the connected device. 
Last check Shows the date when the device was last tested.
Message text Shows detailed information about the device status.
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"Update Diagnostics" button
Click the "Update Diagnostics" button if required.

9.3.5.4 "Communication" tab

Purpose
In this tab, you can display the address of a device (short address and long address for HART 
devices). If the device was configured in the process devices network view, you can change 
the address.

Field Explanations/operating instructions
Short address*
(default value: 0)

 The short address is displayed here for HART devices. 

Long address*
(default value: 
0x0000000000)

For HART devices, the long address is displayed here. 
As soon as the device is known, the long address is stored. 

DP master address*
(default value: 0)

The address of the hierarchical master on the bus. This parameter is optional 
– this value is ignored when configuring via HW Config.

IP address
(default value: 0.0.0.0)

The address that is based on the Internet protocol. 

* Entry can be changed.

Table 9-1 "Properties" area

Field Explanations/operating instructions
Master type
(default value: Secon‐
dary master)

The HART modem uses the serial port of a PC and a HART modem or HART 
interface connected to it to communicate with the connected HART devices. 
It can be both primary and secondary master. 

"Ignore secondary mas‐
ter" check box

If there is no secondary master, the time behavior can be optimized and 
devices can be addressed faster by enabling this option.

"Prefer 'Long address'" 
check box

Once a device is known, communication with it is performed only via the long 
address. In this case, multiple devices on the same HART modem can have 
the short address 0. To make a device known with short address, no other 
devices can be connected to the HART modem.

MODBUS communica‐
tion
(default value: Serial)

Serial: 
COM interface must be suitably set for the device (interface, baud rate, etc.).
IrDA: USB infrared adapter required. The device (1 at a time) then commu‐
nicates via this adapter. (Multiple USB IR adapters are not supported.)

Response time*
(default value: 1000 ms)

This is the time waited to obtain a response from a MODBUS device. If this 
value is too low, it is possible that no connection to the device will be made. 
If it is too high, the communication can be extremely slow.

Subnet ID*
(default value: 0x0000 
0x0000)

The S7 subnet ID of the network. This parameter is optional – this value is 
ignored when configuring via HW Config.
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Field Explanations/operating instructions
PROFIBUS CP slot*
(default value: 2)

The slot address of the PROFIBUS interface. This parameter is optional – 
this value is ignored when configuring via HW Config.

Rack no.
(default value: 0)

Number of the rack. The rack no. can only be 0 or 1.

* Entry can be changed.

NOTICE

HART device replacement

For a device replacement, this long address must be set to 0 so that a replacement device 
can be newly identified.

The replacement device must be the only device on the HART modem.

The "Redundancy" area is displayed for field devices which are capable of redundant 
interconnection.

Table 9-2 "Redundancy" area

Field Explanations/operating instructions
"Redundancy activated" 
check box

 There is a redundant partner device for this device.

Corresponding slave The redundant partner device can be found via this field.
Select object* A new object can be added with this button.

* Entry can be changed.

A network adapter can be selected for ETHERNET or PROFIBUS devices.

Table 9-3 "Assign assigned network and network adapter" area

Field Explanations/operating instructions
Assigned network The selected interface is displayed in this field.
Assign network to interface* A network can be added to the selected interface with this button.
"Use 'PG/PC Interface' set‐
tings" check box*

This device uses an PG/PC interface.

"Use network adapter" check 
box*

This device uses a network adapter.

Network adapter* A network adapter can be selected with this field.

* Entry can be changed.
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See also
Connecting field devices to a redundant bus system (Page 118)

"Select object" dialog box (Page 119)

9.3.5.5 "Document Manager" tab
Use this tab to assign documents to a PDM object.

Actions on the "Document Manager" tab

Action To execute
File 1. Click the "..." button.

2. Navigate to the document required.
3. Click "Open".

The storage path and file name of the selected file are 
displayed in the "File" box.

Title Enter a name for the document.
Test whether a document can be 
displayed

Select the menu command Open.

Remove a document from the list. Select the menu command Reset.

Open documents
To open the documents, select the SIMATIC PDM menu command Help > Document 
Manager. Select the required document from the submenu.

9.3.6 Calibration log

Purpose

You can use the "Calibration log" function of SIMATIC PDM to create calibration logs for field 
devices. You open the calibration log using the Device > Calibration log menu command.
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Dialog box
The "Calibration log" dialog box contains the following tabs:

Tab Settings and information
Test environment 
(Page 202)

● Field device data
● Operator data and test date of the calibration log
● Remarks of the operator about the test
● Comment field
● Settings for the scheduling 

(default: deactivated)
– Service
– Measuring circuit test
– Calibration

Diagnostics 
(Page 204)

● Information regarding the display of the communication connection status
● Information regarding the display of the device status
● Date of the last test
● Messages of the last test

Settings for measur‐
ing range (Page 204)

Channel-specific information (configurable: maximum of 8 channels)
● Channel selection
● Configurable settings for each channel:

– Measuring circuit unit
– Measuring range
– Output unit
– Output range
– Permitted deviation (setpoint/actual value)
– Comment fields

Attachments 
(Page 205)

Configure files that are to be attached to the log. Files with the following exten‐
sions may be used:
● pdf
● doc; docx
● xls; xlsx
● txt; csv
● rtf
● jpg; jpeg; png; gif; tiff; tif; bmp
● wav; wma
● htm; html
● chm; hlp
Note:
This function is not available in the SIMATIC PDM Portal.

Comments 
(Page 206)

● Additional comments for different comment types
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9.3.6.1 Menus and dialog boxes

File menu

Log archive
Opens the dialog with the saved logs.

Save
Saves the current log in PDF format

Storage location

Note

The default storage location is determined from the PDM settings. If you want to adapt the 
memory location, select the path in the "General" tab (Options > Settings for SIMATIC PDM 
menu).

Print
Prints the currently displayed view.

Close
Closes the log.

Options menu

Log settings
Opens the "Log settings" dialog box. 

In this dialog box, you can adapt the display of the calibration log according to your 
requirements and preferences.
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"Log settings" dialog box
● "Heading calibration log" text box.

You change the heading for the calibration log in this text box.

● "Log content" area
You configure the visibility of information in the calibration log in this area.

Name of text box Setting Visibility
Test environment You can change the heading for the 

"Test environment" area in this text 
box.

Always visible

Identification data You can change the heading for the 
"Identification data" area in this text 
box.

Always visible

Diagnostics You can change the heading for the 
"Diagnostics" area in this text box. 

If the "Visible" option is selected, this 
area is visible in the log.

Settings for measur‐
ing range

You can change the heading for the 
"Settings for measuring range" area 
in this text box.

Always visible

Available Channels You can set the number of device 
channels between one and eight in 
this text box.

-

Attachments You can change the heading for the 
"Attachments" area in this text box.

If the "Visible" option is selected, this 
area is visible in the log.

Comments You can change the heading for the 
"Comments" area in this text box.

If the "Visible" option is selected, this 
area is visible in the log.

Help menu

Help
Opens the help for SIMATIC PDM. 

You can navigate to different help topics from the Table of Contents. The "Index" and "Find" 
functions enable you to display information on specific terms. 

About...
Opens the information about the version and the copyright details of SIMATIC PDM.     

Tab

"Test environment" tab

Purpose
This tab displays information about the current device. You can change the names in the "Plant" 
and "Tester" text boxes. Without these names, it is not possible to save and print logs.
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The following entries are possible:

● Entering comments 

● Enabling scheduling for service monitoring, measuring circuit testing and calibration.

"Measuring circuit identification data" area

Field Explanations/operating instructions
Plant You can assign the plant name in this text box.
Process tag Shows the name of the process tag 
Device type Shows the device type
Manufacturer Shows the manufacturer of the field device
Article number Shows the article number of the device
EDD revision Identifier for an EDD revision
Type ID Identifier for a device type in hexadecimal format.

You can find information on this in IEC 61804-3.
Device revision Identifier for a device revision

"Test details" area

Field/Area Explanations/operating instructions
Tester You can assign the name of the tester in this text box.
Date of test Shows the date of the test
Test medium  
Comment Enter a comment.

"Scheduling" area

Field Explanations/operating instructions
"Service" check box If this check box is selected, you can enter a time for the next service 

in the text box.
The time is monitored. When the time is reached or exceeded, the 
diagnostic status of the instance is set to "Maintenance demanded".

"Measuring circuit test" check 
box

If the check box is selected, you can enter a time for the next meas‐
uring circuit test in the text box.
The time is monitored and when it is reached or exceeded, the diag‐
nostic status of the instance is set to "Maintenance required".

"Calibration" check box If the check box is selected, you can enter a time for the next cali‐
bration in the text box. 
The time is monitored and when it is reached or exceeded, the diag‐
nostic status of the instance is set to "Maintenance required".
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"Diagnostics" tab

Purpose
This tab displays general diagnostic information about the current device.

"Measuring circuit identification data" area

Field/button Explanations/operating instructions
Communication Shows whether the communication is good or faulty.
Device status Shows detailed information about the status of the connected device.
Last check Shows the date when the device was last tested.
Message text Shows detailed information about the device status.
"Update diagnostics" button Click the "Update diagnostics" button if required.

"Settings for measuring range" tab

Purpose
You can specify the calibration settings and the information for the measuring circuit test in 
this tab.

"Selected channel" drop-down list
You can select the channel number (1 ... n) of the active channel in this drop-down list.

"Settings for measuring range for channel 1 ... n" area

Area Field Explanations/operating instructions
Measuring range
 
 

Unit of measure Enter the current unit of measure.
Start value Enter the start value.
End value Enter the end value.

Output
 
 

Unit of measure Enter the current unit of measure. 
Start value Enter the start value.
End value Enter the end value.

 Permitted deviation between 
actual value and setpoint.

Maximum permissible deviation between the ac‐
tual value and setpoint in percent.

Menus and dialog boxes in SIMATIC PDM 
9.3 "Device" menu

Help for SIMATIC PDM (V9.1)
204 Operating Manual, 02/2017, A5E39027365-AA



Area Field Explanations/operating instructions
Characteristics Table Table column header You can enter up to ten value pairs.

Measured value The measured value is specified by the tester as a 
percentage. 
The unit of measure cannot be changed here.

Encoder signal of the speci‐
fied value

Value is calculated based on the settings and speci‐
fied measured value.

Setpoint Value is calculated based on the settings and speci‐
fied measured value.

Actual value Adoption of the current value
Deviation in % The deviation is calculated between the actual val‐

ue and setpoint.
The field turns red as soon as the deviation is out‐
side the maximum permissible tolerance setting.

Comment on hardware Enter a comment for the hardware.
Comment on monitoring Enter a comment for the monitoring.
Comment on measuring circuit Enter a comment for the measuring circuit.

"Attachments" tab

Purpose
You can add up to five attachments in this tab, which you can then show or link to in the log. 
You can delete or open previously inserted files.

Possible file types:

● pdf

● doc; docx

● xls; xlsx

● txt

● jpg

"Attachment 1 ... 5" area

Field/button Explanations/operating instructions
File -
"Select file" button Click this button to select a file as an attachment.
"Remove file" button Click this button to delete a previously added file.
"Show" button Click this button to show a previously added file.
"Heading" Enter a name for the document.
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"Comments" tab

Purpose
You can enter additional comments in this tab.

Comment types

Area Explanations/operating instructions
Wiring error Enter a comment for this comment type.
Inappropriate measuring location
Device error
Comment on error

9.3.6.2 Menu bar

Structure
Below, you will find an overview of the calibration log menus.

Menu Submenu 
File
 

● Log archive (Page 201)
● Save (Page 201)
● Print (Page 201)
● Close (Page 201)

Options ● Log settings (Page 201)
Help ● Help (Page 202)

● About... (Page 202)

9.3.6.3 Toolbar
The toolbar is located below the menu bar and contains several buttons. You can use the 
buttons to execute frequently used menu commands without having to open the menu. 

Icons     
Meanings of the icons used:

Icon Menu com‐
mand

Description

Save 
(Page 201) 

Saves the current log as a PDF file.

Print 
(Page 201) 

Prints the current view.
Opens the "Print" dialog box. Select a printer that is available on the 
computer.

Menus and dialog boxes in SIMATIC PDM 
9.3 "Device" menu

Help for SIMATIC PDM (V9.1)
206 Operating Manual, 02/2017, A5E39027365-AA



Icon Menu com‐
mand

Description

Log settings 
(Page 201) 

Opens the "Log settings" dialog box.
You can adapt the log according to your requirements and preferen‐
ces in this dialog box.

Help 
(Page 202) 

The SIMATIC PDM help opens.

9.3.7 Change log

The change log records which actions have been performed with SIMATIC PDM on objects 
of the plant. 

Properties 
● The change log is part of the associated SIMATIC project.

● The change log is a circular log (first in, first out).

● Some boxes of the change log are created automatically. Information is entered in the 
language preset in the SIMATIC project.

Note
SIMATIC PDM Client 

Archived change logs cannot be opened on the SIMATIC PDM Web client.

Requirements for using the "Change Log" function
You need the "SIMATIC PDM Extended" license key to use the "Change log" function.

Entries in the change log
The "SIMATIC PDM Change Log" dialog window displays actions which have been performed 
in the project or on individual objects (devices). The displayed actions depend on the object 
displayed in SIMATIC PDM.
You can limit the displayed information by setting the filter. The "Action" drop-down list of the 
filter shows the actions that can be displayed.
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Note

The following actions are NOT recorded in the change log:
● Actions that were triggered from the EDD
● Operator actions that were performed in the online context

It comprises the following entries:

Column Meaning
Object identification Database identification of the object (device or network) for which a change was 

made
Object name Name of the object (device or network) for which a change was made
Action Indicates which action was executed
Time Time set on the computer when the action was carried out
Description Description of action
Details Details of action
Comment Comment which a user entered before applying a change.

Prerequisite for an entry:
In the SIMATIC PDM settings, the "Show entry dialog for change log comments" 
check box on the "General" tab must be selected.

User name Logon name of the user who performed the change
Computer name Name of the computer from which the change was made
Object path Name of a device with the path where the device can be found

9.3.7.1 Menus and dialog boxes

File menu

Add entry
Adds a manual entry to the change log.

Archive
Archives the entries depending on the set date.

Load archive
Loads an archived change log.

This function is not available on SIMATIC PDM Web client.
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Print
Prints the currently displayed view.

Close
Closes the change log or LifeList.

View menu

Filter
Reduces the information displayed in the change log.

Find
Finds entries in the change log after input of a search term. 

"Find" dialog box
Procedure

1. Select the menu command View > Find.
The "Find" dialog box opens.

2. Enter the string you are looking for.

3. Click "Find next".

Settings in the "Find" dialog box
● Entry field

 You can enter any string. You can search for this string.

● "Find next" button
The system searches through the displayed device list. The displayed change log is 
searched and the found entry selected.
The next entry found is selected when you press the button again. The search starts all 
over again at the end of the list. 
A message will inform you if no matching entry is found.

● "Close" button
Closes the dialog.

Show all objects
Toggles the view between all objects and the object for which the change log was called.
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Help menu

Help
Opens the help for SIMATIC PDM. 

You can navigate to different help topics from the Table of Contents. The "Index" and "Find" 
functions enable you to display information on specific terms. 

Info
Opens the information about the version and the copyright details of SIMATIC PDM.     

9.3.7.2 Menu bar

Structure
Below, you will find an overview of the Change log menus.

Menu Submenu 
File
 

● Add entry (Page 208)
● Archive (Page 208)
● Load archive (Page 208)
● Print (Page 209)
● Close (Page 209)

View ● Filter (Page 209)
● Find (Page 209)
● Show all objects (Page 209)

Help ● Help (Page 210)
● Info (Page 210)

9.3.7.3 Toolbar
The toolbar is located below the menu bar and contains several buttons. You can use the 
buttons to execute frequently used menu commands without having to open the menu. 
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Icons     
Meanings of the icons used:

Icon Menu com‐
mand

Description

Add entry 
(Page 208) 

Adds a manual entry to the change log.

Print 
(Page 209) 

Prints the current view.
Opens the "Print" dialog box. Select a printer that is available on the 
computer.

Filter 
(Page 209)

Filters the displayed change log.
Opens the "Filter" dialog box. Enter a character string and specify 
the filter options.

Find 
(Page 209) 

Searches the displayed change log.
Opens the "Find" dialog box. Enter a character string and specify the 
search options.

Show all ob‐
jects 
(Page 209) 

Toggles the view between all objects and the view from which the 
change log was called.

Help 
(Page 210) 

The SIMATIC PDM help opens.

9.3.8 Set device checked

The "Device checked" attribute is an independent bit memory.

An activation stamp is set at the time when the attribute is activated. This time stamp is deleted 
at the time of deactivation. 

There are no special access restrictions for setting the attribute. The attribute is usually set by 
the service technician or the project administrator.

Function of the "Device checked" attribute
This attribute does not influence the mode of operation of the PDM. None of the internal PDM 
functions depend on this attribute or are influenced by it.

The user defines the exact meaning of this attribute.

Devices with the set attribute can be queried, displayed and exported with the appropriate filter 
setting using the maintenance station.
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Procedure
1. There are three different options to set or reset the attribute:

– Set the attribute in the PDM device properties.

– Set the attribute with the button in the toolbar.

– Set the attribute in the device menu.

In the plant view, the activation stamp is displayed in the "Device checked" column.
As soon as the attribute is changed (activated/deactivated), an entry is made in the PDM 
Change Log. 

9.3.9 Check configuration

You can use the "Check configuration" function for the device description connected to a PDM 
object. This function checks whether the device description conforms to the EDD configuration 
rules for SIMATIC PDM.

Properties 
● The check for device descriptions includes all the attributes of the associated object. 

● If inconsistencies are identified, SIMATIC PDM enters a description of the current state in 
the log for the "Check configuration" function.

Procedure
1. Select an object (device) in the tree of the parameter view.

2. Select the Device > Check configuration menu command. 
The following dialog is opened:

3. Click "Start".
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4. You will see a message as soon when the check is completed.

– If the device description conforms to the EDD configuration rules for SIMATIC PDM, the 
result indicates that the device is configured correctly.

– When the device description is configured incorrectly, the message "Messages and 
warnings were issued" is displayed.

5. To display the message log, click "Messages".
The message log opens.

6. Click the "Save..." button to save the message log.
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9.3.10 Templates...

Some manufacturers offer templates in the device descriptions (EDD) . 

You can apply these templates to other devices. 

When parameters are configured in a template, you can transfer a plant-specific configuration 
to other devices by applying the template.

Properties 
If templates are integrated into a device description, these templates are available for 
integrating device descriptions in SIMATIC PDM. 

If parameters of a device contained in a template are changed, the template of the device is 
changed as well.

Requirement
A device is selected in the parameter view.

Use templates
1. Select the menu command Device > Templates....

The list of all defined templates included in the device description of the currently selected 
device is displayed. The title of the displayed templates are read from the "Label" attribute 
of the template.

2. Click a template.
A table with the following columns opens:

– Parameter

– Value

– Unit

– Status

3. If you change a parameter, it will be marked with the following symbol in the "Status" column: 

4. To save the device-specific changes, click "OK".
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9.4 "View" menu 
The menus and dialog boxes can contain other device-specific menu commands.

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, device-specific functions are grayed out in the second window and can only be 
accessed in the window that was opened first.

Note

Device-specific menu items and help for these menu items are derived from the device 
description assigned to the object. You will find device-specific information in the online help 
and in the documentation provided by the device manufacturer. The PDF file associated with 
this documentation does not contain any device-specific information.

9.4.1 Process variables / Measured value display (depends on device)

General Information         
Opens the "Process variables" or "Measured value display" online dialog box. 

Structure
The dialog box and its associated help program are structured in a device-specific manner. 
The information required for this is derived from the device description assigned to the object. 
Therefore, this dialog box cannot be described in detail here.

The device description contains the following information:

● Structure of the individual tabs

● Which values are displayed

● Where and how the values are displayed

● Scope of the message window

● Scope and content of the device-specific help program

Status information
Status icons can be displayed for every value shown in the dialog box. You can find information 
on this in the section ""Status" column of the parameter table (Page 76)".

Operator elements
● "Close" button

● "Messages" button

● "Help" button
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Cycle time
If there is an online connection to the field device, the process variables displayed in the dialog 
box are updated cyclically. To set the cycle time, select the menu command Options > SIMATIC 
PDM > Settings in SIMATIC Manager and then go to the "Communication (Page 259)" tab.

9.4.2 Start LifeList
This menu command is used to call the LifeList.

LifeList makes it possible to identify active field devices without configuration. With LifeList , 
you perform a scan on one of the following network objects:

● PROFIBUS DP network

● PA network

● HART modem network

● FF network

9.4.3 Charts and trends (depends on device)

Note

History trends can be displayed in SIMATIC PDM if they are provided by the manufacturer of 
the device description.

Additional information
● Section "Trend chart (Page 160)"

● Section "Work with trends (Page 167)"

● Section "Editing trends (Page 168)"

● Section "Icons and buttons (Page 164)"
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Example
The figure below shows an example of a dialog window with history trends.     

9.4.3.1 Displaying process variables and measured values 

Note

Functions for the display of process variables and measured values are available in SIMATIC 
PDM, if they are provided by the manufacturer of the device description.

Note

If the color of the value to be displayed changes from orange to yellow, the parameter could 
not be read within the monitoring time.

Menus and dialog boxes in SIMATIC PDM 
9.4 "View" menu 

Help for SIMATIC PDM (V9.1)
Operating Manual, 02/2017, A5E39027365-AA 217



Additional information
● Section "Trend chart (Page 160)"

● Section "Tachometer chart (Page 163)"

● Section "Bar chart (Page 162)"

● Section "Icons and buttons (Page 164)"

● Section "Work with trends (Page 167)"

● Section "Editing trends (Page 168)"
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9.5 "Diagnostics" menu
The menus and dialog boxes can contain other device-specific menu commands.

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, device-specific functions are grayed out in the second window and can only be 
accessed in the window that was opened first.

Note

Device-specific menu items and help for these menu items are derived from the device 
description assigned to the object. You will find device-specific information in the online help 
and in the documentation provided by the device manufacturer. The PDF file associated with 
this documentation does not contain any device-specific information.

9.5.1 Update diagnostics

SIMATIC PDM attempts to establish an online connection to the object which is currently 
selected and to update the status.         

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, this menu item is grayed out in the second window and can only be accessed in the 
window that was opened first.

See also
"Update diagnostics - ..." dialog box (Page 219)

9.5.1.1 "Update diagnostics - ..." dialog box
In this dialog box, you select the objects whose diagnostic status you want to update. 

"Select" area
If the object selected prior to carrying out the menu command contains subordinate objects, 
you can determine the diagnostic status for all subordinate objects. Use the option buttons in 
the "Select" area to make your selection.

● Object

● Object with all subordinate objects

● Object with all subordinate objects and networks
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Field Explanations/operating instructions
Object Determines the diagnostic status of the selected object. 
Object with all subordi‐
nate objects

Determines the diagnostic status of the selected object, including all subor‐
dinate objects.
Note: 
The tree structure can be expanded and collapsed for objects with subordi‐
nate objects.

Object with all subordi‐
nate objects and net‐
works

Determines the diagnostic status of the selected object, including all subor‐
dinate substructures.

Starting an action
The diagnostic status of the selected object is not determined automatically. Click "Start" to 
start the action for the current selection.

List   
The list in the dialog box shows the objects for which the diagnostic status is to be determined 
based on the option selected in the "Select" area.

The processing status is indicated by the following icons:

The diagnostic status was determined. 

Messages and warnings occurred during determination of the diagnostic status.

Determination of diagnostic status was aborted due to an error.

The object is currently being processed elsewhere.

Determining diagnostic status has never been performed for this device.

Determining diagnostic status was not performed because the action is not supported by 
the device type.
Determination of diagnostic status is currently underway for this device.

Display
Click "Start" to execute the menu command. The dialog box is updated as long as the function 
is executed or until the function is canceled.

Status display

● During the process, the progress is indicated as a percentage for the relevant device.

● Once the process is complete, the display field shows the entry "Result".

Messages
The message log shows errors and warnings or outputs from the EDD.
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9.6 "Options" menu (depends on device)
The menus and dialog boxes can contain other device-specific menu commands.

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, device-specific functions are grayed out in the second window and can only be 
accessed in the window that was opened first.

Note

Device-specific menu items and help for these menu items are derived from the device 
description assigned to the object. You will find device-specific information in the online help 
and in the documentation provided by the device manufacturer. The PDF file associated with 
this documentation does not contain any device-specific information.
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9.7 "Help" menu

9.7.1 Contents
This menu command displays the Help on SIMATIC PDM. 

You can navigate to different help topics from the Table of Contents. The "Index" and "Find" 
functions enable you to display information on specific terms. 

9.7.2 Help for device parameters
This menu commands calls the device-specific help with descriptions of the parameters. 

Note: The device-specific help is derived from the device description assigned to the object.

9.7.3 Info
This menu command displays information about the software version and the copyright. 

9.7.4 Find
The displayed parameter list is scanned.

You may enter any string. You can run the search for this string.

9.7.5 Document Manager
In the submenu of the "Document Manager" menu command, you can call the documents 
assigned to a PDM object.

To assign the documents, select the menu command Device > Object Properties > Document 
Manager.

Additional information
● Section "Inserting plant-specific documents for process mode (Page 122)"

● Section ""Document Manager" tab (Page 199)"
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Menus and dialog boxes for SIMATIC PDM in HW 
Config 10

Installing SIMATIC PDM makes additional functions available in the Edit > SIMATIC PDM 
menu of HW Config. 

See also
Exporting (Page 230)

Importing (Page 231)

Download to device (Page 231)

Upload to PG/PC (Page 232)

Update diagnostics (Page 233)

Start LifeList (Page 233)

Device selection (Reassign) (Page 233)

Show change log (Page 235)

Synchronizing with HW Config (Page 236)
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Menus and dialog boxes for SIMATIC PDM in the 
SIMATIC Manager 11
11.1 "Edit" menu

11.1.1 SIMATIC Manager > "Edit" menu
Installing SIMATIC PDM makes additional functions available in the Edit menu of SIMATIC 
Manager. 

Requirement
A field device or a network with subordinate field devices is selected in one of the SIMATIC 
PDM views.

Functions
● Start SIMATIC PDM

Select menu command Edit > Open object.

● SIMATIC PDM functions
The following functions are available in the Edit > SIMATIC PDM menu:

– Exporting (Page 175) 

– Importing (Page 179) 

– Download to device (Page 186) 

– Upload to PG/PC (Page 188) 

– Update diagnostics (Page 219) 

– Start LifeList (Page 233) 

– Device selection (Reassign) (Page 233) 

– Show change log (Page 235)

11.1.2 Object properties

Displays general information about the selected object. 
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This information is stored together with the parameter set. 
Depending on the device, some of this information can be transferred to the device, for 
example:

● TAG

● Message

● Description

● Address

● ...

11.1.2.1 "General" tab

Purpose   
On this tab you will find information on the PDM object and you can enter additional information, 
if you so wish. 

You can find information on this in the section ""Options" menu (Page 256)".

Field Explanations/operating instructions
Object name (TAG)* The name of the PDM object assigned during configuration is entered here 

as a default. 
You can enter a new object name. The change is applied everywhere where 
reference is made to the object name. The name is only visibly updated once 
the change has been saved or (in some cases) when the object concerned 
is next opened.

Description* Enter a comment for the object here, e.g. plant area and function, or leave 
the field blank.

Message* Enter a message here for a service technician, for example, or leave the field 
blank. 

Text 1*  
Enter additional information here or leave the field blank.
 

Text 2*
Text 3*
Author Displays the name of the author.
Date created Displays the date on which the PDM object was created.
Last change Displays the date on which the last change was made.
Comment* Enter a comment here or leave the field blank.
"System configuration" 
check box

If this option is activated, the object is linked with the system for hardware 
configuration (e.g. with STEP 7/HW Config).

License information Shows the utilization of the TAG licenses (number of tags used and licensed 
TAGs).

Priority* Select an object marking here (nothing, important, SIF).
This value is then displayed in a "Priority" column in the plant view.
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Field Explanations/operating instructions
Device checked Shows the time stamp for when the attribute "Device checked (Page 211)" 

was activated.
Project-specific write 
protection

Shows the time stamp for when the attribute "Project-specific write protec‐
tion (Page 250)" was activated.

* Entry can be changed.

11.1.2.2 "Device" tab

Purpose   
You display the device data in this tab. 

The contents of the fields cannot be changed. The contents are derived from the device 
description assigned to the object provided they are entered in this description. 

Some entries are displayed as codes instead of plain text.

Field Explanations/operating instructions
Device type Shows the device type as specified in the "Device Selection" dialog box.
Manufacturer Shows the manufacturer.
Order number Shows the order number of the device.
Catalog path Shows the catalog path.
Device DDL Shows the device description file assigned to the object.
EDD revision Shows the version of the device description file (hexadecimal format).
Device revision Shows the hardware version of the device (hexadecimal format).

11.1.2.3 "Diagnostics" tab

Purpose 
This tab shows information about the communication of the device. The icon shown for the 
device depends on the information available. If communication is disrupted, the device status 
and the date of the last test are empty.

Field Explanations/operating instructions
Communication status Shows whether the communication is good or faulty.
Last communication Shows the date on which the last communication with the device took place.
Message text Shows detailed information about the communication as well as communi‐

cation errors or connection problems.
Device status Shows specific information about the status of the connected device. 
Last check Shows the date when the device was last tested.
Message text Shows detailed information about the device status.
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"Update Diagnostics" button
Click the "Update Diagnostics" button if required.

11.1.2.4 "Communication" tab

Purpose
In this tab, you can display the address of a device (short address and long address for HART 
devices). If the device was configured in the process devices network view, you can change 
the address.

Field Explanations/operating instructions
Short address*
(default value: 0)

 The short address is displayed here for HART devices. 

Long address*
(default value: 
0x0000000000)

For HART devices, the long address is displayed here. 
As soon as the device is known, the long address is stored. 

DP master address*
(default value: 0)

The address of the hierarchical master on the bus. This parameter is optional 
– this value is ignored when configuring via HW Config.

IP address
(default value: 0.0.0.0)

The address that is based on the Internet protocol. 

* Entry can be changed.

Table 11-1 "Properties" area

Field Explanations/operating instructions
Master type
(default value: Secon‐
dary master)

The HART modem uses the serial port of a PC and a HART modem or HART 
interface connected to it to communicate with the connected HART devices. 
It can be both primary and secondary master. 

"Ignore secondary mas‐
ter" check box

If there is no secondary master, the time behavior can be optimized and 
devices can be addressed faster by enabling this option.

"Prefer 'Long address'" 
check box

Once a device is known, communication with it is performed only via the long 
address. In this case, multiple devices on the same HART modem can have 
the short address 0. To make a device known with short address, no other 
devices can be connected to the HART modem.

MODBUS communica‐
tion
(default value: Serial)

Serial: 
COM interface must be suitably set for the device (interface, baud rate, etc.).
IrDA: USB infrared adapter required. The device (1 at a time) then commu‐
nicates via this adapter. (Multiple USB IR adapters are not supported.)

Response time*
(default value: 1000 ms)

This is the time waited to obtain a response from a MODBUS device. If this 
value is too low, it is possible that no connection to the device will be made. 
If it is too high, the communication can be extremely slow.

Subnet ID*
(default value: 0x0000 
0x0000)

The S7 subnet ID of the network. This parameter is optional – this value is 
ignored when configuring via HW Config.
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Field Explanations/operating instructions
PROFIBUS CP slot*
(default value: 2)

The slot address of the PROFIBUS interface. This parameter is optional – 
this value is ignored when configuring via HW Config.

Rack no.
(default value: 0)

Number of the rack. The rack no. can only be 0 or 1.

* Entry can be changed.

NOTICE

HART device replacement

For a device replacement, this long address must be set to 0 so that a replacement device 
can be newly identified.

The replacement device must be the only device on the HART modem.

The "Redundancy" area is displayed for field devices which are capable of redundant 
interconnection.

Table 11-2 "Redundancy" area

Field Explanations/operating instructions
"Redundancy activated" 
check box

 There is a redundant partner device for this device.

Corresponding slave The redundant partner device can be found via this field.
Select object* A new object can be added with this button.

* Entry can be changed.

A network adapter can be selected for ETHERNET or PROFIBUS devices.

Table 11-3 "Assign assigned network and network adapter" area

Field Explanations/operating instructions
Assigned network The selected interface is displayed in this field.
Assign network to interface* A network can be added to the selected interface with this button.
"Use 'PG/PC Interface' set‐
tings" check box*

This device uses an PG/PC interface.

"Use network adapter" check 
box*

This device uses a network adapter.

Network adapter* A network adapter can be selected with this field.

* Entry can be changed.
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See also
Connecting field devices to a redundant bus system (Page 118)

"Select object" dialog box (Page 119)

11.1.2.5 "Document Manager" tab
Use this tab to assign documents to a PDM object.

Actions on the "Document Manager" tab

Action To execute
File 1. Click the "..." button.

2. Navigate to the document required.
3. Click "Open".

The storage path and file name of the selected file are 
displayed in the "File" box.

Title Enter a name for the document.
Test whether a document can be 
displayed

Select the menu command Open.

Remove a document from the list. Select the menu command Reset.

Open documents
To open the documents, select the SIMATIC PDM menu command Help > Document 
Manager. Select the required document from the submenu.

11.1.3 SIMATIC PDM

11.1.3.1 Synchronize
Executes synchronization for changes to the HART server in the multiplexer network. 

The synchronization function takes the following into consideration:  

● New hierarchy and devices are inserted. 

● Hierarchies and devices that no longer exist are removed. 

● Renamed devices are also renamed in PDM.

11.1.3.2 Exporting

This menu command starts the export of device data of a PDM object to an XML file.       
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Make the settings for the export of device data in the "Export - <object name>" dialog.

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, this menu command is grayed out in the second window and can only be accessed 
in the window that was opened first.

See also
"Export - ..." dialog box (Page 176)

11.1.3.3 Importing

This menu command starts the import of device data from an XML file to a PDM object.       

Make the settings for the import of device data in the "Import - <object name>" dialog. 

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, this menu command is grayed out in the second window and can only be accessed 
in the window that was opened first.

See also
"Import - ..." dialog box (Page 180)

11.1.3.4 Download to device

This menu command writes the parameters shown in the parameter table to the device.           

If you are not yet online, SIMATIC PDM makes an online connection at this time. 

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, this menu command is grayed out in the second window and can only be accessed 
in the window that was opened first.

Errors and messages
During the loading, all errors and messages are shown immediately. Any errors occurring in 
a device do not cause the entire action to be aborted; they only apply to the device that is 
currently being processed. Errors and other messages are saved and can be displayed at a 
later time. 

Suppressing message dialogs

You can suppress message dialogs during the loading. Select the "Execute 'Load' without info 
dialogs" check box. You can find additional information using the Options > SIMATIC PDM > 
Settings > The "Load" tab (Page 260) menu command.
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Additional information
You can find information on loading FF devices in the PCS 7 FOUNDATION Fieldbus 
commissioning manual

See also
"Download to device - ..." dialog box (Page 187)

11.1.3.5 Upload to PG/PC

This menu command reads the parameters of the device and displays them in the parameter 
table.           

If you are not yet online, SIMATIC PDM makes an online connection at this time. 

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, this menu command is grayed out in the second window and can only be accessed 
in the window that was opened first.

Note

Before uploading to PG/PC from remote I/Os, you need to add a corresponding number of 
empty modules below the head module in the configuration.

Errors and messages
During the loading, all errors and messages are shown immediately. Any errors occurring in 
a device do not cause the entire action to be aborted; they only apply to the device that is 
currently being processed. Errors and other messages are saved and can be displayed at a 
later time. 

Suppressing message dialogs

You can suppress message dialogs during the loading. Select the "Execute 'Load' without info 
dialogs" check box. You can find additional information using the Options > SIMATIC PDM > 
Settings > The "Load" tab (Page 260) menu command.

Additional information
You can find information on loading FF devices in the PCS 7 FOUNDATION Fieldbus 
commissioning manual

See also
"Upload to PG/PC - ..." dialog box (Page 189)
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11.1.3.6 Update diagnostics

SIMATIC PDM attempts to establish an online connection to the object which is currently 
selected and to update the status.         

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, this menu item is grayed out in the second window and can only be accessed in the 
window that was opened first.

See also
"Update diagnostics - ..." dialog box (Page 219)

11.1.3.7 Start LifeList
This menu command is used to call the LifeList.

LifeList makes it possible to identify active field devices without configuration. With LifeList , 
you perform a scan on one of the following network objects:

● PROFIBUS DP network

● PA network

● HART modem network

● FF network

11.1.3.8 Device selection (Reassign)
Use this menu to assign a different or new device description (EDD) to an object.

The devices are structured by the device types in a tree structure.       

Note
Integrated devices

You can only select devices for which a device description file has been integrated via the 
Device Integration Manager.
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Device description dependency
When a device is replaced in a plant, you have to update the project in SIMATIC PDM. When 
devices are replaced in a plant, the following situations can arise:

● Device descriptions are compatible
The device to be replaced can be operated with the device description of the device to be 
integrated (e.g. after updating the firmware). 
The configuration can be downloaded to the device to be integrated.

● Device descriptions are incompatible
The device to be replaced cannot be operated with the device description of the device to 
be integrated, e.g. a device is replaced with one from a different manufacturer.
The device to be replaced should be removed from the configuration when it is replaced 
with an incompatible device. Reconfigure the device.
Recommendation:
Export the device data before making the change, because the device will be initialized 
again with the new device description.
The following steps describe how to reassign the device description.

Assigning a device description to an object
You have the following options for assigning a device description to an object:

● Identify a device via an online connection

● Assigning the device description manually

Identify a device via an online connection
If you have an online connection to the device, click the "Device identification" button.

● "Device identification" button
When you click this button, a connection to the device is established and an attempt is 
made to read the information from the device and assign the required device description 
to it.

● If not all the necessary information could be read out, you need to assign the device 
description manually. After device identification, the tree structure includes a preselection 
with paths designed for the device. 
Select one of these paths.

● If device identification is not unique, select the required device in the result list and click 
the "Device identification" button again. 
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Assigning the device description manually
Select the required device description from the "Device catalog" list, based on the following 
data:

● Manufacturer

● Device type

● Device revision and DD revision

Note
Note on remote I/Os

With remote I/O, you search for the manufacturer and a type for the head-end station during 
device selection. 

Assign the required device description to the device.

Device description missing from PC
Open the Device Integration Manager and integrate the missing device descriptions.

See also
Integrating device descriptions (Page 51)

11.1.3.9 Show change log

The change log records which actions have been performed with SIMATIC PDM on objects 
of the plant. 

Properties 
● The change log is part of the associated SIMATIC project.

● The change log is a circular log (first in, first out).

● Some boxes of the change log are created automatically. Information is entered in the 
language preset in the SIMATIC project.

Note
SIMATIC PDM Client 

Archived change logs cannot be opened on the SIMATIC PDM Web client.

Requirements for using the "Change Log" function
You need the "SIMATIC PDM Extended" license key to use the "Change log" function.
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Entries in the change log
The "SIMATIC PDM Change Log" dialog window displays actions which have been performed 
in the project or on individual objects (devices). The displayed actions depend on the object 
displayed in SIMATIC PDM.
You can limit the displayed information by setting the filter. The "Action" drop-down list of the 
filter shows the actions that can be displayed.

Note

The following actions are NOT recorded in the change log:
● Actions that were triggered from the EDD
● Operator actions that were performed in the online context

It comprises the following entries:

Column Meaning
Object identification Database identification of the object (device or network) for which a change was 

made
Object name Name of the object (device or network) for which a change was made
Action Indicates which action was executed
Time Time set on the computer when the action was carried out
Description Description of action
Details Details of action
Comment Comment which a user entered before applying a change.

Prerequisite for an entry:
In the SIMATIC PDM settings, the "Show entry dialog for change log comments" 
check box on the "General" tab must be selected.

User name Logon name of the user who performed the change
Computer name Name of the computer from which the change was made
Object path Name of a device with the path where the device can be found

11.1.3.10 Synchronizing with HW Config
Starts the synchronization of PDM objects with HW Config objects.

You can select the "Synchronize with HW Config" menu command in process device plant 
view or the process device network view. This menu command starts the synchronization of 
PDM objects with HW Config objects.
The message log shows any warnings, errors and information relating to the synchronization 
or synchronization conflicts.

If SIMATIC PDM is installed, but there is no valid license, the following "message" is displayed:

You are attempting to start configuration/engineering for SIMATIC PDM with insufficient 
licensing. If you answer Yes, synchronization between HW Config and the SIMATIC PDM 
database will be necessary after sufficient licensing. Do you want to continue?

If you answer with "yes", you allow all HW Config actions during this session regardless of 
SIMATIC PDM licenses.
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If you continue with "No", the license check of SIMATIC PDM becomes active for this HW 
Config session.

11.1.3.11 Create stand-alone project
The substructures of an existing, integrated project can be applied to a PDM stand-alone 
project. 

Procedure
1. Open the process device network view.

2. Create an Ethernet network.

3. Select the created Ethernet network.

4. In the Properties > Communication shortcut menu, enter the subnet ID with which you PC 
is connected.
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5. Start the function "Import from existing station".
A dialog opens in which you can see all projects.
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6. Select the project whose substructure you want to apply.
A dialog opens that shows all automation stations that are connected to the Ethernet subnet 
ID.

7. Select an automation station and click "Import".
The import starts.
The corresponding substructures are created below the Ethernet network.
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11.2 "Insert" menu

11.2.1 Inserting an object
Installing SIMATIC PDM makes additional functions available in SIMATIC Manager. These 
can be accessed by selecting the menu command Insert > SIMATIC PDM.

Select the PDM object that you want to insert. Depending on the object selected in SIMATIC 
Manager, only objects which can be inserted at the selected object are available.

Requirement
One of the following views is open:

● Process device network view

● Process device plant view

Purpose   
The configured view determines which of the following object types can be inserted:

● Object

● Networks

● Interface

● Communications network

● Devices

Insert > SIMATIC PDM > <submenu>

Networks (process device network view) and devices (process device plant view)
● You can select the "Networks" menu command in the process device network view. This 

menu command expands the tree structure by adding the "Networks" folder for working 
with PDM objects.

● You can select the "Devices" menu command in the process device network view. This 
menu command expands the tree structure by adding the "Devices" folder for working with 
PDM objects.

Note
"Networks" (process device network view) and "Devices" (process device plant view) folders

If you want to reuse copied projects without PDM objects, you can delete this folder 
including the PDM configuration it contains. Select the following function in the SIMATIC 
Manager: File > Save As... with the "With reorganization (slow)" check box selected. 
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Communications network (process device network view)
In the process device network view, you can create the following communications networks 
under the "Networks" folder: 

● Ethernet network

● HART modem network

● HART server (multiplexer network)

● MODBUS network

● PROFIBUS DP network.

● PROFINET network

Selecting the menu command opens the selection dialog ("Insert object - <...>" dialog box).

You can use the menu command to create the following objects:

● Only when downloading the first time: 
The "PC station" object (PDM computer, computer on which PDM is installed)

● The communications network

Password protection
If there is password protection for communication with a PROFINET network, follow these 
steps:

1. In the shortcut menu, select the menu command Update connection data.
The dialog box "The station is password protected" appears.

2. Enter the password in the input box.

3. Click "OK".

Objects 
● Process device network view

In the process device network view, you can create objects for field devices. This is done 
at a communications network.
Selecting the menu command opens the selection dialog ("Insert object - <...>" dialog box). 
Click the "Assign Device Type..." button. The "SIMATIC PDM device selection" dialog box 
opens. Select the field devices in the tree structure.

● Process device plant view
You can create objects (objects for field devices) in the process device plant view under 
the "Devices" folder.
Selecting the menu command opens the selection dialog ("Insert object - <...>" dialog box). 
Click the "Assign Device Type..." button. The "SIMATIC PDM device selection" dialog box 
opens. Select the field devices in the tree structure.

Interface (process device network view)
You can add an interface to a PC object in the process device network view. 

Select the PC object and then the menu command Insert New Object > Interface in the shortcut 
menu.
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SIMATIC PDM offers the following three interface types:

● DP interface (PROFIBUS DP interface via CP module)
You can make additional network settings (Page 197) for a PROFIBUS DP interface.

● COM interface (serial interface via COM1, COM2)

● ETHERNET interface
You can make additional network settings (Page 197) for an ETHERNET interface.

Network Required 
PROFIBUS DP network DP interface
HART modem network COM interface
MODBUS network COM interface
S7 DSGW network Ethernet interface
HART server (multiplexer network) Installation of the HCF OPC server

See also
"Communication" tab (Page 197)
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11.3 "View" menu 

11.3.1 Process devices plant view
The process devices plant view provides an overview of all configured devices in all configured 
networks.

This view is used to obtain a quick overview of the configured devices. You cannot configure 
new networks in this view.

Opening and adapting the process devices plant view
Opening the process devices plant view (Page 68)

Adapting the process device plant view (Page 69)

See also
"Settings" for the SIMATIC project (Page 85)

PDM parameter view (Page 250)

Toolbar in the "Process device plant view" dialog box (Page 244)

Messages (Page 68)

Menus and dialog boxes in the "Process device plant view" dialog box (Page 244)
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11.3.2 Menus and dialog boxes in the "Process device plant view" dialog box

11.3.2.1 Toolbar in the "Process device plant view" dialog box
The toolbar is located below the menu bar and contains a number of icons with which you can 
quickly perform frequently used menu commands without having to open a menu and select 
the command.

Icons and functions
The objects are linked to the following menu commands:

Objects in the toolbar Menu command
Exporting (Page 175) 

Importing (Page 179) 

Download to device (Page 186) 

Upload to PG/PC (Page 188) 

Update diagnostics (Page 219) 

Device Selection (Reassign) (Page 248)

"Project" selection box Select the project. You can find more information on this in the section 
""Project" selection box (Page 249)".

Input box (for search strings) This box is an input box for search strings: 
Enter a search string. You can find more information on this in the 
section "Find (Page 249)".

11.3.2.2 "File" menu

New object

Requirement A project is selected.
Procedure Click on the menu command File > New Object.

The selection for configurable properties appears.
You can find more information on this in the section "Inserting an object (Page 240)".
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Note
Configuring user diagnostics with the maintenance station 

The newly created objects have no communication assignment. This subsequent 
communication assignment is not possible. 

This configuration allows the user diagnostics with the maintenance station.

Copy
Copy the selected object to the clipboard.

Note

You can only copy objects that have been configured in the process device plant view (objects 
with no communication assignment). 

Devices that have been configured in the process device network view or in HW Config cannot 
be copied.

Paste
Insert the object from the clipboard at the selected point.

Note

You can only insert objects that have been copied in the process device plant view (objects 
with no communication assignment). 

Requirement:

A project is selected in the "Project" selection box. No objects can be inserted into the 
multiproject.

Delete
Deletes the selected object from the process device plant view. 

Note

You can only delete objects that have been configured in the process device plant view (objects 
with no communication assignment). 

Devices that have been configured in the process device network view or in HW Config cannot 
be deleted.
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Rename object
The function for renaming objects is similar to that in the Windows Explorer.

11.3.2.3 "Device" menu

Exporting

This menu command starts the export of device data of a PDM object to an XML file.       

Make the settings for the export of device data in the "Export - <object name>" dialog.

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, this menu command is grayed out in the second window and can only be accessed 
in the window that was opened first.

See also
"Export - ..." dialog box (Page 176)

Importing

This menu command starts the import of device data from an XML file to a PDM object.       

Make the settings for the import of device data in the "Import - <object name>" dialog. 

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, this menu command is grayed out in the second window and can only be accessed 
in the window that was opened first.

See also
"Import - ..." dialog box (Page 180)

Download to device

This menu command writes the parameters shown in the parameter table to the device.           

If you are not yet online, SIMATIC PDM makes an online connection at this time. 

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, this menu command is grayed out in the second window and can only be accessed 
in the window that was opened first.
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Errors and messages
During the loading, all errors and messages are shown immediately. Any errors occurring in 
a device do not cause the entire action to be aborted; they only apply to the device that is 
currently being processed. Errors and other messages are saved and can be displayed at a 
later time. 

Suppressing message dialogs

You can suppress message dialogs during the loading. Select the "Execute 'Load' without info 
dialogs" check box. You can find additional information using the Options > SIMATIC PDM > 
Settings > The "Load" tab (Page 260) menu command.

Additional information
You can find information on loading FF devices in the PCS 7 FOUNDATION Fieldbus 
commissioning manual

See also
"Download to device - ..." dialog box (Page 187)

Upload to PG/PC

This menu command reads the parameters of the device and displays them in the parameter 
table.           

If you are not yet online, SIMATIC PDM makes an online connection at this time. 

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, this menu command is grayed out in the second window and can only be accessed 
in the window that was opened first.

Note

Before uploading to PG/PC from remote I/Os, you need to add a corresponding number of 
empty modules below the head module in the configuration.

Errors and messages
During the loading, all errors and messages are shown immediately. Any errors occurring in 
a device do not cause the entire action to be aborted; they only apply to the device that is 
currently being processed. Errors and other messages are saved and can be displayed at a 
later time. 

Suppressing message dialogs

You can suppress message dialogs during the loading. Select the "Execute 'Load' without info 
dialogs" check box. You can find additional information using the Options > SIMATIC PDM > 
Settings > The "Load" tab (Page 260) menu command.
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Additional information
You can find information on loading FF devices in the PCS 7 FOUNDATION Fieldbus 
commissioning manual

See also
"Upload to PG/PC - ..." dialog box (Page 189)

Update diagnostics

SIMATIC PDM attempts to establish an online connection to the object which is currently 
selected and to update the status.         

If a device is opened twice, for example, by opening the higher-level network and by opening 
it directly, this menu item is grayed out in the second window and can only be accessed in the 
window that was opened first.

See also
"Update diagnostics - ..." dialog box (Page 219)

Device Selection (Reassign)
This function is used to manually assign a device type and thus an EDD for the selected object.

See also
Creating your own device library using the project filter (Page 53)

Creating your own device library from a collection of device descriptions (Page 54)

Displays general information about the selected object. 

This information is stored together with the parameter set. 
Depending on the device, some of this information can be transferred to the device, for 
example:

● TAG

● Message

● Description

● Address

● ...
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11.3.2.4 Functions

"Project" selection box
The "Project" selection box organizes the data displayed in the device list:

● Selection of an individual project: 
The list shows the devices and data of the project.

● Select a multiproject: 
The list shows the devices and data from the entire multiproject.

Click on the "Project" selection box. The "Project" selection box displays all available user 
projects. Select individual projects or select "All" to see all the devices included in the selected 
projects.

Find
Enter the "string" (word) or partial string in the input box to be used for the search. 

● Limit search to a single column of the table 
Click on the header in the table. Select the check box for the columns in which for the term 
to be searched.

● Find multiple strings
Spaces enable you to filter according to multiple terms in the table columns that are selected 
for the search. No wildcards are accepted.
Example: 
"SITRANS 00" to find the strings "SITRANS" and "00"

● Change search
Changes the search string. 

● Delete search string
If you do not want to limit the search, delete the entries in the input box.

Sorting columns
● Sort

Left-click in table header of a column. 
Sorts the table based on this column. 
A left-click on a sorted column reverses the sort order in the table based on the clicked 
column.

● Limit search to a single column of the table 
Click in the table. Open the shortcut menu and select the check box for the columns in 
which you want to search for the term.

● Change the order of the columns of the table 
Click on the header in the table. Select the column with the header. Hold down the left 
button and drag the column to the desired position within the table.
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Hardware configuration
When an object has been created using HW Config, the "Hardware configuration" application 
can be opened. 
HW Config analyzes the current configuration and, if possible, highlights the corresponding 
object.

PDM parameter view
You have the following options for opening SIMATIC PDM:

● Double-click on the object.

● Select an object

– Press Enter.

– CTRL + ALT + O

– "Open object" shortcut menu

The parameter view of SIMATIC PDM opens.

Show change log
Opens the change log. (See also Show change log (Page 235)")

Specify project-specific write protection
The "Project-specific write protection" function prevents unintentional changes of field device 
parameters.

Note

This function is not an absolute write protection against parameter changes in the device. It 
only prevents unintentional changes by the user. Depending on the architecture of the DD 
devices, DD methods and functions can change the parameters.

An activation stamp is set at the time when the project-specific write protection is activated. 
This time stamp is deleted at the time of deactivation. 

There are no special access restrictions for setting a project-specific write protection. The 
function is usually activated or deactivated for configured field devices by the project 
administrator.

Effects of the project-specific write protection
Activation of the project-specific write protection has an effect on the following functionalities:

● The "LoadToDevice" function in the device menu, the maintenance menu as well as in the 
online dialogs, all method buttons and the transfer button are locked or deactivated.

● In case of bulk operations, write-protected devices are omitted.
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● Write orders from the device DD cannot be intercepted.

● Pure read operations, such as "LoadToPc", "Diagnostics" or device export as well as display 
of process data in measured value dialogs still work.

Procedure
1. Open the plant view.

2. Select the field devices for which you want to set project-specific write protection and those 
whose project-specific write protection you wish to revoke.

3. Open the shortcut menu with a right-click.

4. Select the menu item "Project-specific write protection".
The check mark in front of the "Project-specific write protection" menu item either appears 
or disappears.
The time stamp in the "Write protection" column either appears or disappears.
The padlock symbol at the respective device symbol appears or disappears.
As soon as write protection changes (activated/deactivated), an entry is made in the PDM 
change log. 

11.3.3 Operation view

Core statement
The operation view indicates all operations initiated by you.

Opening the operation view
You open the operation view in one of two ways:

● Click "View > Operation View" 

● Perform an operation
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Structure
The operation view is located below the plant view and shows all operations initiated by you. 
You can use the dividing line in the upper area to change the size of the operation view. This 
setting is retained the next time the operation view is opened.

Closing the operation view
The upper area of the operation view contains the "X" button. Click this button to close the 
operation view. If you would like to close the operation view while operations are being 
executed, an error message to that effect appears.
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Controlling the operation view
The operations of the operation view are controlled in the left area. The following two symbols 
are used for this.

Symbol Description
The operations are being executed.

The operations have been paused.

Filtering the operation view
You filter the operations of the operation view in the left area. The following four filters are 
available:

Status Description
Completed All operations that are completed are displayed.
Error All operations that were finished with an error are displayed.
Warning All operations that were finished with a warning are displayed.
Successful All operations that were finished successfully are displayed.

Status bar
The lower area contains the status bar of the operation view. The results of the operations are 
given in the status bar. The following three statuses are possible:

Symbol Description
(x) "x" operations were successfully executed.
(x) "x" operations were finished with a warning.
(x) "x" operations were finished with an error.

Operation list
The area on the right displays the operation list. It shows information on the individual 
operations in a table.

Table column: Status
The following statuses exist:

Symbol Status Visible under
The operation was successfully execu‐
ted.

Completed, Successful

Messages and warnings occurred dur‐
ing execution of an operation.

Completed, Warning

The operation was not executed due to 
an error.

Completed, Error

The operation is currently being pro‐
cessed elsewhere.

Completed, Error
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Symbol Status Visible under
The operation is waiting to be executed. Active

The operation was not executed. Completed, Successful

The operation is currently being execu‐
ted.

Active

Table column: Object name
The name of the device, the diagnostic information, the status and the project-specific write 
protection are displayed.

Table column: Operation type
The following operation types are displayed:

Symbol Operation type
Export

Import

Download to device

Upload to PG/PC

Update diagnostics

Table column: Progress
A progress bar with percentage information appears while an operation is being executed.

Table column: Status message
Messages can occur while an operation is being executed.

Interactions while operations are being executed
It is impossible to completely prevent unwanted interactions from taking place. If this happens, 
the respective line in the table of the operation view is marked in orange and a dialog box 
appears. Operator control of the plant view and the associated operation view is then disabled 
until all dialogs have been closed. 

Change log
If you have activated the "Show input dialog for comments in change log" option, a change log 
is displayed in the plant view for each operation that you have initiated. The number of devices 
selected is irrelevant.
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Export
A dialog box appears for the export. The settings in the dialog apply to all selected devices. 
The following settings are available:

● Export directory

● HTML transformation file

● The information to be exported, e.g. device parameters, diagnostics, document manager

Import
A dialog box appears for the import. The settings in the dialog apply to all selected devices. 
The following settings are available:

● Import file

● Identification data for the import

● Device parameters for the import

11.3.4 Process devices network view
The process devices network view displays the devices in groups according to the network 
topology. 

You can configure smaller projects directly in the process devices network view, for example, 
for end-to-end connections between a PC and a device in the factory.

Opening the process device network view
1. Select the View > Process device network view menu command in SIMATIC Manager. 

The process device network view opens.

See also
"Settings" for the SIMATIC project (Page 85)

Menus and dialog boxes for SIMATIC PDM in the SIMATIC Manager
11.3 "View" menu 

Help for SIMATIC PDM (V9.1)
Operating Manual, 02/2017, A5E39027365-AA 255



11.4 "Options" menu
You will find the following views in SIMATIC Manager after the installation of SIMATIC PDM:

● Process device plant view

● Process device network view

Project settings
The project settings are made in the SIMATIC Manager. These settings apply to the SIMATIC 
project and SIMATIC PDM.

● Language for the menus and dialog boxes

● Default project view

● Display

● Details in the columns

Make the project settings In SIMATIC Manager using the following menu command: Options 
> Settings...

Settings Tab Meaning
Language selection "Language" tab Language displayed in the menus and dialog boxes in the SIMATIC 

Manager and SIMATIC PDM
Default project view
 

"View" tab Start view for the SIMATIC Manager: Available views of SIMATIC 
PDM:
● Process device plant view
● Process device network view

Details in the columns "Columns" tab Views and object types in the parameter table

"Columns" tab
On the "Columns" tab, you can select the columns that you want to be displayed in a PDM 
view.

Select an object type in the tree structure. Then go to the "Visible Columns" list and activate 
the check boxes for the entries you want to be displayed for the selected object type.

Object types

● Type 1 in the tree structure

– Process device plant view

– Process device network view

● Type 2 in the tree structure

– Process device plant view > Devices

● Type 3

– Process device network view > Networks
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● Type 4

– Process device network view > Networks > PC

● Type 5

– Process device network view > Networks > Communication network

– Process device network view > Networks > Communication network > Object(on all 
subordinate levels)

 Visible columns
Object type Type 1 Type 2 Type 3 Type 4 Type 5
Object name Standard Standard Standard Standard Standard
Picture Name For OS Standard - - - -
LID
(Location identifier denotes the 
installation position of a device)

- Standard - - -

Address - x - Standard Standard
Description Standard Standard Standard Standard Standard
Message Standard Standard Standard Standard Standard
Device status - Standard - - Standard
Last communication - Standard - - Standard
Text1 x x x x x
Text2 x x x x x
Text3 x x x x x
Device - Standard x x Standard
PLT ID* - Standard - - x
Manufacturer - Standard - - Standard
Serial number - x - - x
Installation date - x - - x
Hardware version - x - - x
Software version - x - - x
Article number - x - - x
Object status - Standard - - Standard
DD revision - x - - x
Author x x x x x
Revision date Standard Standard Standard Standard Standard
Comment x x x x x

*Process control ID generated internally by PDM for identification of an object for connections 
to the Asset Management System (PCS 7 Maintenance Station and PDM Maintenance 
Station).

● Type 6

– Settings for a multiproject
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 Process device plant view (multiproject) Process device network view (multiproject)
Object name Standard Standard
Project language Standard Standard
UNC path Standard Standard
Path to "Computer" Standard Standard
Computer Standard Standard
Computer after removal Standard Standard
Path after removal Standard Standard

See also
Settings for SIMATIC PDM (Page 258)

Menus and dialog boxes for SIMATIC PDM in the SIMATIC Manager (Page 225)

11.4.1 Settings for SIMATIC PDM

This command opens the "Settings" dialog box.     

In this dialog box, you can adapt SIMATIC PDM to your preferences and requirements.

Setting options for SIMATIC PDM
Select the menu command Options > SIMATIC PDM > Settings... .

Settings Tab Notes
Device parameters "General" tab (Page 259) Display of the device parameters
Communication "Communication" tab 

(Page 259) 
Settings for communication

Load procedures The "Load" tab (Page 260) Selection of information for load procedures
Device Integration 
Manager

"Device Integration Manag‐
er" tab (Page 261) 

Settings for the Device Integration Manager

Maintenance project "Maintenance Station" tab 
(Page 262) 

Settings for the maintenance station project

PDM clients "PDM clients" tab (Page 263) Allow computers to access to the SIMATIC 
PDM Server through a browser

Change log "Change Log" tab 
(Page 264)

Settings for the change log

Service "Service" tab (Page 264) Settings for expert mode of SIMATIC PDM

See also
"Settings" for the SIMATIC project (Page 85)
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11.4.1.1 "General" tab

Purpose   
You can set the display of the device parameters in this tab.

Area Field Explanations/operating instructions
Project "Use message as long TAG for HART 

revision < V6" check box
If this check box is selected, the string stored in the "Message" pa‐
rameter is sent as a "Long TAG" for HART devices with a HART revi‐
sion prior to V6. 

"Select type when device is inserted in 
HW Config" check box

If the check box is selected, the dialog for device type selection ap‐
pears immediately when you insert a device in HW Config if the device 
cannot be assigned explicitly to a device type.
If the check box is cleared, this dialog does not appear until the device 
is opened for the first time.

File paths HTML transformation file XSL file that contains the information for display in HTML format.
Path for "Export" files Storage path for files created with the "Export" function.
Path for "Asset export" files Storage path for "Asset export" files
Path for "Document" files Storage path for "Document Manager" files
Path for "Message protocol" files Storage path for "Message protocol" files
Path for "Compare Log" files Path for "Compare Log" files
Path for "Calibration Log" files Storage path for "Calibration Log" files
Path for "Archive" files Storage path for "Archive" files

11.4.1.2 "Communication" tab

Purpose   
The following communication settings can be made in this tab:

Field Explanations/operating instructions
Cycle time
(default value: 1000 
ms)

Updating of the values shown in the "Process value display" dialog box is carried 
out in accordance with the time interval entered here. 
Note: You can change the cycle time value for periodic communication jobs. We 
recommend against significantly reducing the cycle time unless absolutely nec‐
essary. 

Identity If the "Identity check" check box is selected, SIMATIC PDM performs an identity 
check automatically each time there is any online communication.
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Field Explanations/operating instructions
Device diagnostics If the "Diagnostics update" check box is selected, SIMATIC PDM performs de‐

vice diagnostics automatically each time there is any online communication.
HART communica‐
tion

If the "SHC mode enabled" option is activated, SIMATIC PDM independently 
detects for the analog channels of HART remote I/Os whether the SHC function 
(uninterrupted HART command sequence) as per the "HART on PROFIBUS" 
specification from the "PROFIBUS & PROFINET International (PI)" fieldbus or‐
ganization is supported. 
● SIMATIC PDM is able to use SHC mode if the HART module of the remote 

I/O supports this mode. 
This results in shorter reading and writing times for the parameter data of 
HART field devices.

● If the HART module of the remote I/O does not support SHC mode, the 
conventional communication method is used instead.

Note: 
Communication with HART field devices interrupted:
If communication with individual HART field devices is interrupted repeatedly 
when this option is used, you should deactivate it when working with the HART 
field devices concerned.

Identity check and device diagnostics

Note
Reduction of times for servicing or loop check

You can reduce the load/read times by up to 20 seconds if you deactivate the identity check 
and device diagnostics. You can still use the "Update diagnostics (Page 233)" function for 
diagnostics.

During any communication with the field device, identity is checked and the diagnostics is 
updated.

You have the option of disabling these functions

Manually updating the diagnostics is still possible

11.4.1.3 The "Load" tab
On the "Load" tab, specify which information you want to be displayed during loading 
processes. 
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"Upload to PG/PC" area

Check box Explanations/operating instructions
Save parameter set in project data re‐
gardless of transmission errors.

Saves the configured parameters even if individual parame‐
ters could not be loaded from the device. 

Save inconsistent parameter sets in 
project data

Saves the parameters received from the device, even if indi‐
vidual parameters have invalid values (for example, range 
limit exceeded). 

Execute even if the device TAG does not 
match the project data TAG

Executes the action even if the device identifiers in the device 
and in the project data differ.

"Download to Device" area

Check box Explanations/operating instructions
Reset changed configuration flag Resets the configuration flag after successfully loading a de‐

vice.
Each change in the configuration of a device sets the config‐
uration flag. 

Download inconsistent parameter sets 
to the device.

Writes parameter values to the device, even if the values are 
invalid (e.g. range exceeded). 

Execute even if the device TAG does 
not match the project data TAG

Executes the action even if the device identifiers in the device 
and in the project data differ.

"Execute 'Load' without info dialogs" check box
If this check box is selected, information dialogs are not displayed during download. This setting 
applies to all loading processes.

"Exclude passivated FF blocks" check box
If this check box is selected, passivated function blocks are ignored during download. 

11.4.1.4 "Device Integration Manager" tab
You can open the configuration dialog for the Device Integration Manager by selecting the 
menu command Options > SIMATIC PDM > Settings... in SIMATIC Manager and then opening 
the "Device Integration Manager" tab.       

Visible columns Displayed information
Status* Status of the device description integration
Path* Catalog path of the devices for which a device description was found
Device name* Device name
Manufacturer* Manufacturer
Communication* Communication type for the connection to the field device
Device class* Hierarchical name of the device type (e.g. flow sensor)
New version* Version of the device description which was read in from a device description library
Integrated version* Version of the device description that is integrated in SIMATIC PDM
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Visible columns Displayed information
Integrated on Date on which a device description was integrated into SIMATIC PDM
Description Descriptive text from the device description
Type ID ID for a device type in hexadecimal format
GSD file Name of the communication description file
New EDD revision Revision of the imported device description
Integrated EDD revision Revision of the integrated device description
New device revision Device revision of the device description that was read from a device description library. 

Devices of the associated device type with this device revision can be interpreted in SIMATIC 
PDM.

Integrated device revision Device revision of the device description which is integrated in SIMATIC PDM. Devices with 
this device revision of the device type can be interpreted in SIMATIC PDM.

Device library Revision of the device description library (EDD library) from which the device description of 
the associated device has been read in

* Selected by default

Use the following buttons to speed up the configuration process:

● Select all (select)

● Deselect all

● Reset selection

"Actions during device integration" area               

Check box Explanations/operating instructions
Semantic check If this check box is selected, the Device Integration Manger checks 

the device description files for semantic errors during the integration 
process.

11.4.1.5 "Maintenance Station" tab

Purpose   
In this dialog box, you specify the path to the project of a maintenance station for the use of a 
maintenance station. 

Table 11-4 Maintenance project area

Field Explanations/operating instructions
"Maintenance project" in‐
put box

You can enter the path for the maintenance project in this input box. 

"Assign current project" 
button

Click this button to use the currently open project as the project for the 
maintenance station.

"Transfer maintenance 
alarm to MS station" 
check box

Select this check box if you want maintenance alarms that are detected by 
SIMATIC PDM to be sent to the maintenance station. This option must be 
enabled for integration into the PDM MS.
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Table 11-5 "Client settings" area

Field Explanations/operating instructions
"Automatic logoff of the 
session when there is no 
activity" check box

Select this check box if the SIMATIC PDM Server idle sessions should log 
off after a specified time.
Enter the time to wait until logoff in the "Time" input box.
 

"Time" input box You can specify the time after which idle sessions are to be logged off.
Requirement: 
The "Automatic logoff portal view in case of inactivity" check box is selected.

Additional information
You can find information on working with the maintenance station in the configuration manual 
titled Process Control System PCS 7 Operator Station.

11.4.1.6 "PDM clients" tab
You can allow computers to access to the SIMATIC PDM Server through a browser in the 
"PDM clients" tab.

The number of computers is limited by the number of available PDM clients.

"License information" display area

Note
Insufficient licenses available

If there are not enough licenses, you need to release clients. 

To release a client, clear the check box for the client that you want to release.

The "License Information" display area shows you the number of currently active PDM 
sessions via a browser and the number of licensed PDM clients. 

Access table in the "PDM Clients" tab

Column Function
Network share If you select the check box for a client (x), the computer with the IP address specified 

in the line is allowed to access the SIMATIC PDM Server.
IP address Select the "Network share" check box and enter the IP address of a computer to 

be authorized to access the SIMATIC PDM Server.
Comment Enter a plant-specific comment (e.g. name of the computer in the plant).

● "Enable all possible clients" button
Activates all available PDM client licenses.

● "Disable all clients"
Blocks access to the SIMATIC PDM Server.
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Releasing licenses
To release a client, click on the selected check box of the client. 
The IP address and the comment of the client is retained. You do not have to enter the 
information again the next time you use the client. The updated license information is displayed 
in the License Information section.  

11.4.1.7 "Change Log" tab

"Enable change log" check box
When this check box is selected, a log file is created when changes are made in SIMATIC 
PDM. 

"Automatic Archiving" area

Drop-down list Explanations/operating instructions
Off Disables automatic archiving of the log file.
By interval Archives the log file in a particular cycle (yearly, monthly, weekly). 
By limit value or memory size Archives the log file once it has reached a particular memory size.

"Show input dialog for comments in change log" check box
If this check box is activated, the "Change log comment on process" dialog opens when 
changes are entered. You can enter comments in the entry dialog. 

11.4.1.8 "Service" tab
Service options for EDD developers are activated in this dialog box. A "Debug log" is created 
if you activate options.

Recommendation:

Activate the service options for EDD developers only if instructed by the hotline to do so.

Trace mode

Field Explanations/operating instructions
User If this check box is selected, user actions are logged.
Errors If this check box is selected, a log is started when an error occurs. After 

the first error message appears, all further error messages are listed.
Warning If this check box is selected, a log is started when a warning occurs. 

After the first error message or warning appears, all further error mes‐
sages or warnings are listed.
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Field Explanations/operating instructions
Communication If this check box is selected, a log is started. After the first error mes‐

sage or warning appears, all further error messages or warnings are 
listed. In the "Communication" tab, you can specify what types of notes 
are recorded in the communication log.

Detail If this check box is selected, a log is started when SIMATIC PDM starts. 
After the first message appears, all messages, warnings, and errors 
are listed.

EDD Expert mode - Activate messages for analyzing device descriptions
Object Manager Expert mode - Activate specific system messages for analysis

Trace Level

Field Explanations/operating instructions
Details If this check box is selected, a log is started when SIMATIC PDM 

starts. After the first message appears, all messages, warnings, and 
errors are listed.

Warnings If this check box is selected, a log is started when a warning occurs. 
After the first error message or warning appears, all further error mes‐
sages or warnings are listed.

Errors If this check box is selected, a log is started when an error occurs. 
After the first error message appears, all further error messages are 
listed.

Nothing Deactivates expert mode for Trace level

Trace Function Type
The expert options for the errors are activated in this dialog box.
We recommend that you only enable logging when the Hotline instructs you to do so.

Tools for EDD development

Field Explanations/operating instructions
Displaying EDD IDs If this check box is selected, the parameter table shows the variable 

IDs of the EDD.
Open online dialogs offline If this check box is selected and there is no connection with the device, 

no error message pertaining to the connection status will be output; 
the online dialog will open instead. The values displayed are those 
saved in the project or the EDD.

11.4.2 Role management
Opens the "SIMATIC Logon Role Management" dialog box.

SIMATIC Logon Role Management is the SIMATIC Logon component used to create roles 
and assign Windows groups and users as well as operational permissions to the roles.
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Role management is used to regulate access to applications and functions by users and 
groups. 

Access protection forces users to log on to the system if they want to use an application or 
function.

By default in SIMATIC PDM, no roles are administered, which means there is no user assigned 
to a role. In order to manage roles in SIMATIC Logon, the user must be in the Windows group 
"Logon_Administrator".

Function rights and roles
You can create new roles yourself and provide them with function rights. Function rights allow 
access to specific SIMATIC PDM functions. These pre-defined function rights are preset by 
the software and cannot be changed or deleted.

It is not possible to create new function rights.

Function rights in SIMATIC PDM:

● Access to the command interface

● "Parameter View" menu command

● "Device" menu command

● "View" menu command

● "Diagnostics" menu command

● "Service" menu command

● "Write to device" menu command

● "Read from device" menu command

● "Save" menu command

● Online access to the device: Allows communication with the device

Predefined roles
The predefined roles "PDM CI" and "Service user" are created for SIMATIC PDM. The 
predefined roles can neither be changed nor deleted.

Role: PDM CI

The "PDM command interface" role controls access of an application to the PDM command 
interface. The application also reports the administered Windows user.

After a successful password check and check of role membership, the application is allowed 
access to PDM via the command interface.

Role: Service user
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The role "Service user" allows access to the following menu commands and functions:

● "Parameter View" menu command

● "Device" menu command

● "View" menu command

● "Diagnostics" menu command

● "Service" menu command

● "Write to device" menu command

● "Read from device" menu command

● "Save" menu command

● Online access to the device: Allows communication with the device

● Access to a SIMATIC PDM Server

Note
Using a maintenance station

The Windows user using the ASSET must be a member of the "SIMATIC HMI" Windows group.

11.4.3 HART server
Opens the HART server application.

You can use SIMATIC PDM to configure HART devices for the following networks: 

● Multiplexer networks

– Multiplexer network with panel (for example, MTL multiplexer)

– Multiplexer network without panel (for example, P+F multiplexer)

● Wireless HART gateway

– You configure a wireless HART gateway as a HART multiplexer. 

You need a HART server application in the project to integrate and manage these networks. 
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SIMATIC PDM Server option 12
12.1 Setting up the SIMATIC PDM Server

The SIMATIC PDM Server add-on includes:

● A SIMATIC PDM Server provides interactive websites to the user interface of SIMATIC 
PDM.

● The SIMATIC PDM portal is the interactive home page of the SIMATIC PDM Server.

Restrictions
Each session via a browser requires active connections to the SIMATIC PDM Server. 

The maximum number of concurrent connections depends on the following:

● Permissible number of connections from the browser of the computer accessing the 
SIMATIC PDM Server.

● Permissible number of connections of the operating system of the SIMATIC PDM Server. 

Ensure that the permissible number of simultaneous active connections is not exceeded. 

Messages:

● Session limit reached
If the server limit has been reached, you see the message "Session limit reached".

● Connection error
If the client limit has been reached, you see the message "Connection error".

NOTICE

Number of permissible active connections exceeded

The maximum number of concurrent sessions is limited. 
● Exceeding this number results in a short-term blockade of all logged-on users. 
● At the same time, a new user who exceeds this number cannot log on.

NOTICE

Limited functionality

For use of the HART Server functionality, you must be logged onto the SIMATIC PDM Server 
locally.

Help for SIMATIC PDM (V9.1)
Operating Manual, 02/2017, A5E39027365-AA 269



Requirements 
The following requirements must be fulfilled to operate SIMATIC PDM Server add-on:

● Microsoft Internet Information Server (IIS) with ASP.NET support must be enabled
You can find information on this in the next section.

● SIMATIC PDM Server Configurator has been run.
You use the configuration tool to activate the options of the SIMATIC PDM Server on the 
Internet Information Server.
You can find information on the Server Configurator in the section "SIMATIC PDM Server 
Configurator (Page 273)".

● The port is entered in the Windows Firewall, which has been registered and enabled in the 
SIMATIC PDM Server Configurator. You need administrator rights to make this setting.
SIMATIC PDM sets the firewall rule during its installation. 
If you use a different firewall, set these rules there and enable them.

● A maintenance project must be configured in SIMATIC Manager
You can find information on this in the section ""Maintenance Station" tab (Page 262)".

● All Windows users who want to access the SIMATIC PDM Server are authorized for access.
You can find information on this in the section "Role management (Page 265) ".

● SIMATIC PDM Web Server on a Windows Server
If SIMATIC PDM is to be opened from a faceplate, the following conditions must be met:

– The server is added to the list of "Trusted sites".

– Under "Internet options" in the "Advanced" tab of the in Internet Explorer, "Play 
animations in webpages" option must be enabled.

● SIMATIC PDM Web client on a Windows Server

– The server must be registered in the list of "Trusted Sites".

● If you are using a Windows installation with IIS 8.5 or later, you also have to activate the 
Web sockets.

● If computers are to access the SIMATIC PDM Server using a browser, they must be 
registered in the list of PDM clients.
You can find information on this in the section ""PDM clients" tab (Page 263)".

Enabling Microsoft Internet Information Server (IIS) with ASP.NET support

Note
Compatibility with respect to operating system and ASP.NET 

If you are using Windows 10 or Windows Server 2016, additional check boxes are available:
● .NET Extensibility 4.6
● ASP .NET 4.6

The PDM Server does not check to determine whether .NET Extensibility 3.5/4.6 is enabled. 
To use ASP .NET 3.5/4.6, enable .NET Extensibility 3.5/4.6.

SIMATIC PDM Server option
12.1 Setting up the SIMATIC PDM Server

Help for SIMATIC PDM (V9.1)
270 Operating Manual, 02/2017, A5E39027365-AA



To enable the Microsoft Internet Information Server with ASP.NET support, proceed as follows 
(example with Windows 7):

1. Open the Windows Control Panel.

2. Navigate to "Programs and Features" > "Turn Windows features on and off".
The "Windows Features" dialog box opens.

3. Navigate through the tree structure to "Internet Information Services" and select the 
corresponding check box.
If the check box is already selected, you can activate it again.

4. Navigate to "Internet Information Services" > "Management tools".

5. Select the "IIS Management Console" check box.

6. Navigate to "Internet Information Services" > "World Wide Web Services" > "Application 
Development Features".

7. Select the "ASP.NET" check box.

8. Navigate to "Internet Information Services" > "Common HTTP Features".
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9. Select the "Static Content" check box.

10.Close the window with "OK".
The Microsoft Internet Information Server with ASP.NET support is now enabled.
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12.2 SIMATIC PDM Server Configurator
The SIMATIC PDM Server Configurator is an application on the SIMATIC PDM Server. 
You can use the configuration tool to make settings for the communication of the SIMATIC 
PDM Server.

The communication of the SIMATIC PDM Server must be configured once before the initial 
start.

Opening the configuration tool
In the Windows Start menu, select the command Programs > Siemens Automation > SIMATIC 
> SIMATIC PDM > PDM Server Configuration.
The "SIMATIC PDM Server Configuration Tool" dialog window opens.

"SIMATIC PDM - Server configuration tool" dialog window
The following tabs may appear in the "SIMATIC PDM Server Configuration Tool" dialog window 
depending on the installed add-ons:

Installed option Tabs
SIMATIC PDM Server "PDM server" tab
SIMATIC PDM Command Service "Command interface server" tab

"PDM server" tab

Note

All data are sent via an unsecured connection for HTTP access. 

Transmission of data over a secure connection requires the following:
● A trusted server certificate is selected.
● Access is made via HTTPS.

Area Field Description
General informa‐
tion

Website name Name of the website
The default name usually only has to be changed if there is 
a conflict with another server program.

Physical path The files required to display SIMATIC PDM in a browser are 
located in this path.

Connection settings
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Area Field Description
Connection
 

"Certificate" input 
box

Certificate for the HTTPS connection
A certificate is only required if a browser on the SIMATIC 
PDM Server is to have access via secure communication 
(HTTPS connection).
Requirements for the certificate:
● The certificate must be a computer certificate.
● The certificate must have a corresponding private key. It 

must be located within the LocalMachine/Personal of the 
Windows Certificate Store container.

● The certificate has a key encryption for key usage and 
server authentication for extended key usage.

● The certificate has not expired.
You can find information about importing certificates in the 
Microsoft Knowledge Base.

"IP connection (op‐
tional):"
input box

Fixed link to a network adapter or IP address

Ports
 

"Secure connec‐
tion" check box

● If the check box is selected, a secure connection is 
established via HTTPS.

● If the check box is not selected, a connection is 
established via HTTP.

"Port http"
input box

Port via which SIMATIC PDM Server can be reached via the 
unencrypted HTTP protocol
The default port only needs to be changed if there is a conflict 
with another program.

"Port https"
input box

Port via which SIMATIC PDM Server can be reached via the 
encrypted HTTPS protocol
The default port only needs to be changed if there is a conflict 
with another program.

Check box "Auto-start website" If the check box is selected, SIMATIC PDM Server is ready 
for access via a browser.
Clear the check box if you want to deny access to a browser.
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"Command interface server" tab
The certificates are required for encrypting the data.

Area Field Description
Certificate man‐
agement

List List of available certificates
"Import..." button A certificate is required only if you want to encrypt the com‐

munication.
● Open the "Import" dialog window.

Select the path and a certificate file 
(file type: *.pem).

● Click "OK".
The certificate is checked and imported.

The list is then updated.
"Remove" button Deletes a certificate selected in the list 
"Details" button Displays information about the certificate.

Connection settings
Server certificate
 

"Certificate file" 
drop-down list

Displays existing certificate files.
Select the desired certificate file.

"Private key file" 
drop-down list

Displays existing private key files.
Select the desired private key file.

Port settings
 

"Port" input box Port via which SIMATIC PDM Server can be reached.
The default port only needs to be changed if there is a conflict 
with another program.
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12.3 SIMATIC PDM Portal
The SIMATIC PDM portal is the interactive home page of the SIMATIC PDM Server.

After logging on to SIMATIC PDM Portal, you can view all projects and subprojects in the 
browser and change field devices.

IE11/Chrome must be used as browser on the SIMATIC PDM Web client. SIMATIC software 
is not required on the PDM client.

Note

For the secure operation of SIMATIC PDM, it is necessary to take suitable preventive action 
and integrate the PDM client into a holistic industrial security concept. For more information 
about industrial security, please visit http://www.siemens.com/industrialsecurity (http://
www.siemens.com/industrialsecurity).
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12.4 Logging on to the SIMATIC PDM Portal
The SIMATIC PDM portal is the interactive home page of the SIMATIC PDM Server.

After logging on to SIMATIC PDM Portal, you can view all projects and subprojects in the 
browser and change field devices.

Requirement
● For the computers that want to connect to the SIMATIC PDM Server through a browser, 

the following shall apply:

– A unique, static IP address is assigned to the computer.

– The IP address is registered in the settings of the SIMATIC PDM Server.

● The IP address for the router (gateway) is registered in the settings of the SIMATIC PDM 
Server.

● The computers which are accessed using a browser on a SIMATIC PDM Server are 
licensed.

– The number of computers concurrently accessing the SIMATIC PDM Server 
corresponds to a maximum licensed number.
Number of used and available licenses:
You can find information on this in the SIMATIC Manager in the menu Options > 
Settings in ""PDM clients" tab (Page 263)".

● The users are assigned function rights and roles for SIMATIC PDM (see "Role 
management (Page 265)"):

– Service technician

– Plant-specific defined roles
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Opening the SIMATIC PDM Portal
1. Open an browser.

2. Enter the URL of the SIMATIC PDM Server in the "Address" input box and confirm the entry.
The browser connects you to the "SIMATIC PDM Logon" dialog box.

Note
Error messages during logon attempt

If you want to use a browser to access the SIMATIC PDM Server, error pages with 
information about the error may be displayed. 

Typical errors are:
● The licensing is not sufficient.
● The IP address of the computer is not registered on SIMATIC PDM Server (access to 

IP address xyz not allowed).

Note
Checking certificates

SIMATIC PDM automatically checks the validity of certificates when opening the 
applications. Some tests require specific network access e.g. URLs that are located in the 
local network or the Internet. If these network addresses are not reached, there may be 
delays. You can find information on this in http://support.industry.siemens.com/cs/ww/de/
view/87057037.

3. If the display language does not match your operating language, select a different language 
by selecting a national flag.
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4. Specify your domain, user name and password in the text boxes and confirm the entries.

Domain Specify a Windows domain, a logon computer with installed SI‐
MATIC Logon (workgroup mode) or the local computer of the 
user who wants to log on to SIMATIC PDM Portal.
"." is allowed for the local computer.

User name Enter your Windows user name.
Password Enter your Windows password.
"Remember me next time" 
check box

If you select this check box, your logon data is saved for the next 
access.

5. The browser connects you to the SIMATIC PDM Portal and shows the contents of the 
maintenance project. 

See also
"SIMATIC PDM Portal" main window (Page 280)
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12.5 "SIMATIC PDM Portal" main window

The SIMATIC PDM Portal has the following layout
"Project information" area
The "Project information" area shows the project currently 
running in SIMATIC PDM, and a filter area.
The settings in the "Filter" reduce the information displayed 
in the device list.
● If the currently active project in SIMATIC PDM is a 

multiproject, you can limit the information displayed by 
selecting a subproject.

● "Show devices" button: Shows all signal modules, 
interface modules and link modules. 
The DP/PA link is not displayed. 
The display is reset the next time the portal is opened.

● If you enter a character string in the "Tag" input box, the 
information displayed is limited to the rows containing this 
character string. 

● "Magnifying glass" button: Refreshes the device list.
● "X" button: Deletes the settings in the "Filter" are and 

refreshes the device list.

"User information" area
Displays information about the user:
● User: Logged-on user
● Role: Functional role of the user (e.g. administrator; 

service technician, etc.)
● Function rights: The list contains the actions that user can 

perform based on selected check boxes:
– "Parameter view" menu command
– "Device" menu command
– "View" menu command
– "Diagnostics" menu command
– "Service" menu command
– "Write to device" menu command
– "Read from device" menu command
– Online access to device
– "Save" menu command

● "Logoff" button: 
Used for logging off from the SIMATIC PDM Server
Automatic logoff of the session following inactivity is 
possible. You can find information on this in section 
""Maintenance Station" tab (Page 262)".

Device list
Displays a list of devices that is selected by the settings in the "Project information" area.
The list has the following columns:
● Tag: PDM object
● Connection point: Path to AS
● Project: Assignment to multiproject / project / AS
● Last change: Time of change
● Priority: See section ""General" tab (Page 195)"
Status bar
Displays the number of devices that is selected by the settings in the "Project information" area.

SIMATIC PDM Server option
12.5 "SIMATIC PDM Portal" main window

Help for SIMATIC PDM (V9.1)
280 Operating Manual, 02/2017, A5E39027365-AA



12.6 Edit field device in SIMATIC PDM via the browser view

Requirements
● The SIMATIC PDM Portal is open.

● The user has been granted the function rights that are required for the action.
You can find information on this in the section ""SIMATIC PDM Portal" main window 
(Page 280)"; subheading "User information"; "Function rights".

Procedure
1. Select the desired device in the "Tag" column of the device list. 

2. Select the desire command in the shortcut menu.

Menu command Function
Open Opens the browser view of SIMATIC PDM for the desired device.

You can find more information on this in the section "Menus and dialog 
boxes for SIMATIC PDM in the browser view (Page 282)".

Object properties Opens the "Device Selection (Reassign) (Page 248)" dialog box for the 
desired device.

Device Selection (Reas‐
sign)

Opens the "Device selection (Reassign) (Page 233)" dialog box for the 
desired device.

SIMATIC PDM Server option
12.6 Edit field device in SIMATIC PDM via the browser view

Help for SIMATIC PDM (V9.1)
Operating Manual, 02/2017, A5E39027365-AA 281



12.7 Menus and dialog boxes for SIMATIC PDM in the browser view

12.7.1 "File" menu
You can find the following commands in the "File" menu in the browser view of SIMATIC PDM:

● Save (Page 175)

● Exporting (Page 230)

● Importing (Page 231)

● Print (Page 183)

● Exit (Page 183)

12.7.2 "Device" menu
You can find the following commands in the "Device" menu in the browser view of SIMATIC 
PDM:

● Download to device (Page 186)

● Upload to PG/PC (Page 188)

● Assign address and TAG (Page 190)

● Device Selection (Reassign) (Page 248)

● Calibration log ... (Page 199)

● Change log ... (Page 235)

● Check configuration

● Templates

12.7.3 "View" menu
You can find the following commands in the "View" menu in the browser view of SIMATIC PDM:

● Process variables (Page 215)

● Start LifeList (Page 233)
Export of the LifeList data is not available in the browser view of SIMATIC PDM.

12.7.4 "Diagnostics" menu
You can find the following commands in the "Diagnostics" menu in the browser view of 
SIMATIC PDM:

● Update diagnostics (Page 219)
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12.7.5 "Help" menu
You can find the following commands in the "Help" menu in the browser view of SIMATIC PDM:

● Contents... (Page 222)

● Help for device parameters... (Page 222)

● Info... (Page 222)

● Find (Page 222)

● Document Manager (Page 222)

SIMATIC PDM Server option
12.7 Menus and dialog boxes for SIMATIC PDM in the browser view

Help for SIMATIC PDM (V9.1)
Operating Manual, 02/2017, A5E39027365-AA 283



SIMATIC PDM Server option
12.7 Menus and dialog boxes for SIMATIC PDM in the browser view

Help for SIMATIC PDM (V9.1)
284 Operating Manual, 02/2017, A5E39027365-AA



Notes, Tips & Tricks 13
13.1 Information on configuration and parameter assignment

This section contains notes that provide additional information in particular cases. You should 
also read the information in the file pdmbase-readme. This file is usually available in the folder ...
\Siemens\SIMATIC_PDM.

Bus parameters
For information on specific settings for the bus parameters made in the Set PG/PC Interface 
program, you need to read the pdmbase-readme file. 

PROFIBUS PA profile devices

Using profile parameter assignment (profile EDD)
The following procedure applies to profile devices for which there is no EDD in the device 
description catalog and for which you want to use your own device-specific GSD file (device 
master file):

1. Import the device-specific GSD file required for the master configuration. 
Following the import, you can find the device-specific GSD file for the field device in the 
hardware catalog under .. \ Additional field devices.

2. Place the field device in the DP/PA master system.

3. Assign a suitable profile device description (EDD) to the field device. 
You can find information on this in the section "Device selection (Reassign) (Page 233)".

Using profile communication (profile GSD)
The following procedure applies to profile devices for which a profile GSD file and a custom 
device-specific device description (EDD) are to be used for parameter assignment:

1. Place the profile GSD file required for the master configuration in the DP/PA master system.

2. Assign a suitable device description to the field device. 
You can find information on this in the section "Device selection (Reassign) (Page 233)".

Block configuration of HART devices
HART devices are configured using general parameters and parameters that are assigned to 
blocks. For example, some pressure transmitters can measure the temperature as well. For 
such a device, you set the number of blocks and the number of inputs/outputs to two each. 
SIMATIC PDM supports devices having up to six blocks. The number of inputs/outputs is 
limited to a maximum of four by the HART definition. The online dialog of the Block 
assignment can be used to assign I/O to the blocks. This online dialog box is only supported 
by devices that allow inputs/outputs to be assigned to blocks. 
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Basic configuration of HART devices
The basic configuration of HART devices (in the "SIMATIC PDM Device Selection" dialog box 
under HART > Universal > Standard) includes the range of functions that are defined by HFC 
in the Universal Commands and the Common Practice Commands. 

Setting the time format in a system
Ensure you set the same time format (12 hour format / 24 hour format) for all programs and 
devices.
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13.2 Connecting field devices by means of Industrial Ethernet

Difference between routing and data record routing
"Routing" refers to the transmission of data beyond network boundaries. A transmitter sends 
information across network boundaries to a receiver. Particular equipment engineering is 
required for this function to work. 

Data record routing is a routing function which is used exclusively by SIMATIC PDM . Only 
S7-400  CPU modules with a firmware version of V5.1 or higher meet the requirements. 
Appropriate interfaces could be internal CPU interfaces, communication processors (e.g., CP 
443-5 EXT) or external equipment (e.g., IE/PB-Link). You can find information on the suitability 
of modules in the associated operating instructions.

Data sent by means of data record routing can include the following:

● Parameter assignments of the communication devices concerned

● Device-specific information (e.g., setpoints, limits, or similar)

With data record routing, the structure of the destination address depends on the contents of 
the data, i.e., on the device for which the data is intended. The field devices themselves do 
not have to support data record routing, since these devices do not forward the information 
they receive. 

IE/PB-Link in connection with S7 stations   
You need an IE/PB-Link to go establish a connection via Ethernet to a DP device at an S7-300  
or at the internal DP interface of S7‑400 up to firmware V5.1 . The link provides the data record 
gateway for the plant. An IE/PB-Link must be created for each DP line in the project.

To commission the IE/PB-Link , you must assign an IP address to the link. To do this, you 
connect the IE/PB-Link with the Engineering Station via Ethernet. 

● The IE/PB-Link PN IO is supplied with a fixed MAC address. If not configured, the IE/PB-
Link PN IO is accessible via this MAC address (requires Ethernet port).

● An IP address is automatically assigned during the configuration process. This IP address 
is later transferred to the IE/PB-Link PN IO (IO device) when the PROFINET IO controller 
starts up.

● You assign a device name to the IE/PB-Link PN IO  so that the IO controller is able to 
identify the IO device during this process. In the SIMATIC Manager or in HW Config, select 
the menu command Target system > Edit Ethernet nodes... . 
(You can find detailed information on the procedure in the online help for STEP 7.)

Requirement
For the SIMATIC project, an IE/PB-Link is created in a SIMATIC 300 station. 
(Hardware catalog under "SIMATIC 300 > Gateway > IE/PB Link PN IO)
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Procedure
1. In SIMATIC Manager, select the menu command PLC > Edit Ethernet Node....

The "Edit Ethernet Node" dialog box opens.

2. Enter the MAC address of the IE/PB-Link in the "Ethernet node" section or click the 
"Browse..." button to search for and select the IE/PB-Link.

3. Assign the corresponding IP parameters to the IE/PB-Link.

4. Open HW Config.

5. Parameterize the Ethernet connection and the DP interface with the values that apply to 
the project.

6. On the "Operating Mode" tab, select the "No DP" check box. The IE/PB-Link now operates 
like a PG/PC.

7. Once you have configured and programmed all stations, start NetPro and select the 
Network > Save and Compile menu command in order to generate all routing tables.

8. To communicate via Ethernet, you select the TCP/IP protocol in the programming device/
PC interface settings for the CP 1613 or other network card that will be used for 
communication.

9. Create another programming device/PC parallel to the stations in the component view, and 
configure an Ethernet interface in this programming device/PC.

10.Assign this interface to the interface configured under the programming device/PC interface.

Now when you open the hardware configuration for a SIMATIC 300 station, communication to 
the devices will also function via Ethernet.

IE/PB-Link in connection with third-party systems
In order to be able to use systems made by third-party manufacturers, you will have to configure 
a SIMATIC 300 or SIMATIC 400 station as a "dummy" station. For this purpose, a simple 
configuration consisting of a rack, PS, CPU and DP interface will be sufficient. The devices 
will then be distributed on the DP lines of this station just as they are connected to the third-
party masters. 

Select the DP settings on the third-party master so that the token routing is performed through 
two masters (the third-party master and the IE/PB-Link). 

Like in an S7 plant, one IE/PB-Link per DP line is also required here.

The same settings as for STEP 7 stations apply for establishing communication. You need a 
programming device/PC with an Ethernet interface. 
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13.3 HART applications

System environment
Implementation of intelligent field devices with HART functionality requires the following system 
environment (see the figure below):

● Current loop 4 - 20 mA

● HART configuration tool:
The HART parameters can be set using an external handheld panel (HART Handheld) or 
a HART configuration tool (SIMATIC PDM). The configuration tool deploys the HART 
analog module, whereas the HART Handheld is connected directly in parallel to the field 
device.

● HART system integration:
The HART analog module assumes a "master" function by receiving the commands from 
the HART configuration tool. It then transfers these commands to the intelligent field device 
and returns corresponding response frames. The interface of the HART analog module is 
formed by data records which are transferred via the I/O bus. The HART configuration tool 
must generate and interpret the data records.

● IM153-2 head-end station for the HART configuration tool:
Head-end station for PROFIBUS DP, which supports master class 1 and master class 2 
functionality.

Figure 13-1 System environment: Use of HART
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Appendix A
A.1 Communication Problems

If communication problems occur, you should check for the following:

Connecting
● Configuration

– Is the programming device or PC interface configured correctly? The SIMATIC Manager 
menu command Options > Set PG/PC Interface or the Windows Control Panel can be 
used to set the PG/PC interface parameters.

– If you are not performing configuration in HW Config: Is the correct interface assigned 
to the PC? Is this interface assigned to the correct network? Check the assignment by 
selecting the interface and the required network with the menu command Edit > Object 
Properties in the "Communication" tab.

– In case of routing: Is a programming device/PC included in the project in the component 
view? Is the correct interface assigned to the programming device/PC?

– Are the addresses (address, slot, channel) assigned correctly and uniquely in the 
project?

● Hardware structure

– Is the system complete and has it been cabled correctly? Are all the connectors plugged 
in correctly? Are the modules inserted correctly?

– Are all the modules and devices of the plant supplied correctly?

– Are there low-or high-frequency interference in the system? Is the system subject to the 
influence of electromagnetic fields?

– Is there a short circuit on the bus or a wire break in a wire leading to the device?

● Addressing the devices

– Are the addresses (address, slot, channel) set correctly for the devices in the system?

– Do the addresses set on the devices agree with the configured addresses?
The address settings are made on the devices via parameter assignments, hardware 
switches, or a combination of both. 
The device address can be set by means of SIMATIC PDM for some field devices 
(PROFIBUS DP/PA and FF). You can find additional information on this in the section 
"Delivery contents (Page 29)".
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● Consistent project engineering and configuration in the CPU and CP

– The project engineering settings loaded to the CPU or to a CP must match the 
configuration. The routing tables for the project/multiproject must have been created 
and all components loaded in the network configuration (NetPro). 
To load the configuration to the CPU or to a CP, select the HW Config menu command 
Target system > Download to module > Target module.

● Maximum number of connections

– Devices or communication components can only manage a restricted number of open 
connections. It is therefore possible that connections cannot be established. To open 
new connections to devices, close S7 applications. For information on the maximum 
number of connections permitted, refer to the respective device manuals.

– At least two connections must be supported simultaneously for remote I/Os to enable 
communication with the connected HART devices.

Communication Errors
Communication errors can occur when using standard device descriptions, for example, HART 
Universal Standard descriptions. 

● The reason for this may be an unsuitable device assignment. If this is the case, assign a 
suitable device in the network or plant view. 
You can find additional information on this in the following sections:

– Section "Delivery contents (Page 29)"

– Section "Replacing devices (Page 121)"

● Another reason may be that the device does not fulfill or fully implement the standard. 
Contact the device manufacturer in this case.

Broken Connection
● Reset functions

– Was a reset function triggered in the device? A reset can be triggered manually or by 
the firmware of the device (for example, in case of hardware errors or incorrect program 
execution). The reset can block the device in a defined "safe" operating state or trigger 
a restart of the program with initial settings. These initial settings can differ from the 
desired settings, for example, different address or transmission rate.

● Disturbances

– Do low-or high-frequency interference occur in the system or is the plant subject to the 
influence of electromagnetic fields? Has the power supply of the system, of parts of the 
system or of devices been disconnected? Have connectors been withdrawn or plugged 
in elsewhere?

Note

If any other communication problems occur, contact the device manufacturer. 

Appendix
A.1 Communication Problems
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A.2 Message window

A.2.1 "Decision on error" dialog box
You can obtain the specific information you need from the dialog box; if necessary, contact 
the hotline.

A.2.2 "Error history" dialog box
You can obtain the specific information you need from the dialog box; if necessary, contact 
the hotline.

A.2.3 "Error" dialog box
You can obtain the specific information you need from the dialog box; if necessary, contact 
the hotline.

A.2.4 "Multiple errors" dialog box
You can obtain the specific information you need from the dialog box; if necessary, contact 
the hotline.

A.2.5 "Messages" Dialog Box

Purpose  
Messages about the following points are displayed in this dialog box.

● Communication problems  

● Export/import 

● DIM 

● Device descriptions

You can obtain the specific information you need from the dialog box; if necessary, contact 
the hotline.
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