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Thank you for purchasing the SLP-P30
for DCP31/32 DIGITRONIK Digital
Program Controller.

This manual contains information for
ensuring correct use of the SLP-P30. It
also provides necessary information for
installation, maintenance, and trou-
bleshooting.

This manual should be read by those
who design and maintain devices that
use the SLP-P30.

Be sure to keep this manual nearby for
handy reference.



The DIGITRONIK
TM

is a trademark of Azbil Corporation in Japan.

NOTICE

© 2004-2013 Azbil Corporation All Rights Reserved.

Be sure that the user receives this manual before the product is used.

Copying or duplicating this user’s manual in part or in whole is forbid-
den. The information and specifications in this manual are subject to
change without notice.

Considerable effort has been made to ensure that this manual is free
from inaccuracies and omissions. If you should find an error or omis-
sion, please contact the azbil Group.

In no event is Azbil Corporation liable to anyone for any indirect, special
or consequential damages as a result of using this product.

Do not apply strong force while connecting a loader plug. Doing so might
damage the instrument.

Handling Precautions
Application of excessive force to the loader plug might cause
communication failure. If such failure happens, reconnect the loader
plug correctly.

IMPORTANT



Unpacking
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Check the following items when removing the SLP-P30 from its package:

1. Check the model No. to make sure that you have received the product which you ordered.

2. Check the SLP-P30 for any apparent physical damage.

3. Check the contents of the package against the Package List to make sure that all accessories are included

in the package.

After unpacking, handle the SLP-P30 and its accessories with care to prevent damage or loss of parts.

If an inconsistency is found or the package contents are not in order contact your dealer, immediately.

Name Model No. Q'ty Remarks

System disk SLP-P30J50 1 CD-ROM

Dedicated cable - 1 -

User's Manual CP-UM-1759JE 1 This manual. This manual is
written in both Japanese and
English.



The Role of This Manual
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The 4 manuals described below are available for the DCP31/32. Read them as necessary for your specific

requirements.

If a manual you require is not available, contact the azbil Group or your dealer.

SLP-P30 Smart Loader Package for DCP31/32 User's Manual
Manual No. CP-UM-1759JE

This manual. This manual is written in both Japanese and English.

This manual is supplied with the Smart Loader Package SLP-P30. The
manual describes the software used to make various settings for the
DCP31/32 using a personal computer.

Personnel in charge of design or configuration of a system using the
DCP31/32 must thoroughly read this manual.

The manual describes software installation, operation of the personal
computer, various functions, and setup procedures.

DCP31/32 DIGITRONIK CPL Communication User's Manual

Manual No. CP-SP-1066E

This manual is required reading for those using the CPL communications
functions of the DCP31/32.

This manual outlines CPL communications, wiring, communications
procedures and DCP31/32 communications data, troubleshooting, and
communications specifications.

DCP31 DIGITRONIK Digital Program Controller User's Manual

Manual No. CP-UM-1757E

This manual is provided with the DCP31 (single-loop model). It is required
reading for those in charge of designing, producing and maintaining control
systems incorporating the DCP31, and for those using the DCP31 in other
applications.

It describes mounting onto control panels, wiring, parameter setup,
program setup, operation methods, maintenance and inspection,
troubleshooting and specifications.

DCP32 DIGITRONIK Digital Program Controller User's Manual

Manual No. CP-SP-1042E

This manual is provided with the DCP32 (double-loop model). It is required
reading for those in charge of designing, producing and maintaining control
systems incorporating the DCP32, and for those using the DCP32 in other
applications.

It describes mounting onto control panels, wiring, parameter setup,
program setup, operation methods, maintenance and inspection,
troubleshooting and specifications.



Organization of This User's Manual
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This manual is organized as follows:

Chapter 1. INTRODUCTION
Be sure to read this chapter before you start using the Smart Loader Package. The chapter describes
the required operating environment for the personal computer and briefly introduces the features of
the Smart Loader Package.

Chapter 2. INSTALLATION AND BASIC OPERATION
This chapter describes how to install, start and quit the SLP-P30, and summarizes its functions,
screen configurations and basic operations.

Chapter 3. METHODS OF OPERATION
This chapter describes setup operations for environment, file operations, communications with the
DCP31/32 and data.

Chapter 4. TROUBLESHOOTING
This chapter describes error messages and remedies for problems that may occur.

Conventions Used in This Manual

The following conventions are used in this manual:

Handling Precautions:
Handling Precautions indicate items that the user should pay attention to when
handling the SLP-P30.

Note: Notes indicate useful information that the user might benefit by knowing.

: This indicates the item or page that the user is requested to refer to.

(1), (2), (3): The numbers within the parentheses indicate steps in a sequence or indicate
corresponding parts in an explanation.

[OK] button: Indicates a selection button on a personal computer screen.

[File]: Indicates messages and menus displayed on the personal computer.

[File] → [New]:
Indicates a sequence of selections on a personal computer. Select [File] first
and then select [New].

>>: Indicates the result of an operation, details displayed on the personal computer
or other devices, or the state of a device after an operation.

[Ctrl] key: Indicates keys on the keyboard.
[x] key

[Ctrl]+[x] keys: Indicates the operation of pressing the [x] key with the [Ctrl] key on the keyboard
held down.
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Chapter 1. INTRODUCTION
1  -  1 Overview

The SLP-P30 (simply called “SLP” from here on) is an engineering tool for the DIGITRONIK Digital Program

Controller DCP31/32 (simply called “DCP” from here on).

The SLP runs on Windows XP Home Edition/XP Professional/Vista (32 bit type)/7 (32 bit type, 64 bit type)

(simply called “Windows” from here on) on a personal computer.

The SLP has the following functions:

(1) Program pattern editing and parameter editing

(2) Data communication (program patterns, writing/reading of parameters)

(3) File management (program patterns, writing/reading of parameters)

E1



1  -  2 System Operating Environment

The following system environment is required for using the loader:

■ Hardware

Handling Precautions
• Before starting up SLP-P30, quit all other applications.

If you start up SLP-P30 while another application is running, SLP-P30
may malfunction.

• This loader is so designed that it runs on almost all the PC/AT
compatibles.

• The communication time-out may occur if the loader is connected
through the RS-232C communication for an extended period of time
while Windows’ power management is running.
In this case, turn OFF the power management (power management
setting of Control Panel).

■ Hardware configuration

■ Personal computer used for confirmation of operating environment

SLP-P30

Reading/Saving
Data disk

Communications
Special Cable (Accessory)

DCP31/32

Chapter 1. INTRODUCTION

Item Description

Target model PC/AT compatibles with a Pentium chip or higher

Memory 32 MB or more

Operating system Windows XP Home Edition/XP Professional/Vista (32 bit type)/
7 (32 bit type, 64 bit type)

Display 800 x 600 pixels or more, 16-bit color or more

USB port 1 port or more

Hard disk drive Hard disk with at least 40 MB of free space

CD-ROM drive 1 drive or more.

Pointing device Windows-compatible mouse or equivalent device

E2

Manufacturer Model No.

Dell OptiPlex G1

Personal
Computer

Peripheral
Devices



Chapter 2. INSTALLATION AND BASIC FUNCTION
2  -  1 Installation, Starting and Quitting the Software Package

■ Installation
Install the SLP on the hard disk of a personal computer.

Keep the system disk that you purchased as a backup.

This section describes how to install the SLP on a personal computer.

Handling Precautions
• This disk does not contain the PC operating system, and you cannot use

it without an operating system.

• The installation program may malfunction if you start it while another
application is running. Close other applications before starting up the
installation program. The SLP sometimes cannot be started depending
on the combination of other applications and drivers.

For details on Windows and personal computer settings, refer to their
user’s manuals.

● Installing the SLP
(1) Put the CD in the CD-ROM drive of your personal computer.

>> The following screen appears for installing the driver for the USB loader

cable and selecting a SLP model.

(2) Click the [Install SLP] button.

>> The following screen appears:

E3
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(3) Click the [Next >] button.

>>The following screen appears:

(4) If you agree to the software license agreement and wish to install the loader,

click the [Next >] button. If you want to abort the installation, click the

[Cancel] button.

>>After clicking the [Next >] button, the following screen appears:

Note
•  To change the installation destination directory, click the [Browse...]

button.
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(5) Click the [Next >] button.

>>The following screen appears:

Note
•  To change the group, enter the new group name.

(6) Click the [Next >] button.

>>The following screen appears:

Chapter 2. INSTALLATION AND BASIC OPERATION
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(7) Click the [Next >] button.

>>The following screen appears:

(8) Click the [Finish >] button.

>>When the installation is completed successfully, the display will return to

the Windows desktop.

Chapter 2. INSTALLATION AND BASIC OPERATION
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■ Installing the device driver

A device driver must be installed before using the USB loader cable.

Follow the procedure below to install the device driver.

Handling Precautions
• Be sure to follow the procedure below when installing the device driver.

The USB cable may not be recognized if the procedure is not followed. If
the cable is not recognized, uninstall the driver and then install it again.

• Administrator privileges on the computer are required for driver installa-
tion. Installation should be done by the administrator or by a user who
belongs to the administrator group. The USB loader cable is supported
on Windows XP/Vista (32 bit type)/7 (32 bit type, 64 bit type). It is not
supported on Windows XP(64 bit type), or on Windows 2000, Windows
95, Windows NT, MS-DOS or PC-DOS.

• If there are multiple USB ports, connect the USB loader cable to the
same port every time. If it is connected to a different port, there is a
chance that driver installation may be required again.

1. Put the SLP CD-ROM into the CD-ROM drive of the personal computer.
>>The installation program is then started up automatically and the following

screen appears:

(1) Click the [Install USB loader cable driver] button.

>> The following screen appears:

(2) Click the [Next >] button.

>> The following screen appears:
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(3) Select [AGREE] and click the [Next>] button.

>>The following screen appears :

(4) Click the [Continue Anyway] button.

>>The installation program then starts up, and after it is completed, the follow-

ing screen appears:
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(5) Click [Finish] button to complete the installation.

2. Insert the USB loader cable into the USB port.
>>When Windows recognizes the USB cable, the notification shown below

appears on the task tray and the driver installation wizard appears.

3. Install the device driver.
(1) Usually, when Windows recognizes the USB loader cable, the window shown

below appears. (In some cases, depending on the Windows environment, it

may not appear.) Select [No, not this time] and click the [Next >] button.
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(2) For the retrieval location of the device driver to be installed, select the [Install
the software automatically (Recommended)] and click the [Next >] button.

>>Retrieval of the device driver starts.

>>When the device driver is found, the following window appears:

(3) Click [Continue Anyway].
>>Installation of the device driver starts
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>>When the device driver installation is complete, the following window appears:

(4) Click [Finish].
>>When the installation is complete, the notification shown below appears on

the task tray, and Windows now correctly recognizes the USB loader cable.
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(5) Select [Control Panel] → [System] → [Hardware] → [Device Manager]
(for Windows XP), [Control Panel] → [Device Manager] (for Windows

Vista/7), and find the port number for the Yamatake USB Loader Comm. from 

[Ports (COM & LPT)].

(6) Start the SLP, select [Menu] → [Option], and set to the communications port

number obtained in the previous step. Then press the [OK] button to complete

the configuration.

Note
• If the CD-ROM for the SLP is not available, execute [drvsetup.exe] (32 bit type)

or [drvsetup64.exe] (64 bit type) on the computer on which the SLP is installed.

Then install the device driver.

Normally [C:\Program Files\slp\SLPP30] (32 bit type), or 

[C:\Program Files(x86)\slp\SLPP30] (64 bit type).

■ Uninstalling the device driver

Handling Precautions
• Removing the driver requires restarting the computer. Close other

applications first, and then uninstall the driver.

• To uninstall the driver, administrator rights are required on the computer.
Uninstalling should be done by the administrator or by a user who
belongs to the administrator group.

1. Execute the driver removal program.
(1) Go to [Control Panel] → [Add or Remove Programs] and click on

[Windows Driver Package - Yamatake (YC slp) USB (04/10/2008
2.0.2.8)]. Click the [Change/Remove] button. 

(2) Click the [Yes] button.

(3) Restart the computer.
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■ Starting the SLP

Handling Precautions
• Before starting the SLP, quit all other applications. If you start the loader

while another application is running, the SLP may not function. Also, set
any power saver function, infrared communications and screen
saver to OFF.

• Make sure that the Decimal Symbol setting is “ . ” for [Control Panel] Æ
[Regional Settings] → [Number] command. If it has been set to some
other character, the loader cannot correctly function.

(1) Click the [Start] button at the lower portion of the screen and select

[Programs] → [SLP] → [SLP-P30(DCP31,32)] command.

>>The SLP starts and the menu window is displayed, along with handling

precautions.

(2) Click the [Next >] button.

>>The model setting method screen appears:
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(3) Select either method on the model setting method screen and click the [Next>]
button.

>>If [0: Set model number] is selected, the basic model screen basic model

No. will appear.

If [1: Read from DCP30] is selected, the communication range selection

screen Select will appear.

For more details, refer to the sections listed below.

When the basic model screen is displayed:

3-1 Type Setup and Environment Setup (see page E18).
When the communication range selection screen is displayed:

3-3 Communications with the DCP (see page E23).

Note
•  For details on the operating system or the mouse you are using, refer to the

user's manual provided with Windows or with your personal computer.

■ Quitting the SLP
(1) Click the icon at the top right of the screen. You can also quit by selecting

[Menu] → [Quit] command.

>>The following screen appears:

(2) Click the [OK] button.



2  -  2 Description of Functions
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■ SLP functions
The SLP provides the following functions for configuring DCP operation:

• Program pattern editing

• Parameter editing

• File management

• Data communications

• Model setting

The figure below shows what these functions do.

Note
• “File” refers to data for one DCP. Each file comprises the various parameter

settings and the model number information.

Functions

Program pattern editing • Creates and edits program patterns.

• Creates and edits parameters.
Parameter editing

• Saves created data to a file on a floppy disk
  or hard disk.
• Reads saved files for re-editing.

File management

Data communications
• Writes created data to the DCP.
• Reads from the DCP to the SLP.

Model setting
• Sets the model No. of the DCP to be 
  connected with the SLP.
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2  -  3 Screen Configuration

■ SLP screen configuration
• Basic SLP screen

• Dialog box displayed when [Help] → [Version(A)] command is selected.

Setup items

Menu bar

Toolbar

Selection
window

Message window

Program pattern No.
Tag
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2  -  4 Menu Configuration List

Menu Icon Sub Menu 1 Sub Menu 2 Description Shortcut Keys

File New - Creates new data. [Ctrl]+[n]

Open - Opens existing data. [Ctrl]+[o]

Save - Saves the active data. [Ctrl]+[s]

Save As - Saves the active data with a new [Ctrl]+[a]
name.

- CSV Out (X) - Saves the active data in CSV -
format.

- HTML Out (H) - Saves the active data in HTML -
format.

- Quit - Quits the application. [Ctrl]+[q]
Edit - Data Check - Checks all values. -

Insert Segment New Segment Inserts a new segment. -

- Segment Copy Inserts the copied segment data. -

Cut Segment (T) - Copies the selected segment data [Ctrl]+[x]
and deletes it.

Copy Segment - Copies the selected segment data. [Ctrl]+[c]

Paste Segment - Overwrites (pastes) the copied segment [Ctrl]+[v]
data onto the selected segment.

Clear (A) - Initializes the selected data. -

Copy Pattern (Y) - Copies the selected pattern data. -

Paste Pattern (S) - Overwrites (pastes) the copied pattern -
data onto the selected pattern.

Communication Read (DCP30→SLP) - Reads the device data. [Ctrl]+[r]

Write (SLP→DCP30) - Writes the data to the device. [Ctrl]+[w]

Setup - Program setup (A) Program Displays the program setup. [Ctrl]+[Shift]+[a]
- Parameter setup (B) Variable parameter Displays the variable parameter. [Ctrl]+[Shift]+[b]

Variable parameter2 Displays the variable parameter 2. [Ctrl]+[Shift]+[c]
Event configuration data Displays the event configuration data. [Ctrl]+[Shift]+[d]
PID parameter Displays the PID parameter. [Ctrl]+[Shift]+[e]
PID parameter2 Displays PID parameter 2. [Ctrl]+[Shift]+[f]
Setup data Displays the setup data. [Ctrl]+[Shift]+[g]
Table data Displays the table data. [Ctrl]+[Shift]+[h]
Constant-value Displays the constant-value [Ctrl]+[Shift]+[ i ]
operation data operation data.

Option Type setup - Changes the type setup. [Ctrl]+[t]

Environment setup - Changes the environment setup. [Ctrl]+[e]

View - Pattern Graph - Displays the pattern graph. -
- Table Graph - Displays the table graph. -

Help - Version (A) - Displays the version information. -
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3  -  1 Type Setup and Environment Setup

■ Type setup
First, set the SLP type appropriate for the DCP model.

(1) Click the icon. This has the same result as selecting [Option] →
[Type setup] command, or pressing [Ctrl] + [t] keys.

>>The type setup dialog box appears.

(2) Select the DCP and click the [Next >] button.

>>The output type dialog box appears.
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(3) Select the output type and click the [Next >] button.

>>The option 1 dialog box appears.

(4) Select option 1 and click the [Next >] button.

>>The option 2 dialog box appears.

(5) Select option 2 and click the [ Complete] button.

Handling Precautions
•  The type setting here is for the internal use of the loader.

Be sure to set the correct DCP type.



■ Environment setup
Set the communications port and font on the personal computer.

(1) Click the icon.

Alternatively, select [Option] → [Environment setup] command, or press the

[Ctrl] + [e] keys.

>>The environment setup dialog box appears.

(2) Select the communications port.

(3) Select the font size.

(4) Click the [ OK] button.

Handling Precautions
• Normally, use “Port COM1.”

Even if another communications port can be selected, it sometimes
cannot be used, depending on its configuration.
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3  -  2 File Operations
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■ Making new files
(1) Click the icon, select the [File] → [New] command, or press the 

[Ctrl] + [n] keys.

>>The New dialog box appears.

(2) Click [OK] button.

>>A new file opens.

■ Opening existing files
(1) Click the icon, select the [File] → [Open] command, or press the 

[Ctrl] + [o] keys.

>>The open dialog box appears.

(2) Select the folder (directory) from the [Look in:] drop-down menu.

(3) Click (select) the file name.

(4) Click the [Open] button.

>>The file you selected opens.

■ Overwriting and saving files
(1) Click the icon, select the [File] → [Save] command, or press the 

[Ctrl] + [s] keys.

>>The file is overwritten and saved.
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■ Saving files with a new name
(1) Click the icon, select the [File] → [Save As] command, or press the

[Ctrl]+[a] keys.

>>The Save As dialog box appears.

(2) Select the folder name under the [Save in:].

(3) Enter the file name in the [File name] input box.

(4) Click the [Save] button.

>>The file is saved under the file name that you entered.

Note
•  The file is overwritten and saved if you click on (select) a file name in the

File name window.

■ Outputting CSV format files
(1) Select the [File] → [CSV Out(X)] command.

>>The CSV output dialog box appears.

(2) Select the folder name under [Save in:].

(3) Enter the file name at [File name].

(4) Click the [Save] button.

>>The file is output under the file name that you entered.

Note
•  The file is overwritten and saved if you click on (select) a file name in the

File name window.

A CSV file is a text file delimited by commas, and can be used in Microsoft

Excel or other off-the-shelf spreadsheet applications.

•  When opening a CSV file using Microsoft Excel, the display format for

numerical values, time and the line, is converted into the standard Microsoft

Excel format.

■ Outputting HTML format files
(1) Select the [File] → [HTML Out(H)] command.

>>The HTML output dialog box appears.

(2) Select the folder name under [Save in:].

(3) Enter the file name at [File name].

(4) Click the [Save] button.

>>The file is output under the file name that you entered.

Note
•  The file is overwritten and saved if you click on (select) a file name in the

File name window.

•  An HTML file can be used with browsers like Microsoft Internet Explorer,

like and word processors Microsoft Word.



3  -  3 Communications with the DCP

■ Communication from the DCP to the SLP (reading from the DCP)
(1) Click the icon, select the [Communication] → [Read (DCP30→SLP)]

command, or press the [Ctrl]+[r] keys.

>>The communication dialog box appears.

(2) Check the contents of the communication and click the [ OK] button.

>>The confirm dialog box appears.

(3) Click the [ OK] button.

>>Reading from the DCP starts.

■ Communication from the SLP to the DCP (writing to the DCP)
(1) Click the icon, select the [Communication] → [Write (SLP→DCP30)]

command, or press the [Ctrl]+[w] keys.

>>The communication dialog box appears.

(2) Check the contents of the communication and click the [ OK] button.

>>The confirm dialog box appears.

(3) Click the [ OK] button.

>>Writing to the DCP starts.

Handling Precautions
• If data settings are incorrect, an error list appears and the

communication does not start.

• If the main unit model does not match the settings in the loader, an error
message appears, showing that the settings are for the wrong model.
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3  -  4 Setting up Data

■ Selecting setup items

● Moving the highlighted section of the display with the keyboard
(1) Press the [↑], [↓], [←] or [→] key to move the highlighted section of the

screen.

● Moving the highlighted section of the display with the mouse
(1) Click the section you want to move.

(2) Click the scroll bar to scroll the screen.

>>The screen cannot be scrolled beyond the topmost or bottommost rows on

screen.

● Changing the active window
(1) Press the [Tab] key.

>>The screen moves to the next operation window.

Note
•  Setup items are moved to according to their order on the screen.

■ Entering numerical data

● Entering numerical values
The following describes how numerical values are entered:

• To enter a numerical value, press the [0] to [9] keys on the keyboard.

• To enter a hexadecimal number, press the [0] to [9] keys or the [A] to [F] keys on

the keyboard.

• To enter a decimal point, press the [.] key at the desired decimal point position.

• To enter a minus value, press the [-] key.

• To enter time data, press the [0] to [9] keys, [:] key, and [.] key on the keyboard.

Note
• To enter “2:00”, press the [2], [:], [0], and [0] keys or press the [1], [2], and

[0] keys.

• When entering time in h:min or min:s format, you cannot use the [.] key.

Likewise, when entering time in the 0.1s format, you cannot use the [:]
key.

• To correct a wrong entry, press the [Back Space] key.

>>The current displayed value is deleted.

• To cancel the currently entered numerical value, press the [Esc] key.

>>The original value is redisplayed.
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● Entering values for setup items
Use the [0] to [9] keys on the keyboard to enter values.

(1) Select the setup item to highlight it.

(2) Enter the desired value with the [0] to [9] keys.

(3) Press the [Enter] key. Pressing the [↑] or [↓] key gives the same result.

>>The value is set.

Note
• If you set the numerical value by pressing the [↑] or [↓] key, the highlighted

section moves on the screen. If you move a setup item using the mouse, the

value is not set.

• If an entered value is invalid, the original value is redisplayed. To cancel a

value midway during entry, press the [Esc] key.

● Selecting and entering data

Note
• Items that can be selected and entered are automatically displayed.

(1) Select a setup item from the drop-down menu, or press the [Tab] or [Alt]+[↓]
keys.

>>Selection Item is displayed.

(2) Click on a setup item with the mouse, or press the [↑], [↓], [←] or [→] keys, or

press the [Enter] key.

>>The value is set.

Note
• When you use the mouse, the value is set at the same time that you select it

with the mouse.

Setup item Setup item menu
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■ Editing segments
Before using any segment editing function, it is necessary to move the highlighted

section onto a target segment.

● Inserting a new segment
(1) Click the icon, or select the [Edit] → [Insert Segment] → [New

Segment] command.

>>The confirm dialog box appears.

(2) Click the [OK] button.

>>A new segment is inserted.

● Inserting a copied or cut segment
(1) Click the icon, or select the [Edit] → [Insert Segment] →

[Segment Copy] command.

>>The confirm dialog box appears.

(2) Click the [OK] button.

>>The copied or cut segment is inserted.

Handling Precautions
• Before inserting a copied or cut segment, it is necessary to copy or

cut the segment.  The same copied or cut segment may be inserted
any number of times.

● Cutting a segment
(1) Click the icon, select the [Edit] → [Cut Segment(T)] command, or press

the [Ctrl] + [x] keys.

>>The confirm dialog box appears.

(2) Click the [OK] button.

>>The selected segment is cut.

Handling Precautions
• Cut data is retained in the loader's memory. When using the cut

data for another segment, refer to the following descriptions:
● Inserting a copied or cut segment (see above)
● Pasting a segment (see page E27)

● Copying a segment
(1) Click the icon, select the [Edit] → [Copy Segment] command, or press

the [Ctrl] + [c] keys.

>>The confirm dialog box appears.

(2) Click the [OK] button.

>>The selected segment is copied.

Handling Precautions
•  The copied data is retained in the loader's memory. When using the

copied data for another segment, refer to the following descriptions:
● Inserting a copied or cut segment (see page E26)
● Pasting a segment (see below)

Chapter 3. METHODS OF OPERATION
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● Pasting a segment
(1) Click the icon, select the [Edit] → [Paste Segment] command, or press

the [Ctrl] + [v] keys.

>>The confirm dialog box appears.

(2) Click the [OK] button.

>>The segment is pasted.

Handling Precautions
•  Before pasting a segment, it is necessary to copy or cut a desired

segment.

•  Pasted values overwrite any values that were previously set.

•  Copied or cut values can be pasted any number of times.

● Clearing data
(1) Click the icon, or select the [Edit] → [Clear(A)] command.

>>The confirm dialog box appears.

(2) Click the [OK] button.

>>The set values are cleared.

Note
•  The clear command is used to return the set values to their default values.

Handling Precautions
•  When “Display OFF” is selected with setup data C68 to C71, the

program items of the main unit are not displayed, but rather the
program pattern window items of the SLP-P30.

■ Copying and pasting program patterns
Before using any program-pattern editing function, it is necessary to display a

target program pattern.

● Copying a program pattern
(1) Click the icon, or select the [Edit] → [Copy Pattern(Y)] command.

>>The confirm dialog box appears.

(2) Click the [OK] button.

>>The selected program pattern is then copied.

Handling Precautions
•  The copied data is retained in the SLP-P30 memory. When using the

copied data for another program pattern, refer to the following
description:
● Pasting a program pattern (see below)
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● Pasting a program pattern
(1) Click the icon, or select the [Edit] → [Paste Pattern(S)] command.

>>The confirm dialog box appears.

(2) Click the [OK] button.

>>The program pattern is pasted.

Handling Precautions
•  Before pasting a program pattern, it is necessary to copy a pattern.

When there are already values set for the program pattern, the
pasted values overwrite them. Copied pattern values can be pasted
any number of times.

■ Changing tags

● Changing a tag
(1) Double-click a tag text.

>>The tag is highlighted.

(2) Enter a desired tag through the keyboard.

(3) Press the [Enter] key.

Note
•  If any illegal character is entered, the tag name is returned to the previous

tag name. Only alphanumeric characters and symbols having an ASCII code

ranging from 20 to 5FH may be used. (see table on page E24.)

■ ASCII code table

Upper 3bits

Lower 4bits

0 1 2 3 4 5 6 7
0 NUL SLE space 0 @ P ' p
1 SOH CS1 ! 1 A Q a q
2 STX DC2 “ 2 B R b r
3 ETX DC3 # 3 C S c s
4 EOT DC4 $ 4 D T d t
5 ENQ NAK % 5 E U e u
6 ACK SYN & 6 F V f v
7 BEL EIB ´ 7 G W g w
8 BS CAN ( 8 H X h x
9 HT EM ) 9 I Y i y
A LF SIB * : J Z j z
B VT ESC + ; K [ k {
C FF FS , < L \ l |
D CR GS - = M ] m }
E SO RS . > N ^ n ~
F SI US / ? O _ o DEL

The shaded part (     ) is not used.



3  -  6 Displaying Graphs

■ Displaying program pattern graphs
Select [View] → [Pattern Graph] command.

>>The pattern graph of the selected program pattern is displayed.

■ Displaying input line graphs
Select [View] → [Table Graph] command.

>>The line graph is displayed.

Note
•  To select an area you want to enlarge, drag the mouse from the upper left

portion to the lower right portion of the area. If you drag the mouse in the

reverse direction, the enlarged graph scale is returned to its previous size.
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3  -  7 Data Check

E30

■ Checking the high and low limits of all data
Select [Edit] → [Data Check] command.

>>The data check begins.

■ Displaying items with abnormal values
If any setting error is found through the check of high and low data limits, an error

dialog box appears and the erroneous items are listed.

(1) Click the [OK] button in the error dialog box.

(2) Double-click a setup item you want to display in the error list.  The same

operation can also be performed by selecting (highlighting) a setup item you

want to display and pressing the [Enter] key.

>>The relevant setup item is displayed.

Note
•  The format of the error list is Serial No.: Setup group name: Item name:

Line No.  Additionally, when the setup group is the program, the setup

group name is displayed as Program - Program No.

Chapter 3. METHODS OF OPERATION
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4  -  1 Error Messages

■ Communications error messages

■ File error messages

Category Message Description Remedy

Communication Time out. The message could not be received Check the cable connections and
error within the time limit. contacts.

An instrument other than DCP31/32 Use the loader while it is connected to
might be connected. the DCP31/32.
The main unit might not be connected.

Cannot open communications port. The communication port could not be Do not run the loader and another 
opened. application that uses the

communication port at the same time.

Communications error has A system error occurred. Try again or quit the loader and 
occurred. restart Windows.

DCP Operating through the console or Other operation is running on the After quitting the other operation,
status error CPL communication. main unit or via CPL communication. try again.

Cannot be written since the mode The main unit is not READY. Put the main unit in the READY mode
is other than the READY mode. and try again.

Data, which cannot be written, After checking the mode of the main
exists since the mode is other unit, try again.
than the READY mode.

Cannot be written according to
the status of the instrument.

Check the currently connected Currently connected instrument is not Connect the DCP31/32 and start the
instrument. the DCP31/32, or the DCP31/32 is operation.

not connected.

Cannot support currently Versions of SLP-P30 or DCP31/32 Contact the azbil Group or your
connected DCP31/32. are not supported. dealer.

Category Message Description Remedy

File name This file name is not valid. An invalid file name has been Enter the correct file name.
error entered.

This file cannot be found. Make A non-existent file name has been Correctly enter the name and path of
sure that the correct path and entered, or the directory (folder) is an existing file.
file name are given. incorrect.

This file name is a reserved A file name reserved as a device Enter the correct file name.
device name. Use a different file name has been entered.
name.

Disk error Not enough free space on disk. There is not enough free space on Secure enough free space on disk.
disk.

The device is not ready. The disk is not prepared. Prepare a disk, and repeat the 
operation.

Cannot make file. The save destination might be a Save to a different destination.
CD-ROM.

File name too long. The file name is too long. Limit file names to 255 or fewer
characters.

Path name The path does not exist. An illegal path name has been Enter the correct path name, and
error Make sure that the correct path is entered. repeat the operation.

given.

File information Illegal file size. File is damaged. Damaged files cannot be used.

error Illegal file information. Recreate the file.
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■ Startup error messages
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Category Message Description Remedy

Loader system Can't start up two or more An attempt was made to start up Click the [OK] button.
error SLP-P30s at once. two or more SLP-P30s at once.
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Terms and Conditions
We would like to express our appreciation for your purchase and use of Azbil Corporation's products.
You are required to acknowledge and agree upon the following terms and conditions for your purchase of Azbil Corporation's
products (field instruments, control valves, and control products), unless otherwise stated in any separate document,
including, without limitation, estimation sheets, written agreements, catalogs, specifications and instruction manuals.

1. Warranty period and warranty scope
1.1 Warranty period

Azbil Corporation's products shall be warranted for one (1) year from the date of your purchase of the said
products or the delivery of the said products to a place designated by you.

1.2 Warranty scope
In the event that Azbil Corporation's products has any failure attributable to azbil during the aforementioned warranty
period, azbil shall, without charge, deliver a replacement for the said product to the place where you purchased, or
repair the said product and deliver it to the aforementioned place.
Notwithstanding the foregoing, any failure falling under one of the following shall not be covered under this warranty:

(1) Failure caused by your improper use of Azbil Corporation's products
(noncompliance with conditions, environment of use, precautions, etc. set forth in catalogs, specifications,
instruction manuals, etc.);

(2) Failure caused for other reasons than Azbil Corporation's products;
(3) Failure caused by any modification or repair made by any person other than azbil or azbil's

subcontractors;
(4) Failure caused by your use of Azbil Corporation's products in a manner not conforming to the intended

usage of that product;
(5) Failure that the state-of-the-art at the time of Azbil Corporation's shipment did not allow us to predict; or
(6) Failure that arose from any reason not attributable to Azbil Corporation, including, without limitation, acts

of God, disasters, and actions taken by a third party.
Please note that the term "warranty" as used herein refers to equipment-only-warranty, and Azbil Corporation
shall not be liable for any damages, including direct, indirect, special, incidental or consequential damages in
connection with or arising out of Azbil Corporation's products.

2. Ascertainment of suitability
You are required to ascertain the suitability of Azbil Corporation's products in case of your use of the same with
your machinery, equipment, etc. (hereinafter referred to as "Equipment") on your own responsibility, taking the
following matters into consideration:

(1) Regulations and standards or laws that your Equipment is to comply with.
(2) Examples of application described in any documents provided by Azbil Corporation are for your reference

purpose only, and you are required to check the functions and safety of your Equipment prior to your use.
(3) Measures to be taken to secure the required level of the reliability and safety of your Equipment in your use

Although Azbil Corporation is constantly making efforts to improve the quality and reliability of Azbil
Corporation's products, there exists a possibility that parts and machinery may break down.
You are required to provide your Equipment with fool-proof design, fail-safe design, anti-flame
propagation design, safety design, or the like so that the said Equipment may satisfy the level of the
reliability and safety required in your use, whereby preventing any occurrence of physical injuries, fires,
significant damage, and so forth.

3. Precautions and restrictions on application
Azbil Corporation's products other than those explicitly specified as applicable (e.g. azbil Limit Switch For Nuclear
Energy) shall not be used in a nuclear energy controlled area (radiation controlled area).
Any Azbil Corporation's products shall not be used for/with medical equipment.
In addition,
you are required to conduct a consultation with our sales representative and understand detail specifications,
cautions for operation, and so forth by reference to catalogs, specifications, instruction manual , etc. in case that
you intend to use Azbil Corporation's products for any purposes specified in (1) through (6) below.
Moreover, you are required to provide your Equipment with fool-proof design, fail-safe design, anti-flame
propagation design and other designs of protection/safety circuit on your own responsibility to ensure the
reliability and safety, whereby preventing problems caused by failure or nonconformity.

(1) For use under such conditions or in such environments as not stated in technical documents, including
catalogs, specification, and instruction manuals

(2) For use of specific purposes, such as:
* Nuclear energy/radiation related facilities

[For use outside nuclear energy controlled areas] [For use of Azbil Corporation's Limit Switch For
Nuclear Energy]

* Machinery or equipment for space/sea bottom
* Transportation equipment

[Railway, aircraft, vessels, vehicle equipment, etc.]
* Antidisaster/crime-prevention equipment
* Burning appliances
* Electrothermal equipment
* Amusement facilities

(3) Supply systems such as electricity/gas/water supply systems, large-scale communication systems, and
traffic/air traffic control systems requiring high reliability

(4) Facilities that are to comply with regulations of governmental/public agencies or specific industries
(5) Machinery or equipment that may affect human lives, human bodies or properties
(6) Other machinery or equipment equivalent to those set forth in items (1) to (5) above which require high

reliability and safety



4. Precautions against long-term use
Use of Azbil Corporation's products, including switches, which contain electronic components, over a prolonged
period may degrade insulation or increase contact-resistance and may result in heat generation or any other
similar problem causing such product or switch to develop safety hazards such as smoking, ignition, and 
electrification.
Although acceleration of the above situation varies depending on the conditions or environment of use of the
products, you are required not to use any Azbil Corporation's products for a period exceeding ten (10) years
unless otherwise stated in specifications or instruction manuals.

5. Recommendation for renewal
Mechanical components, such as relays and switches, used for Azbil Corporation's products will reach the end of
their life due to wear by repetitious open/close operations.
In addition, electronic components such as electrolytic capacitors will reach the end of their life due to aged
deterioration based on the conditions or environment in which such electronic components are used.
Although acceleration of the above situation varies depending on the conditions or environment of use, the
number of open/close operations of relays, etc.
as prescribed in specifications or instruction manuals, or depending on the design margin of your machine or
equipment, you are required to renew any Azbil Corporation's products every 5 to 10 years unless otherwise
specified in specifications or instruction manuals.
Field instruments (sensors such as pressure/flow/level sensors, regulating valves, etc.) will reach the end of their
life due to aged deterioration of parts.
For those parts that will reach the end of their life due to aged deterioration, recommended replacement cycles are
prescribed. You are required to replace parts based on such recommended replacement cycles.

6. Other precautions
Prior to your use of Azbil Corporation's products, you are required to understand and comply with specifications
(e.g., conditions and environment of use), precautions, warnings/cautions/notices as set forth in the technical
documents prepared for individual Azbil Corporation's products, such as catalogs, specifications, and instruction
manuals to ensure the quality, reliability, and safety of those products.

7. Changes to specifications
Please note that the descriptions contained in any documents provided by Azbil Corporation are subject to change
without notice for improvement or for any other reason.
For inquires or information on specifications as you may need to check, please contact our branch offices or sales
offices, or your local sales agents.

8. Discontinuance of the supply of products/parts
Please note that the production of any Azbil Corporation's products may be discontinued without notice.
For repairable products, we will, in principle, undertake repairs for five (5) years after the discontinuance of those
products. In some cases, however, we cannot undertake such repairs for reasons, such as the absence of repair
parts.
For field instruments, we may not be able to undertake parts replacement for similar reasons.



Specifications are subject to change without notice. (09)

1-12-2 Kawana, Fujisawa
Kanagawa 251-8522 Japan

URL: http://www.azbil.com
1st edition: Dec. 2004 (W)
11th edition: Apr. 2013 (F)
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